Yum Update HS sur installation neuve de Centos 5.9

Support général incluant les problèmes liés à l'installation.
Giulo92
Messages : 2
Inscription : 24 février 2014, 17:44

Yum Update HS sur installation neuve de Centos 5.9

Message par Giulo92 » 24 février 2014, 18:06

Bonjour a tous,

je suis nouveau sur Linuxavec quelques bases d'admins. En revanche je suis perdu et donc bloqué suite a cette nouvelle installation pour effectuer un 'yum update'

J'ai installé sur VMWare une distribution FAN 2.4 sur CentOS 5.9 mais une fois l'installation effectué et le paramétrage du réseau (IP Fixe, Mask, Gateway, DNS) renseigné, je n'arrive pas a effectuer la commande 'yum update'

Message d'erreur :

#yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 309, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 178, in main
result, resultmsgs = base.doCommands()
File "/usr/share/yum-cli/cli.py", line 345, in doCommands
self._getTs(needTsRemove)
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 101, in _getTs
self._getTsInfo(remove_only)
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 112, in _getTsInfo
pkgSack = self.pkgSack
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 662, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 502, in _getSacks
self.repos.populateSack(which=repos)
File "/usr/lib/python2.4/site-packages/yum/repos.py", line 232, in populateSack
self.doSetup()
File "/usr/lib/python2.4/site-packages/yum/repos.py", line 79, in doSetup
self.ayum.plugins.run('postreposetup')
File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/fastestmirror.py", line 176, in postreposetup_hook
if downgrade_ftp and _len_non_ftp(repo.urls) == 1:
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 686, in <lambda>
urls = property(fget=lambda self: self._geturls(),
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 683, in _geturls
self._baseurlSetup()
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 619, in _baseurlSetup
mirrorurls.extend(self._getMirrorList())
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1632, in _getMirrorList
print "Could not retrieve mirrorlist %s error was\n%s" % (url, e)
File "/usr/lib64/python2.4/codecs.py", line 178, in write
data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 202: ordinal not in range(128)

Je donne le résultat de la commande 'dig +short fr.centos.org' = 69.39.81.179

PS : j'ai un proxy possible a ajouter mais malgré ma config cela ne marche pas plus...
http_proxy=http://x.X.x.X:80

Si quelqu'un a une idée....Merci d'avance.

Beta-Pictoris
Messages : 952
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Yum Update HS sur installation neuve de Centos 5.9

Message par Beta-Pictoris » 24 février 2014, 21:19

Bonjour,

Aurais tu, par hasard ;) , installé plusieurs versions de Python sur ton système ?
Peux tu nous donner le résultat de rpm -qa 'python*' ?

tru
Messages : 203
Inscription : 20 octobre 2009, 09:30

Re: Yum Update HS sur installation neuve de Centos 5.9

Message par tru » 25 février 2014, 10:24

Giulo92 a écrit :Bonjour a tous,
...
File "/usr/lib64/python2.4/codecs.py", line 178, in write
data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 202: ordinal not in range(128)
bug "connu" mais corrigé http://bugs.centos.org/view.php?id=4025 et https://bugzilla.redhat.com/show_bug.cgi?id=442877

Giulo92
Messages : 2
Inscription : 24 février 2014, 17:44

Re: Yum Update HS sur installation neuve de Centos 5.9

Message par Giulo92 » 25 février 2014, 14:59

tru a écrit :
Giulo92 a écrit :Bonjour a tous,
...
File "/usr/lib64/python2.4/codecs.py", line 178, in write
data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 202: ordinal not in range(128)
bug "connu" mais corrigé http://bugs.centos.org/view.php?id=4025 et https://bugzilla.redhat.com/show_bug.cgi?id=442877
Merci a vous pour votre aide.

tru
Messages : 203
Inscription : 20 octobre 2009, 09:30

Re: Yum Update HS sur installation neuve de Centos 5.9

Message par tru » 25 février 2014, 22:41

Giulo92 a écrit :Bonjour a tous,

...

J'ai installé sur VMWare une distribution FAN 2.4 sur CentOS 5.9 mais une fois l'installation effectué et le paramétrage du réseau (IP Fixe, Mask, Gateway, DNS) renseigné, je n'arrive pas a effectuer la commande 'yum update'
...
PS : j'ai un proxy possible a ajouter mais malgré ma config cela ne marche pas plus...
http_proxy=http://x.X.x.X:80

Si quelqu'un a une idée....Merci d'avance.
1) FAN != CentOS, je ne sais pas dans quelle mesure FAN a modifié les dépots par défaut
2) ce n'est pas http_proxy qui est utilisé pour yum. Il *faut* mettre une ligne dans le fichier /etc/yum.conf avec par exemple:

Code : Tout sélectionner

proxy=http://mon.proxy:mon_port

Verrouillé