munin and lighttpd

Questions relatives à des problèmes logiciels.
pascalp
Messages : 17
Inscription : 20 octobre 2009, 15:35

munin and lighttpd

Message par pascalp » 16 novembre 2010, 11:24

Hi,

Quel imbecile, j'ai ecrit mon message en anglais... Je recommence.

J'ai installe munin et lighttpd depuis yum, munin est dans epel.

munin est configure et fonctionne. Seulement la generation des graphs a un probleme, le fichier n'est pas execute mais envoye au client tel quel.

ie, si je fait: curl https://munin.parois.net/cgi/munin-cgi- ... ps-day.png

j'obtient le script perl au lieu de mon image... Je n'arrive pas dire a lighttpd d'executer ce fichier...

Code : Tout sélectionner


$HTTP["host"] =="munin.parois.net" {
    $HTTP["scheme"] == "http" {
        url.redirect = ( "^/(.*)" => "https://munin.parois.net/$1")
    }

    $HTTP["scheme"] == "https" {
        server.document-root = "/var/www/html/munin"
        server.errorlog = "/var/log/lighttpd/error.log"

        fastcgi.server = ("/cgi/munin-fastcgi-graph" =>
            ("munin" =>
                ("socket" => "/tmp/munin-fastcgi.sock",
                 "bin-path" => "/var/www/html/munin/cgi/munin-fastcgi-graph",
                 "check-local" => "disable",
                )
            )
       )

      auth.backend = "htpasswd"
      auth.backend.htpasswd.userfile = "/home/debroglie/.htpasswd"
      auth.require = (
         "/" => (
             "method"  => "basic",
             "realm"   => "status",
             "require" => "valid-user"
         )
     )
     }
}


Verrouillé