Pas de son

Questions relatives à des problèmes matériels.
sakamalis
Messages : 30
Inscription : 13 décembre 2009, 23:04

Re: Pas de son

Message par sakamalis » 27 janvier 2010, 08:35

Code : Tout sélectionner

# ls -l /dev/dsp
crw-rw---- 1 root audio 14, 3 jan 27 07:29 /dev/dsp

# lsmod | grep snd
snd_hda_intel         427153  0 
snd_seq_dummy           7877  0 
snd_seq_oss            32577  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                49585  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            42817  0 
snd_usb_audio          77633  2 
snd_mixer_oss          19009  1 snd_pcm_oss
snd_usb_lib            19137  1 snd_usb_audio
snd_pcm                72133  3 snd_hda_intel,snd_pcm_oss,snd_usb_audio
snd_rawmidi            26561  1 snd_usb_lib
snd_timer              24517  2 snd_seq,snd_pcm
snd_seq_device         11725  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_page_alloc         14281  2 snd_hda_intel,snd_pcm
snd_hwdep              12869  2 snd_hda_intel,snd_usb_audio
snd                    55749  15 snd_hda_intel,snd_seq_oss,snd_seq,snd_pcm_oss,snd_usb_audio,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_timer,snd_seq_device,snd_hwdep
soundcore              11553  1 snd
pour le var/log/messages je verrais ce soir. Merci

Avatar de l’utilisateur
159645
Messages : 23
Inscription : 23 janvier 2010, 22:49

Re: Pas de son

Message par 159645 » 27 janvier 2010, 19:17

/dev/dsp appartient a root,
si tu utilise l'ordi avec un compte utilisateur, il faut vérifier que le compte fait bien parti du groupe audio.

sinon que donne
$ lspci -v | grep audio

tu peux aussi jeter un oeil ici pour voir si ta carte est bien supportee http://hardware4linux.info/

sakamalis
Messages : 30
Inscription : 13 décembre 2009, 23:04

Re: Pas de son

Message par sakamalis » 27 janvier 2010, 23:46

159645 a écrit : sinon que donne
$ lspci -v | grep audio
réponse à cette commande : rien

var/log/messages : je n'ai rien vu de particulier
j'ai lu plusieurs forums mais je m'y perds
précision : ma carte mère est une Asus P5V800-MX avec une puce audio intégrée SoundMax ADI1986

Avatar de l’utilisateur
159645
Messages : 23
Inscription : 23 janvier 2010, 22:49

Re: Pas de son

Message par 159645 » 28 janvier 2010, 11:42

Moi j'ai installe CentOs car avec Fedora ma carte son ne fonctionnait pas bien, ton matériel n'est peut être pas tres bien pris en charge.

Sinon tu peux essayer :
$ lspci -v | grep -i audio
ou
$ lspci -v
et tu cherche ta carte son

Bon courage, en attendant tu peux toujours chanter :(

sakamalis
Messages : 30
Inscription : 13 décembre 2009, 23:04

Re: Pas de son

Message par sakamalis » 28 janvier 2010, 23:47

Moi j'ai installe CentOs car avec Fedora ma carte son ne fonctionnait pas bien, ton matériel n'est peut être pas tres bien pris en charge.

Sinon tu peux essayer :
$ lspci -v | grep -i audio
ou
$ lspci -v
et tu cherche ta carte son

Bon courage, en attendant tu peux toujours chanter :(

Code : Tout sélectionner

...
02:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)
        Subsystem: ASUSTeK Computer Inc. Unknown device 818f
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at ff4fc000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [70] Express Legacy Endpoint IRQ 0
...
Merci 159645 de ton aide, je vais chercher encore un peu. Sinon je passe sous Fedora ou autre ... ou alors je change de matériel pour garder CentOS que je trouve super ! En attendant, effectivement je peux chanter ... :D

sakamalis
Messages : 30
Inscription : 13 décembre 2009, 23:04

Re: Pas de son

Message par sakamalis » 29 janvier 2010, 21:43

J'ai trouvé la solution tout seul ! :P

J'ai mis à jour le kernel, et hop ça roule ! Je peux écouter CD audio, DVD, et les clips internet sans souci. Plus de problème de son = résolu

Suffisait d'y penser ... et ça pourra toujours servir à d'autres.

Merci à ceux qui ont bien voulu m'aider, tout particulièrement 159645.

centux
Messages : 231
Inscription : 14 décembre 2009, 19:47

Re: Pas de son

Message par centux » 30 janvier 2010, 00:35

Bonsoir,

Quel est le N° de votre kernel?

Simple curiosité.

Voici le mien: 2.6.18-164.11.1.el5

Merci

sakamalis
Messages : 30
Inscription : 13 décembre 2009, 23:04

Re: Pas de son

Message par sakamalis » 30 janvier 2010, 09:21

Bonjour,

J'ai le même (2.6.18-164.11.1.el5).

Mais j'ai crié victoire trop tôt. Après redémarrage, même situation qu'avant : plus de son. Donc, pas sûr que les mises à jour aient changé quelque chose. Ma carte son doit présenter un problème avec CentOS (et peut-être avec d'autres distributions, je vais voir), aussi je laisse tomber. Pas bien grave, dans la mesure où j'ai le son sur un autre portable avec CentOS. C'est peut-être l'occasion pour moi de changer de carte-mère, probablement hors d'âge ! Dommage de devoir adapter le matériel à l'OS et non l'inverse ... Malgré ce désagrément, je reste intéressé par CentOS.
Encore merci aux différents intervenants.

Verrouillé