Installation imprimante

Questions relatives à des problèmes matériels.
Modrone
Messages : 5
Inscription : 19 août 2010, 23:18

Installation imprimante

Message par Modrone » 11 septembre 2010, 17:20

Bonjour d'un novice Linux

J'essaie d'installer ma nouvelle imprimante HP Photosmart B109n-z wifi.

L'installation se fait avec port USB pour le moment.

Dans CUPS, ce modèle n'existe pas.

La version recommandée d'HPLIP est 3.9.10 et la version de CentOS est 1.6.7.

J'installe la nouvelle version d'HPLIP mais elle n'est pas pris en compte.

J'essaie de trouver le fichhier .ppd sur le net pour contourner le problème d'HPLIP, mais je n'ai rien trouvé...

Comment puis-je faire pour installer mon imprimante ?

Merci par avance de votre aide !

Avatar de l’utilisateur
Heldwin
Messages : 440
Inscription : 20 octobre 2009, 10:11
Localisation : Unknown

Re: Installation imprimante

Message par Heldwin » 11 septembre 2010, 19:46

Hello

J'ai installé hplip 3.10.6 pour regarder. Il y a un ppd pour ton imprimante dedans.
Je ne sais pas si il est possible de ne pas l'utiliser qu'en usb sur linux, car sur linuxprinting ou hp on dirait que non.

Je ne sais pas trop si on peut utiliser ce ppd dans la version actuelle, mais tu peux essayer:
http://rapidshare.com/files/418466960/h ... ijs.ppd.gz

Modrone
Messages : 5
Inscription : 19 août 2010, 23:18

Re: Installation imprimante

Message par Modrone » 11 septembre 2010, 22:08

Merci pour le lien.

J'ai chargé le .ppd et l'ai transféré dans /usr/share, ne sachant pas où le mettre :oops:

J'ai pu terminé l'installation avec CUPS, mais je ne peux pas imprimer.

Lorsque j'allume l'imprimante, une fenêtre s'ouvre sur l'écran me disant :
"Vous venez de brancher une imprimante "HP Photosmart Wireless B109n-z". Le pilote approprié pour cette imprimante n'a pas été détecté. Veuillez sélectionner un pilote :"

Mais mon imprimante ne figure pas dans la liste... car pas dans HPLIP version 1.6.7 sûrement...

Peut-être ai-je déplacé le .ppd au mauvais endroit ?

Avatar de l’utilisateur
Heldwin
Messages : 440
Inscription : 20 octobre 2009, 10:11
Localisation : Unknown

Re: Installation imprimante

Message par Heldwin » 12 septembre 2010, 16:51

Le ppd était dans /usr/share/cups/model/HP , mais le dossier HP semble avoir été rajouté par le hplip 3.10.6 .
(il y a aussi un dossier /etc/cups/ppd/ , mais n'utilisant que des imprimantes réseaux supportées, je ne sais pas trop où le mettre sans faire un test moi-même).

Tu peux essayer de le mettre dans le dossier: model, ou peut-être créer le dossier: HP , et le mettre dedans.

Après, lance la commande: hp-setup , il le trouvera peut-être.
hp-check , pour regarder s'il y a un problème.

Tu peux aussi installer le dernier hplip, mais il faut supprimer 2 paquets avec --nodeps, pour pouvoir l'installer, à cause d'un conflit.

Modrone
Messages : 5
Inscription : 19 août 2010, 23:18

Re: Installation imprimante

Message par Modrone » 14 septembre 2010, 00:19

J'ai installé la nouvelle version de hplip après avoir supprimé la version ancienne et slon les infos trouvées ici : http://bashukhan.com/installing-hplip-3 ... m1120-mfp/.

L'imprimante fonctionne !

Pour le scan, je dois le lancer depuis le terminal averc XSANE. Si je le lance depuis le bureau (Applications -> Graphisme) le scanner n'est pas reconnu...

Si tu as des idées, je suis preneur.

Merci d'avance.

Verrouillé