Mise en place d'un serveur de fax

Questions relatives à des problèmes matériels.
poueted
Messages : 6
Inscription : 06 octobre 2010, 07:10

Mise en place d'un serveur de fax

Message par poueted » 06 octobre 2010, 07:40

Bonjour tout le monde,

Devant faire face à l'achat de super-licences d'un serveur de fax, je me suis dis que ce serait pas mal d'essayer ce qu'il existe en GPL avant de donner des sous pour acheter un soft tout bugé et restreint au minimum acceptable, le tout pour un prix maximal.

Etant habitué à Ubuntu, j'ai voulu voir ce qu'il y avait a coté, et donc opté pour CentOS.
J'ai donc monté un petit serveur sous CentOS 5.5, y ai calé les toujours utiles OpenSSH, Samba et MySQL, qui marchent à merveille.

Et voilà que je me lance dans Hylafax, avec l'aide d'un tuto, car je ne suis pas très expérimenté dans le monde linuxien.

Et je bloque ! Car je ne sais pas comment tester les diverses parties...
Par exemple, mon modem permettant d'envoyer les fax est branché via port série, port série situé sur une carte pluggée en PCI, et je ne sais pas trop comment vérifié à la fois que CentOS dialogue bien avec la carte, et que la carte dialogue bien avec le modem...

ls -l /dev | grep ttyS me donne :

crw-rw-rw- 1 root uucp 4, 64 oct 6 06:31 ttyS0
crw-rw-rw- 1 root uucp 4, 65 oct 6 06:31 ttyS1
crw-rw-rw- 1 root uucp 4, 66 oct 6 06:21 ttyS2
crw-rw-rw- 1 root uucp 4, 67 oct 6 06:21 ttyS3
-rw-rw-rw- 1 root root 15 oct 6 06:31 ttyS4
-rw-r--r-- 1 root root 15 oct 6 06:32 ttyS5

Comme si il y avait 6 ports série ?!? à moins que les ttySn ne désignent d'autres E/S ?

j'ai essayé aussi "echo ATDTnum_tel > /dev/ttyS0", avec num_tel représentant un numéro de téléphone (google m'a expliqué que c'était censé appeller le numéro de tèl indiqué), rien ne se passe (je n'entend pas le modem numéroter), et je ne sais pas où trouver des logs pouvant me donner des informations.

En gros, c'est le brouillard !

Si quelqu'un aurait des informations, ou des expériences à faire partager, merci !

Avatar de l’utilisateur
nouvo09
Messages : 2001
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Mise en place d'un serveur de fax

Message par nouvo09 » 06 octobre 2010, 08:27

Un port série tu dois l'initialiser avant de l'utiliser, tu n'as aucune chance en procédant de la sorte.

Essaie d'utiliser le programme minicom par exemple.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

poueted
Messages : 6
Inscription : 06 octobre 2010, 07:10

Re: Mise en place d'un serveur de fax

Message par poueted » 07 octobre 2010, 08:51

Salut,
Merci à toi pour ta réponse, ça m'a beaucoup aidé !

Ca m'a permis de bien vérifier que les différents composants fonctionnaient.

Pour Hylafax, il me manquait juste un processus à lancer au démarrage.

A+

Verrouillé