Plantages répétitifs de Centos 5

Questions relatives à des problèmes matériels.
Soleille
Messages : 16
Inscription : 20 octobre 2009, 09:47

Plantages répétitifs de Centos 5

Message par Soleille » 23 décembre 2010, 20:16

Bonjour ! :)

J'ai installé Centos 5 sur un PC mais l'écran finit toujours par "geler" et je dois rebooter manuellement.

Cela peut arriver n'importe quand, très souvent quand l'ordinateur "travaille" : quand je fais une mise à jour importante (un "yum update" juste après l'installation par exemple) et en ce moment je n'arrive pas à installer Ubuntu sur VirtualBox (je n'arrive pas au bout de l'installation, ça plante).

Je pense que le problème est d'origine matérielle (configuration dans le BIOS ?) car si j'installe Windows XP je n'ai pas de soucis...

J'ai déjà changé :
- les barettes mémoire (RAM)
- le disque dur
- le lecteur de DVD
et j'ai essayé en mettant une nouvelle carte vidéo (GForce FX5200).

Mais rien à faire : les problèmes continuent.

Maintenant, je tourne avec :
- une carte mère que je ne connais pas... (je ne sais pas comment trouver son nom)
- un processeur Intel(R) Pentium(R) D 3,40 Ghz
- la vidéo et le son intégrés à la carte mère
- un disque dur Maxtor de 160 Giga.
- deux barettes de 1 Giga.

Je n'ai pas un très bon niveau en informatique, mais :
- auriez-vous des conseils à me donner ?
- serait-il possible de trouver l'origine du problème, par exemple dans des fichiers logs (lesquels ?)

Merci pour votre aide, :)

Avatar de l’utilisateur
nouvo09
Messages : 1969
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Plantages répétitifs de Centos 5

Message par nouvo09 » 24 décembre 2010, 00:30

Si c'est un problème matériel, il y a peu de chances que les log t'apprennent quelque chose

mais regarde quand meme dans

/var/log/messages

aussi dans

/var/log/Xorg.0.log pour le serveur X
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Soleille
Messages : 16
Inscription : 20 octobre 2009, 09:47

Re: Plantages répétitifs de Centos 5

Message par Soleille » 26 décembre 2010, 08:48

Effectivement, je n'ai pas trouvé de messages d'erreur et je ne comprends pas tout ce qui y est écrit d'ailleurs...
Il ne me reste plus qu'à changer ma carte mère ou à attendre l'achat d'un nouvel ordinateur.

Merci pour ton aide. :)

danieljp
Messages : 10
Inscription : 13 septembre 2010, 10:55

Re: Plantages répétitifs de Centos 5

Message par danieljp » 02 janvier 2011, 11:52

Bonjour,

Je ne suis pas non plus un expert en informatique mais, avant de tout changer, il serait bon de savoir quelle était la configuration matérielle initiale de l'ordinateur.
Je m'explique : Appareil monté par ses soins et à l'aide de quelles pièces (carte mère, type de processeur, type de carte graphique).
Appareil acheté "clé en main" chez revendeur ou grande surface ; dans ce cas il faudrait nous donner (quand on a peut de connaissances informatiques) le nom du fabricant et le type de modèlede l'ordinateur, par ex : HP Pavillon a6005.fr ou Compaq Présario 5260 (Ce sont ici d'ancien modèles en ma possession, mais qui marchent toujours).
Dans ces deux cas cela permettrait à la personne voulant t'aider de se faire une idée de ton matériel et de peut être voir les problèmes pouvant se manifester.
Généralement et quel que soit le problème posé il est toujours bon de donner le type de matériel et le type de distribution que l'on utilise cela facilite le diagnostique.
Dans ton cas, tu explique que tu as le problème sur CentOS 5.0 mais pas sous Windows XP. Déjà, là cela pose un problème car même si on est un amoureux fou de la marque de Redmond que la panne se répare si l'ordinateur tourne sous Win. XP éloigne plutôt d'un diagnostique de panne matériel et orienterait plus vers un problème de configuration du logiciel(drivers mal reconnu, etc..).
Dans ton cas le plus simple pour voir si la panne est uniquement liée à la distribution Centos 5.0 ; ce serait dans la mesure du possible pour faire un test d'installer une autre distribution sur ton ordinateur.
Je me permettrais de te suggérer Ubuntu, que ce soit la version 9.04, 9.10, 10.04 ; on peut la télécharger sur différents sites dont Ubuntu-fr et ils y a des forums très conviviaux. De plus c'est une des plus simples à utiliser et des plus documentée. Un autre moyen de se procurer la distribution est d'acheter une revue ( le disque est avec) dans une maison de la presse et chez certains buralistes (ceux ayant un bon rayon presse). Vendue même dans certains hypermarchés.(Il y a aussi Debian, Fédora' Mandriva et j'en passe).
Si la panne ne se manifeste pas là non plus, il y a de très grandes chances que tu puisse abandonner la panne matérielle. A mon avis c'est le meilleur test que tu puisse faire tant au niveau matériel que logiciel.

PS: Ceci est important : Sous Win. XP en allant dans fichiers de configurations il y a un endroit ou on peut voir la config entiére de l'ordinateur et là tu pourras relever les valeurs de ton matériel, processeur, mémoire, carte graphique. Je suis désolé de ne pas être plus précis, mais cela fait un moment que je ne suis plus sous Windows et j'avoue que j'ai oublié ou çà se trouve dans le tableau de configuration.
Chaque erreur permet d'apprendre. Bon courage et donne nous le résultat.

Daniel.

Avatar de l’utilisateur
nouvo09
Messages : 1969
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Plantages répétitifs de Centos 5

Message par nouvo09 » 02 janvier 2011, 14:05

A mon avis une panne logicielle provoquerait l'écriture de messages d'erreur dans les fichiers adéquats

au pire, un coredump.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Soleille
Messages : 16
Inscription : 20 octobre 2009, 09:47

Re: Plantages répétitifs de Centos 5

Message par Soleille » 02 janvier 2011, 14:06

Bonjour, :)

Merci pour tous ces conseils et informations.

J'avais déjà essayé effectivement d'installer Ubuntu et Debian en plus de Centos et j'avais toujours les mêmes plantages... Au final, j'ai remis Windows XP sur cette machine.

J'ai installé Centos et les autres systèmes Linux sur un autre PC et... ça roule. :)

Avatar de l’utilisateur
nouvo09
Messages : 1969
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Plantages répétitifs de Centos 5

Message par nouvo09 » 02 janvier 2011, 15:40

Je penche pour un souci de mémoire, dans la mesure où le noyau linux et le noyau windows ne gèrent pas du tout cette mémoire de la même manière.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

danieljp
Messages : 10
Inscription : 13 septembre 2010, 10:55

Re: Plantages répétitifs de Centos 5

Message par danieljp » 02 janvier 2011, 17:04

Bonjour,

Effectivement, le renseignement important ici était que cela se produisait quelle que soit la distribution.
J'ai moi-même été victime de deux plantages de cette sorte et je vais essayé d'en décrire un correspondant au diagnostique général et ressemblant fortement à ce qui m'est arrivé.
Un beau jour, j'ai décidé d'acheter cher un revendeur un ordinateur dans un boitier moyen tour équipé d'une carte mère P45 NEO FR, d'un processeur Intel Q9550 et d'une carte graphique Nvidia GeForce 9800 GTX+. Ma distribution était une Ubuntu soit 8.04 ou 9.04. Garantie de l'objet un an.
Pendant 6 à 7mois tout a bien marché, puis à partir d'un beau matin, l'ordinateur se lance ; le voyant signalant le fonctionnement du disque clignote bien et on reste figé plus moyen d'accéder à qoi que ce soit. Redémarrage manuel et l'ordinateur repart comme si de rien n'était. Ce blocage se produisant plusieurs fois de suite au cours du même démarrage j'ai ramené l'appareil et expliqué mon prolème.
Changements : alim, carte mère, mémoire rien n'y a fait. A un moment (je ne sais comment) ils ont quand même déterminé que le problème venait de la mèmoire. Là j'espère que je vais être assez explicite :
Sur la carte mère P45 NEO FR il y a 4 slots mémoire, 2 vert et 2 orange. J'ai deux barrettes de 2Gio de mèmoire.
Si j'ai bien compris (c'était la façon dont c'était monté en première instance) mes deux barretes devaient être montée sur les deux slots vert. Apparemment c'est de là que venait le problème.
Pour rectifier le problème le premier slot vert et le premier slot orange ont été utilisés et depuis je n'ai plus jamais eu de problème.
Le problème mémoire est la version officielle qui m'a été donnée à la récupération de mon matériel et vu le chagement de slot je n'ai pas trop de raison d'en douter.
J'avoue que je n'ai pas pu avoir plus d'explications.

Daniel.

Verrouillé