Connexion coupé après un temps d'inactivité

Questions relatives à la gestion du réseau.
Cehz
Messages : 6
Inscription : 05 juin 2013, 10:36

Connexion coupé après un temps d'inactivité

Message par Cehz » 10 juin 2013, 09:17

Bonjour,

Je suis actuellement en stage de BTS Informatique (Première année) et je me retrouve dans une situation problématique.
Durant mon stage j'ai pour objectif de virtualiser un serveur physique CentOS sur un Hyper-V, jusque ici aucun soucis, j'ai installé mon OS, configuré mes services (Apache2, MySQL, PHP...), installé des services complémentaires comme DokuWiki (bientôt Cacti) et tout cela fonctionne jusqu'à un certain moment !

Je m'explique, au bout d'un certain temps d'inactivité sur la VM je ne peux plus y avoir accès, le réseau se coupe !
L'accès SSH (via Putty) me donne un message du type "Connection timed out", je ne peu plus pinger la machine depuis Windows et en me connectant en RDP je ne peu pas pinger d'autres machines depuis la VM en question.

J'ai fait quelques recherches sur le sujet mais je ne trouve rien de similaire, à part peut être une sorte de "veille" de la machine, mais aucun rapport avec le réseau ?

Pour information je n'ai aucun part-feu en place et Selinux est désactivé.


Cordialement.

Avatar de l’utilisateur
nouvo09
Messages : 1955
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Connexion coupé après un temps d'inactivité

Message par nouvo09 » 10 juin 2013, 11:29

Salut,

Lorsque le réseau ne répond plus sur ton système invité, au même moment sur le système hôte, il fonctionne correctement ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Cehz
Messages : 6
Inscription : 05 juin 2013, 10:36

Re: Connexion coupé après un temps d'inactivité

Message par Cehz » 10 juin 2013, 14:13

Et bien non justement, je ne peux ni entrer ni sortir de mon système hôte (Test avec des pings entrants et sortants).

On m'a parler de l'ACPI qui pourrais couper ma connexion après un certain temps d'inactivité, je vais étudier ce sujet, je vous tiens au courant !

Edit : J'ai désactivé l'ACPI via la commande chkconfig, mais les déconnexions on l'air de reprendre.

Cordialement.

Avatar de l’utilisateur
nouvo09
Messages : 1955
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Connexion coupé après un temps d'inactivité

Message par nouvo09 » 10 juin 2013, 18:50

Bon j'ai du mal comprendre alors. Précise ta config:

quel est l'OS hôte et quel est l'OS invité ?

plus pour l'hôte, le modèle de la carte réseau.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Cehz
Messages : 6
Inscription : 05 juin 2013, 10:36

Re: Connexion coupé après un temps d'inactivité

Message par Cehz » 11 juin 2013, 09:02

J'ai écrit un peu vite, en fait oui mon système hôte est toujours fonctionnel niveau réseau car il y a déjà 11 autres VM dessus qui fonctionnent sans coupure.

Le système hôte est un hyper-v tournant sous Windows Serveur 2012.

Mon système invité est un serveur CentOS (release 5.4 Final) en x86_64

Le uname -a me renvois les informations suivantes :
Linux eurocactivm.mondomaine.com 2.6.18-164.el5 #1 SMP Thu Sep 3 03:28:30 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Avatar de l’utilisateur
nouvo09
Messages : 1955
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Connexion coupé après un temps d'inactivité

Message par nouvo09 » 11 juin 2013, 12:23

Lorsque ton réseau est planté, que renvoie un

ifconfig

?

Accessoirement, je comprends mal l'utilité d'un OS 64 bits sur une VM.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Cehz
Messages : 6
Inscription : 05 juin 2013, 10:36

Re: Connexion coupé après un temps d'inactivité

Message par Cehz » 11 juin 2013, 13:51

Voilà ce que renvois la commande "ifconfig"

Image

Pense tu que le 64 bits ai un rapport avec ce bug ?

Avatar de l’utilisateur
nouvo09
Messages : 1955
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Connexion coupé après un temps d'inactivité

Message par nouvo09 » 11 juin 2013, 15:55

Cehz a écrit :Voilà ce que renvois la commande "ifconfig"

Pense tu que le 64 bits ai un rapport avec ce bug ?
Il n' a pas d'option particulière dans le fichier /etc/sysconfig/network-scripts/ifcfg-eth0 ?

Pour ce qui concerne le 64 bits aucune idée, je n'en ai jamais installé, et comme j'imagine que tu n'as pas attribué plus de 4 Go de ram à ta VM, l'intérêt essentiel du 64 bits disparait.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Cehz
Messages : 6
Inscription : 05 juin 2013, 10:36

Re: Connexion coupé après un temps d'inactivité

Message par Cehz » 12 juin 2013, 08:37

Je ne savais pas pour le 64 bits.

Ma configuration de ifcfg-eth0 n'a rien de spécial, elle ressemble à la plupart des configuration de carte réseaux.

Image

J'ai peut être trouvé d'où viens le problèmes, lors de la création de ma VM j'ai ajouté / utilisé une "carte réseau héritée" (Mon tuteur me l'a conseillé pour des questions de compatibilités).

J'ai essayé de changer cette carte réseau héritée en carte réseau classique, l'hyper-v lui attribue alors une nouvelle adresse MAC en dynamique mais la VM ne créée pas de configuration "ifcfg-eth1", est-ce normal ?

J'ai ensuite essayé de modifier l'adresse MAC dans ma configuration mais lors de l'utilisation de la commande "service network restart" le message "Le périphérique eth0 à une adresse MAC différente de celle attendue, opération ignorée" s'affiche.

PS : J'ai aussi créé une configuration eth1 avec les même propriétés, le résultat reste le même.

Cordialement.

Avatar de l’utilisateur
nouvo09
Messages : 1955
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Connexion coupé après un temps d'inactivité

Message par nouvo09 » 12 juin 2013, 11:03

moi j'effacerais tous les fichiers de config ifcfg-eth* (ou renommerais ou déplacerais) et je créerais une nouvelle config avec system-config-network
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Verrouillé