[RESOLU] SFTP

Questions relatives à la gestion des services.
Avatar de l’utilisateur
Pierro
Messages : 7
Inscription : 03 décembre 2009, 22:14
Localisation : Toulon - Var - France

[RESOLU] SFTP

Message par Pierro » 14 juin 2010, 21:03

Bonsoir,

Je suis coincé sur sftp. Je recherche des infos sur ce module d' openssh.

Mon authentification est bonne avec mon utilisateur via SSH mais WinSCP ne se connecte pas.
Celui ci me demande de vérifier si sftp tourne hors comme il est appelé me semble t il par sshd je suis bloqué. Si quelqu'un a une piste je suis preneur.

Merci par avance,

EDIT : Voir en bas de page mon post.
Dernière modification par Pierro le 15 juin 2010, 22:22, modifié 3 fois.
Pierro.
"Un jour les geeks domineront le monde, mais pas demain, demain c'est LAN. :)"

Avatar de l’utilisateur
nouvo09
Messages : 2045
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: sftp

Message par nouvo09 » 14 juin 2010, 22:56

Pierro a écrit :Bonsoir,

Je suis coincé sur sftp. Je recherche des infos sur ce module d' openssh.

Mon authentification est bonne avec mon utilisateur via SSH mais WinSCP ne se connecte pas.
Celui ci me demande de vérifier si sftp tourne hors comme il est appelé me semble t il par sshd je suis bloqué. Si quelqu'un a une piste je suis preneur.

Merci par avance,
Tu as vérifie le mode d'emploi de winscp ?

Ta clé a été créée ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Avatar de l’utilisateur
Pierro
Messages : 7
Inscription : 03 décembre 2009, 22:14
Localisation : Toulon - Var - France

Re: sftp

Message par Pierro » 15 juin 2010, 08:00

Bonjour,

Il ne me semble pas que cela vienne de là car j'ai plusieurs CentOS dans mon parc et seule une machine refuse la connexion. Je vais fouiller de ce cote là et je repost.

Merci de votre aide.
Pierro.
"Un jour les geeks domineront le monde, mais pas demain, demain c'est LAN. :)"

MarbolanGos
Messages : 341
Inscription : 26 octobre 2009, 19:03

Re: sftp

Message par MarbolanGos » 15 juin 2010, 10:18

Sur la connexion en ssh essaye de fair eun mode verbose sur la machine qui marche pas et sur une machine qui marche.
En regardant la différence tu verras peut être une différence dans la configuration.
http://rarebril.com/blog
http://www.smolts.org/client/show/pub_d44745d4-fc38-4d31-a94c-499e6e1838ea

Avatar de l’utilisateur
Pierro
Messages : 7
Inscription : 03 décembre 2009, 22:14
Localisation : Toulon - Var - France

Re: sftp

Message par Pierro » 15 juin 2010, 10:42

MarbolanGos a écrit :Sur la connexion en ssh essaye de fair eun mode verbose sur la machine qui marche pas et sur une machine qui marche.
En regardant la différence tu verras peut être une différence dans la configuration.
Bonjour, j'ai fait bien pire. J'ai fait un copier/coller du /etc/ssh/sshd_config et ... ça reste KO

Je vais activer et fouiller les logs.

Merci de vos aides en tous cas,
Pierro.
"Un jour les geeks domineront le monde, mais pas demain, demain c'est LAN. :)"

MarbolanGos
Messages : 341
Inscription : 26 octobre 2009, 19:03

Re: sftp

Message par MarbolanGos » 15 juin 2010, 20:32

Pour tester avec un autre logiciel essaye de faire du sftp avec filezilla. Il aura peut-être un peu plus de "verbosité".
http://rarebril.com/blog
http://www.smolts.org/client/show/pub_d44745d4-fc38-4d31-a94c-499e6e1838ea

Avatar de l’utilisateur
Pierro
Messages : 7
Inscription : 03 décembre 2009, 22:14
Localisation : Toulon - Var - France

Re: SFTP

Message par Pierro » 15 juin 2010, 22:14

Bonsoir,

Je suis un empoté. Je vous présente mes excuses pour ce post.
Mes problèmes venaient de WinSCP. Il semble que les clés ont "merdouillées" lors de la 1er connexion.
J'ai donc supprimé les fichiers :
ssh_host_dsa_key
ssh_host_dsa_key.pub
ssh_host_key
ssh_host_key.pub
ssh_host_rsa_key
ssh_host_rsa_key.pub

de /etc/ssh.

et un petit "service sshd restart".

J'espère au moins que ce post aidera une autre personne.

En tous cas, Grand merci de vos post. Et encore toutes mes excuses.
Pierro.
"Un jour les geeks domineront le monde, mais pas demain, demain c'est LAN. :)"

Avatar de l’utilisateur
nouvo09
Messages : 2045
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: [RESOLU] SFTP

Message par nouvo09 » 15 juin 2010, 23:34

Oui, je pressentais le problème de clé !

tant mieux si c'est réglé alors!
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Avatar de l’utilisateur
Pierro
Messages : 7
Inscription : 03 décembre 2009, 22:14
Localisation : Toulon - Var - France

Re: [RESOLU] SFTP

Message par Pierro » 16 juin 2010, 11:52

nouvo09 a écrit :Oui, je pressentais le problème de clé !

tant mieux si c'est réglé alors!
Bonjour,

Pour la clé : ouais j'veux bien mais peuvent pas documenter un peu ?! GRRrrr.
Pour Info : J'ai trouvé ma solution avec WireShark en regardant un peu les flux qui avaient l'air logiques. Donc dit que mon daemon était bien lancé quand il le devait donc je me suis dit que la phase d'apres c'etait les cles ... Le site d'openssh est bien foutu. En tous cas merci à tous :)

@micalement,
Pierro.
"Un jour les geeks domineront le monde, mais pas demain, demain c'est LAN. :)"

MarbolanGos
Messages : 341
Inscription : 26 octobre 2009, 19:03

Re: [RESOLU] SFTP

Message par MarbolanGos » 16 juin 2010, 12:50

Je pense qu'en passant par filezilla il aura donné clairement l'erreur des clefs. Je dis ça... Je dis rien :mrgreen:
http://rarebril.com/blog
http://www.smolts.org/client/show/pub_d44745d4-fc38-4d31-a94c-499e6e1838ea

Verrouillé