[Samba] Problem SMB posix open, disabling posix open support

Questions relatives à des problèmes logiciels.
Avatar de l’utilisateur
Heldwin
Messages : 440
Inscription : 20 octobre 2009, 10:11
Localisation : Unknown

[Samba] Problem SMB posix open, disabling posix open support

Message par Heldwin » 02 mars 2010, 12:08

Hello

Je suis en train de me configurer un poste de travail Fedora, mais j'ai un problème pour utiliser les partages samba qui se trouvent sur un serveur centos (oui je sais que c'est pas terrible d'utiliser un protocole windows entre un serveur et client Linux, mais bon... :))

Sous root, aucun problème. Mais bon c'est un peu normal je pense, car il s'approprie les droits complets sur le partage ^^ Le problème ne se passe que pour un utilisateur normal. Je peux créer des fichiers, aller dans les dossiers dans lesquels j'ai le droit, mais je ne peux pas ouvrir des fichiers existants ou même que j'ai créés 1 seconde plus tôt. Ce problème de lecture semble être un problème connu et corrigé mais on dirait pas dans la version samba sur 4.X.

Je suis en train de chercher, mais j'ai un peu de peine à trouver des rpm samba plus récents que 3.0.33-0.18 , et il semblerait que ça a été corrigé un peu après mais pour 5.X (https://bugzilla.redhat.com/show_bug.cgi?id=493728 et http://rhn.redhat.com/errata/RHBA-2009-1416.html)

En tout cas, voici le message d'erreur:
kernel: CIFS VFS: server xxx.xxx.xxx.xxx of type Samba 3.0.33-0.18.el4_8.1 returned unexpected error on SMB posix open, disabling posix open support. Check if server update available.
Quelqu'un a déjà rencontré ce problème sur centos 4.X, ou a une info qui pourrait être utile ?
Merci

Avatar de l’utilisateur
Heldwin
Messages : 440
Inscription : 20 octobre 2009, 10:11
Localisation : Unknown

Re: [Samba] Problem SMB posix open, disabling posix open support

Message par Heldwin » 04 mars 2010, 14:32

On dirait que ça ne fait ça que si le propriétaire du fichier ou du dossier n'est pas connu et est représenté uniquement par son uid. Si je suis le propriétaire du fichier, aucun problème.

Pourtant je suis dans le même groupe (et même gid) et le groupe a les droits rwx (autant sur le dossier que sur le fichier...). Il doit y avoir un droit samba manquant quelque part qui crée ce problème...

Je me vois mal répliquer tous les utilisateurs sur les postes linux ...

EDIT:

En y repensant, si le poste linux ne connaît pas le nom utilisateur, c'est que samba ne lui a pas fourni, mais je n'ai aucune idée si c'est volontaire ou si c'est un problème de jonction au domaine.

Comme dit précédemment, je sais que Samba n'est pas adapté pour du Linux-Linux, mais il n'y a qu'un poste linux (le mien ^^) et comme c'est fonctionnel à 90% ... J'ai espoir de faire fonctionner ça :)

Verrouillé