Page 1 sur 1

erreur iperf

Publié : 20 mars 2014, 15:46
par mcyann
Bonjour,
J'interviens de temps en temps sur un serveur nagios qui a priori tourne sous cent os 4 ou red hat (mais j'ai un doute). Un cat/proc/version me donne :
Linux version 2.6.18-274.3.1.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-51)) #1 SMP Tue Sep 6 20:14:03 EDT 2011

Je ne suis pas un pro de linux, j'ai un problème avec un logiciel Iperf qui fait des test sur la bande passante wan et qui ne fonctionne plus depuis 15 jours.
J'ai voulu le mettre a jour, mais depuis j'ai cette erreur : iperf: /lib/libc.so.6: version `GLIBC_2.7' not found (required by iperf)

Est-ce que vous auriez une idée??
Merci d'avance

Re: erreur iperf

Publié : 20 mars 2014, 20:26
par Beta-Pictoris
Ta version d'iperf a besoin de la glibc 2.7. Or ton système doit disposer d'une version plus ancienne de la glibc.

Re: erreur iperf

Publié : 21 mars 2014, 09:48
par mcyann
Bonjour,
Oui, je m'en suis douté, j'ai donc essayé de mettre a jour avec cette commande : yum install libc.so.6, mais j'ai toujours la même erreur.

Est-ce que vous auriez une idée?
Merci d'avance

Re: erreur iperf

Publié : 21 mars 2014, 20:09
par Beta-Pictoris
mcyann a écrit :j'ai donc essayé de mettre a jour avec cette commande : yum install libc.so.6, mais j'ai toujours la même erreur.
Hé non ! Ca ne marche pas comme ça. :lol:

Si tu veux faire tourner ta version d'iperf, tu dois, d'abord, récupérer les sources de la glib 2.7, les compiler et installer les binaires quelque part.

Re: erreur iperf

Publié : 25 mars 2014, 11:53
par tru
Ton kernel 2.6.18-* indique une CentOS-5, mais pas du tout à jour... la version devrait être: 2.6.18-371.6.1.el5.
Récupère iperf pour CentOS-5 (glibc-2.5) et non pas pour une autre distrib, par exemple chez EPEL (iperf-2.0.5-1.el5 ou iperf3-3.0.1-1.el5)