Page 1 sur 1

OCS inventory CentOS6.4 [ Apache2::SOAP is not installed ! ]

Publié : 28 mai 2013, 11:36
par mickadark
Bonjour à tous,

j'effectue l'installation de OCS inventory sur CentOS 6.4 64bits sur une VM sous ESXI 5.0 et mon soucis est :
dès quand je lance l'installation de OCS, je me retrouve avec un message me signalant que le module SOAP n'est pas installé :

Checking for Apache2::SOAP PERL module...
*** Warning: PERL module Apache2::SOAP is not installed !
This module is only required by OCS Inventory NG SOAP Web Service.
Do you wish to continue ([y]/n]


Les commandes que j'ai effectué :

yum install perl-XML-Simple
yum install perl-Apache-DBI
yum install perl-XML-Entities
yum install perl-Net-IP
yum install perl-Apache2-SOAP
yum install mod_perl


ensuite j'ai fait un "yum search Apache2-SOAP" et j'obtient :

=============== N/S Matched: Apache2-SOAP ======================

perl-Apache2-SOAP.noarch : A replacement for Apache::SOAP designed to work with
: mod_perl 2


d'après ce que je comprend il faut que j'effectue un remplacement du module Apache::SOAP pour qu'il fonctionne avec mod-perl 2 ?

Je suis bloqué ici, et je ne vois pas du tout ce qu'il faut faire

Merci d'avance,

Lien de OCS :
https://launchpad.net/ocsinventory-serv ... rc1.tar.gz

Re: OCS inventory CentOS6.4 [ Apache2::SOAP is not installed

Publié : 30 mai 2013, 12:20
par remi
Comme souvent.... sur une distribution RPM, on installe des RPM.

ocsinventory est dans EPEL (version ancienne liée aux stratégies de mises à jour d'une distribution enterprise)
Toutes les dépendances sont disponible et tirées comme il se doit par le paquet principal.

Un backport de la version 2.0.5 est dispo dans mon dépôt.