erreurs retournées par tar

Avatar de l’utilisateur
nouvo09
Messages : 2159
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

erreurs retournées par tar

Message par nouvo09 » 29 juin 2013, 10:38

Depuis bien longtemps j'utilise tar pour sauvegarder mes systèmes et comme j'ai plusieurs versions sur la même machine, je sauvegarde les unes à partir des autres.

Cette fois j'ai voulu faire une sauvegarde de ma partition système Fedora 15 depuis Centos 6, comme d'habitude avec la commande:

Code : Tout sélectionner

time tar cvfW /dest/Fedora15-23.tar * --selinux --exclude=home/user/dwhelper/* --exclude=*.avi --exclude=tmp/* --exclude=home/user/.mozilla/firefox/z8hlui7s.default/Cache --exclude=home/user/.thumbnails
Or, pour la première fois, tar me renvoie des erreurs au moment de la vérification, me disant que l'UID, ni le GID et le mode sont différents.

J'ai donc tenté la même opération, en bootant cette fois sur Fedora12, et je n'ai aucune erreur, le fichier tar est identique en taille à celui produit par Centos (et j'ai bêtement oublié de faire un checksum).

Constatez vous le même comportement, pour savoir s'il faut remonter un bug ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

tru
Messages : 233
Inscription : 20 octobre 2009, 09:30

Re: erreurs retournées par tar

Message par tru » 01 juillet 2013, 11:10


Avatar de l’utilisateur
nouvo09
Messages : 2159
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: erreurs retournées par tar

Message par nouvo09 » 01 juillet 2013, 11:14

Oui bizarre et cela est tout récent.

Je vais regarder s'il y a eu des mises à jours récentes de tar et éventuellement faire un downgrade.

Merci
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Avatar de l’utilisateur
nouvo09
Messages : 2159
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: erreurs retournées par tar

Message par nouvo09 » 01 juillet 2013, 12:22

En effet il y a eu une mise à jour en février, qui a installé la version 1.23 et amené ce bug.

Quoiqu'il en soit j'ai installe le paquet de Fedora 18, le 1.26.9 et le problème a disparu.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Répondre