Page 1 sur 1

CentOS 6.4 problèmes de dépendances.

Publié : 24 septembre 2013, 15:18
par mkl40
Bonjour à tous,

petit nouveau dans l'utilisation de CentOS j'ai un peu de mal à prendre mes marques (tous nos serveurs tournent sous Ubuntu server). Nous avons mis en place un serveur CentOS 6.4 sur lequel nous avons installé mysql depuis les repos Remi (version nécessaire à notre éditeur). Par soucis de simplicité nous souhaiterions utiliser phpMyAdmin pour aller fouiller dans les bases. Je me dis qu'un simple

Code : Tout sélectionner

yum --enablerepo=remi install phpMyAdmin
devrait suffir seulement j'ai des soucis de dépendances :

Code : Tout sélectionner

Error: Package: php-mcrypt-5.3.3-1.el6.rf.x86_64 (rpmforge)
           Requires: php-api = 20090626
           Installed: php-common-5.4.13-1.el6.remi.x86_64 (@remi)
               php-api = 20100412-x86-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-api = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-api = 20090626
           Available: php54w-common-5.4.17-3.w6.x86_64 (webtatic)
               php-api = 20100412
           Available: php54w-common-5.4.19-1.w6.x86_64 (webtatic)
               php-api = 20100412
           Available: php55w-common-5.5.1-2.w6.x86_64 (webtatic)
               php-api = 20121113
           Available: php55w-common-5.5.3-1.w6.x86_64 (webtatic)
               php-api = 20121113
Error: Package: php-cli-5.3.3-23.el6_4.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-23.el6_4
           Installed: php-common-5.4.13-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.13-1.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
Error: Package: php-gd-5.3.3-23.el6_4.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-23.el6_4
           Installed: php-common-5.4.13-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.13-1.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
Error: Package: php-5.3.3-23.el6_4.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-23.el6_4
           Installed: php-common-5.4.13-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.13-1.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
Error: Package: php-mbstring-5.3.3-23.el6_4.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-23.el6_4
           Installed: php-common-5.4.13-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.13-1.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
J'ai essayé en changeant de repo mais rien n'y fait ... Pouvez-vous m'expliquer d'où proviens mon erreur ?

Merci beaucoup.

Re: CentOS 6.4 problèmes de dépendances.

Publié : 24 septembre 2013, 17:30
par nouvo09
Package: php-mcrypt-5.3.3-1.el6.rf.x86_64 (rpmforge)
Tu as installé un paquet provenant de rpmforge et dont la version entre en conflit avec ce que yum veut installer.

rpmforge est connu, ainsi que d'autres, pour son aptitude à générer des conflits.

Désinstalle ce paquet, recommence ta commande avec l'option --disablerepo=rpmforge (si il est actif).

Re: CentOS 6.4 problèmes de dépendances.

Publié : 25 septembre 2013, 10:26
par mkl40
Merci nouvo09 de ta réponse, je vais tester ça aujourd'hui et je te tiens au courant.

Je dois reconnaitre que l'on a ajouté les repos en fonction des versions disponibles sur ceux-ci (notre éditeur était pointilleux sur les versions minimum à installer) ...

Re: CentOS 6.4 problèmes de dépendances.

Publié : 26 septembre 2013, 19:09
par jibe
Salut,
mkl40 a écrit :Je dois reconnaitre que l'on a ajouté les repos en fonction des versions disponibles sur ceux-ci (notre éditeur était pointilleux sur les versions minimum à installer) ...
Dans ce cas, plutôt que d'utiliser des repos diverses et variées généralement génératrices de conflits, il vaut mieux récupérer les sources et recompiler.

Je sais : ça fait peur, mais c'est moins compliqué qu'on pense et finalement plus sûr et souvent plus rapide que se battre avec les conflits ;)

Autre possibilité : utiliser la commande mysql au lieu du clicodrome PhpMyAdmin (voir ce post).

Re: CentOS 6.4 problèmes de dépendances.

Publié : 27 septembre 2013, 15:57
par mkl40
J'y avais pensé mais je m'étais dit que ce serait plus rapide avec les repos ... D'ailleurs je n'ai pas eu le temps de désinstaller le paquet incriminé.

Je suis d'accord avec toi sur l'utilisation de la ligne de commande mysql seulement je ne suis pas seul à devoir chercher des informations et PhpMyAdmin reste très utilisé en interne.