Tout nouveau débutant CentOS

rossfred
Messages : 1
Inscription : 23 mars 2014, 16:55

Tout nouveau débutant CentOS

Message par rossfred » 23 mars 2014, 17:21

Bonjour,

Bon je suis un utilisateur windows qui n'a jamais réussi à se faire au système linux mais comme je sais que la persévérance paye toujours je me lance sur CentOS.

Ok ok j'avoue que c'est sous le conseil d'un ami que je me lance. Donc j'ai téléchargé l'OS, puis installé sur une clé usb bootable (en vérité deux clés car deux DVD mais je n'ai utilisé qu'une seule clé pour l'installation). Je lance l'installation (je suis ce tuto: http://ressources-info.fr/tutoriels-sys ... ficher/21/) et en mettant l'installation minimal pour apprendre à monter des paquets etc... tout se passe bien ... le système me demande de redémarrer, j'exécute... il boot sur ma clé donc je reboot en changeant pour que le système boot sur mon disque dur.... et là... la console apparaît en me mettant:

CentOS release 6.5 (final)
Kernel 2.6.32-431.el6.x86_64

eve1 login:

Bête comme je suis je me dis c'est marrant je n'ai pas l'interface graphique comme dit dans le tuto je vais donc faire un startx.
Je me log donc en "root" avec le mdp et là il me met:

[root@eve1 ~]#

Je lui mets donc "startx" et il me répond "commande introuvable.
Je lui mets "nano startx".. même réponse.

Je vais donc chercher sur internet et certaines personnes ont résolu leur problème en faisant simplement l'installation en mode graphique basic (2ème option d'installation de CentOS).
Je me dis "baaaaah oui ça doit être ça" donc je m'exécute.... et toujours la même chose....

Alors oui je sais que je suis un supernoob mais j'aimerais vraiment monter ce serveur pour pouvoir m'exercer alors si quelqu'un peut m'aider.

Ma config:

ASRock - Z68M-ITX/HT - Carte mère Intel - Mini ITX - Socket 1155

Intel - Processeur - Intel Core i5 2500K / 3,3 GHz - LGA1155 Socket - L3 6 Mo - Box

OCZ - Agility 3 - Disque Flash interne 2,5" - 60 Go - SATA III

Corsair - CMX8GX3M2A1600C9 - Mémoire RAM - DDR3 1600 - 8 Go COR CL9 XMS Kit2

Je pense que ma config est sufisante pour faire tourner CentOS après je me demande si la puce graphique est suffisante ou même reconnu??

Au risque de me répéter mon interrogation est la suivante:
Que faut il que je fasse pour que cela fonctionne?

Merci d'avance

Rossfred

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Tout nouveau débutant CentOS

Message par Beta-Pictoris » 23 mars 2014, 19:19

Il faut installer les paquets adéquats. Mais, comme il y en a beaucoup à installer, il est préférable d'installer les groupes de paquets.

La commande suivante permet d'afficher les groupes disponibles:

Code : Tout sélectionner

yum grouplist
La commande suivante permet d'avoir des informations sur un groupe en particulier:

Code : Tout sélectionner

yum groupinfo "Bureau à usage général"
Pour disposer du bureau gnome au complet, tu peux installer les groupes suivants:

Code : Tout sélectionner

  yum groupinstall "Bureau" \
                            "Bureau à usage général" \
                            "Navigateur Internet" \
                            "Police" \
                            "Suite de bureautique et productivité" \
                            "Système X Window"

Avatar de l’utilisateur
Valdes
Messages : 30
Inscription : 30 mai 2013, 01:22

Re: Tout nouveau débutant CentOS

Message par Valdes » 23 mars 2014, 20:55

À mon avis, le plus simple serait de te faire une VM de CentOS : tout marche direct (matos commun), et c'est beaucoup plus flexible qu'une installation hard. D'autant plus que tu pourras faire des snapshots plus tard, quand tu commenceras à faire des trucs un peu dangereux (ça t'évitera ainsi de tout réinstaller).

Avatar de l’utilisateur
nouvo09
Messages : 1955
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Tout nouveau débutant CentOS

Message par nouvo09 » 24 mars 2014, 00:55

Valdes a écrit :À mon avis, le plus simple serait de te faire une VM de CentOS : tout marche direct (matos commun), et c'est beaucoup plus flexible qu'une installation hard. D'autant plus que tu pourras faire des snapshots plus tard, quand tu commenceras à faire des trucs un peu dangereux (ça t'évitera ainsi de tout réinstaller).
ça fait beaucoup de choses à apprendre d'un coup ça. Laisse les gens faire leurs erreurs de débutant, c'est comme ça qu'on apprend.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

tru
Messages : 203
Inscription : 20 octobre 2009, 09:30

Re: Tout nouveau débutant CentOS

Message par tru » 25 mars 2014, 11:46

1ère leçon: installation minimale -> pas d'interface graphique :), juste une ligne de commande...

Bonne continuation

Bernard
Messages : 4
Inscription : 15 avril 2014, 16:28

Re: Tout nouveau débutant CentOS

Message par Bernard » 15 avril 2014, 18:20

Bonjour,

Je suis dans la même configuration que tout nouveau débutant pour aborder CentOs.

Mon installation 6.4 est effectuée hors connexion internet (support DVD) et visiblement la commande yum veut irrémédiablement aller vérifier quelquechose à l'adresse mirrorlist.centos.org.

Comment puis-je m'affranchir de cette vérification pour que yum installe mes packages à partir du dvd ?

Je cherche à installer httpd. Sur internet c'est facile, il suffit de taper yum install httpd. Mais sur Centos, c'est visiblement plus compliqué.
ma commande yum localinstall httpd-2.2.15-29.el6.centos.x86_64.rpm

Visiblement la seule solution qui fonctionne consiste à utiliser rpm.

Merci pour votre aide.
Cordialement

Répondre