https renvoie toujours vers http

alainreymond
Messages : 2
Inscription : 06 avril 2014, 20:32

https renvoie toujours vers http

Message par alainreymond » 06 avril 2014, 20:40

Bonjour à tous,
Je viens d'installer un Centos 6.5 tout frais. J'ai plusieurs domaines dans
/var/www/vhosts
Je peux me connecter via http://www.mondomaine.com vers le bon
/var/www/vhosts/mondomaine.com/httpdocs

Mais si je tente une connexion vers https://www.mondomaine.com, au lieu de pointer
/var/www/vhosts/mondomaine.com/httpsdocs
comme je devrais m'y attendre, le système me renvoie sur http://www.mondomaine.com

J'ai eu plusieurs serveur sous Centos et je n'ai jamais eu ce problème. Je n'arrive pas à trouver d'où cela peut venir : firewall, autre ?

Quelqu'un a t-il une solution ?

Merci d'avance.

AR

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: https renvoie toujours vers http

Message par Beta-Pictoris » 06 avril 2014, 23:35

Je pense qu'il y a un problème de configuration de certaines directives comme NameVirtualHost.
Tu devrais nous montrer le fichier de configuration d'Apache de ton site https.

alainreymond
Messages : 2
Inscription : 06 avril 2014, 20:32

Re: https renvoie toujours vers http

Message par alainreymond » 07 avril 2014, 09:41

Merci pour la réponse
Voici le code de code de httpd.include contenu dans
/var/www/vhosts/mondomaine.com/conf
Merci pour les suggestions.
Cdlt

Code : Tout sélectionner

#ATTENTION!
#
#DO NOT MODIFY THIS FILE BECAUSE IT WAS GENERATED AUTOMATICALLY,
#SO ALL YOUR CHANGES WILL BE LOST THE NEXT TIME THE FILE IS GENERATED.
#
#IF YOU REQUIRE TO APPLY CUSTOM MODIFICATIONS, PERFORM THEM IN THE  FOLLOWING FILES:

#/var/www/vhosts/mondomaine.com/conf/vhost.conf
#/var/www/vhosts/mondomaine.com/conf/vhost_ssl.conf

<IfModule mod_ssl.c>

    <VirtualHost 92.48.90.219:443 >
        ServerName "mondomaine.com:443"
        ServerAlias  "www.mondomaine.com"
        ServerAlias  "ipv4.mondomaine.com"
        UseCanonicalName Off
        ServerAlias "mondomaine.com.92-48-90-219.serveur.com"

        <IfModule mod_suexec.c>
            SuexecUserGroup "adminmondomaine" "psacln"
        </IfModule>

        ServerAdmin  "info@mondomaine.com"
        DocumentRoot "/var/www/vhosts/mondomaine.com/httpdocs"
        CustomLog /var/www/vhosts/mondomaine.com/statistics/logs/access_ssl_log plesklog
        ErrorLog  "/var/www/vhosts/mondomaine.com/statistics/logs/error_log"

        <IfModule mod_userdir.c>
            UserDir "/var/www/vhosts/mondomaine.com/web_users"
        </IfModule>

        ScriptAlias  "/cgi-bin/" "/var/www/vhosts/mondomaine.com/cgi-bin/"
        Alias  "/plesk-stat" "/var/www/vhosts/mondomaine.com/statistics"
        <Location  /plesk-stat/>
            Options +Indexes
        </Location>
        <Location  /plesk-stat/logs/>
            Require valid-user
        </Location>
        Alias  /webstat /var/www/vhosts/mondomaine.com/statistics/webstat
        Alias  /webstat-ssl /var/www/vhosts/mondomaine.com/statistics/webstat-ssl
        Alias  /ftpstat /var/www/vhosts/mondomaine.com/statistics/ftpstat
        Alias  /anon_ftpstat /var/www/vhosts/mondomaine.com/statistics/anon_ftpstat
        Alias  /awstats-icon /var/www/html/awstats/icon
        SSLEngine on
        SSLVerifyClient none
        SSLCertificateFile /usr/local/psa/var/certificates/certwYQSsK3
        SetEnv PP_CUSTOM_PHP_INI /var/www/vhosts/mondomaine.com/etc/php.ini

        <IfModule mod_fcgid.c>
            FcgidInitialEnv PP_CUSTOM_PHP_INI /var/www/vhosts/mondomaine.com/etc/php.ini
            FcgidMaxRequestLen 16777216
        </IfModule>

        <Directory /var/www/vhosts/mondomaine.com/httpdocs>

        <IfModule mod_perl.c>
            <Files ~ (\.pl$)>
                SetHandler perl-script
                PerlHandler ModPerl::Registry
                Options ExecCGI
                allow from all
                PerlSendHeader On
            </Files>
        </IfModule>
        <IfModule sapi_apache2.c>
            php_admin_flag engine on
            # General settings
            php_admin_flag safe_mode on
            php_admin_value open_basedir "/var/www/vhosts/mondomaine.com/:/tmp/"
            # Performance settings
            # Additional directives
        </IfModule>

        <IfModule mod_php5.c>
            php_admin_flag engine on
            # General settings
            php_admin_flag safe_mode on
            php_admin_value open_basedir "/var/www/vhosts/mondomaine.com/:/tmp/"
            # Performance settings
            # Additional directives
        </IfModule>
        <IfModule mod_fcgid.c>
            <Files ~ (\.fcgi)>
                SetHandler fcgid-script
                Options +FollowSymLinks +ExecCGI
            </Files>
        </IfModule>
        SSLRequireSSL
        Options -Includes +ExecCGI

        </Directory>
            <Directory "/var/www/vhosts/mondomaine.com/statistics">
            AuthType Basic
            AuthName "Statistiques du domaine"
            AuthUserFile "/var/www/vhosts/mondomaine.com/pd/d..httpdocs@plesk-stat"
            require  valid-user
        </Directory>
    </VirtualHost>

</IfModule>

<VirtualHost 92.48.90.219:80 >
    ServerName "mondomaine.com"
    ServerAlias  "www.mondomaine.com"
    ServerAlias  "ipv4.mondomaine.com"
    UseCanonicalName Off
    ServerAlias "mondomaine.com.92-48-90-219.serveur.com"
    <IfModule mod_suexec.c>
        SuexecUserGroup "adminroda" "psacln"
    </IfModule>
    ServerAdmin  "info@mondomaine.com"
    DocumentRoot "/var/www/vhosts/mondomaine.com/httpdocs"
    CustomLog /var/www/vhosts/mondomaine.com/statistics/logs/access_log plesklog
    ErrorLog  "/var/www/vhosts/mondomaine.com/statistics/logs/error_log"

    <IfModule mod_userdir.c>
        UserDir "/var/www/vhosts/mondomaine.com/web_users"
    </IfModule>
    ScriptAlias  "/cgi-bin/" "/var/www/vhosts/mondomaine.com/cgi-bin/"
    Redirect permanent /plesk-stat https://mondomaine.com/plesk-stat
    Redirect permanent /webstat https://mondomaine.com/webstat
    Redirect permanent /webstat-ssl https://mondomaine.com/webstat-ssl
    Redirect permanent /ftpstat https://mondomaine.com/ftpstat
    Redirect permanent /anon_ftpstat https://mondomaine.com/anon_ftpstat
    Redirect permanent /awstats-icon https://mondomaine.com/awstats-icon

    <IfModule mod_ssl.c>
        SSLEngine off
    </IfModule>

    SetEnv PP_CUSTOM_PHP_INI /var/www/vhosts/mondomaine.com/etc/php.ini

    <IfModule mod_fcgid.c>
        FcgidInitialEnv PP_CUSTOM_PHP_INI /var/www/vhosts/mondomaine.com/etc/php.ini
        FcgidMaxRequestLen 16777216
    </IfModule>

    <Directory /var/www/vhosts/mondomaine.com/httpdocs>
        <IfModule mod_perl.c>
            <Files ~ (\.pl$)>
                SetHandler perl-script
                PerlHandler ModPerl::Registry
                Options ExecCGI
                allow from all
                PerlSendHeader On
            </Files>
        </IfModule>
        <IfModule sapi_apache2.c>
            php_admin_flag engine on
            # General settings
            php_admin_flag safe_mode on
            php_admin_value open_basedir "/var/www/vhosts/mondomaine.com/:/tmp/"
            # Performance settings
            # Additional directives
        </IfModule>
        <IfModule mod_php5.c>
            php_admin_flag engine on
            # General settings
            php_admin_flag safe_mode on
            php_admin_value open_basedir "/var/www/vhosts/mondomaine.com/:/tmp/"
            # Performance settings
            # Additional directives
        </IfModule>
        <IfModule mod_fcgid.c>
            <Files ~ (\.fcgi)>
                SetHandler fcgid-script
                Options +FollowSymLinks +ExecCGI
            </Files>
        </IfModule>
        Options -Includes +ExecCGI
    </Directory>

    <Directory "/var/www/vhosts/mondomaine.com/statistics">
        AuthType Basic
       AuthName "Statistiques du domaine"
       AuthUserFile "/var/www/vhosts/mondomaine.com/pd/d..httpdocs@plesk-stat"
       require  valid-user
    </Directory>

</VirtualHost>

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: https renvoie toujours vers http

Message par Beta-Pictoris » 07 avril 2014, 11:45

Le module ssl est-il installé ?

'<VirtualHost _default_:443>' est-il désactivé ?

As tu ajouté une directive 'NameVirtualHost *:443', par exemple, dans /etc/conf/httpd.conf ?

Si tout ceci est correct, as tu testé en désactivant, temporairement, selinux ?

Répondre