Problème avec wget connection refused

Pingwi
Messages : 5
Inscription : 11 novembre 2014, 11:35

Problème avec wget connection refused

Message par Pingwi » 11 novembre 2014, 11:37

Bonjour à tous,

J'ai un problème sous Centos, ça fait longtemps que je ne me suis pas servit de la commande wget et maintenant elle ne fonctionne pas même avec une image jpg simple :

Code : Tout sélectionner

[root@s15413 ~]# wget http://www.bitcoin.fr/public/divers2/ibc-paris-2.jpg
 --2014-11-11 09:45:55--  http://www.bitcoin.fr/public/divers2/ibc-paris-2.jpg
Connecting to 82.165.141.30:3128... failed: Connection refused.
Je précise que l'IP en bas 82.165.141.30 est l'IP du serveur.

Ca ne m'a jamais fait ça avant et sur les forums que j'ai cherché je ne comprend pas leur histoire de proxy à changer ou autre.
Je n'est rien touché et ça ne fonctionne plus.

Si vous pouviez m'aider ?

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème avec wget connection refused

Message par Beta-Pictoris » 11 novembre 2014, 13:22

Peux tu pinger le site en question ?

Tu auras plus d'informations avec les options "debug" et "verbose":

Code : Tout sélectionner

wget -dv http://www.bitcoin.fr/public/divers2/ibc-paris-2.jpg
Pour utiliser un proxy http, teste après avoir modifié la variable http_proxy:

Code : Tout sélectionner

http_proxy=http://adresse_ip:port/
Regarde dans ton navigateur web, les paramètres du proxy.

Pingwi
Messages : 5
Inscription : 11 novembre 2014, 11:35

Re: Problème avec wget connection refused

Message par Pingwi » 11 novembre 2014, 16:27

Le site est un site au hazard, oui je png dessus et j'ai aussi essayé directement avec l'ip

Si j'utilise l'option --no-proxy ça fonctionne.

Ce veut dire que la commande utilise l'IP de mon propre serveur comme proxy. y a pas moyen de supprimer ca ?

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème avec wget connection refused

Message par Beta-Pictoris » 11 novembre 2014, 17:13

Regarde la valeur de la variable:

Code : Tout sélectionner

echo $http_proxy
Teste avec un autre compte utilisateur.
Tu dois, ensuite, rechercher dans quel fichier a été définie cette variable (~/.bash_profile, /etc/profile.d/*, /etc/environnement, ....)

Utilises tu un bureau comme gnome, kde,... ?

Pingwi
Messages : 5
Inscription : 11 novembre 2014, 11:35

Re: Problème avec wget connection refused

Message par Pingwi » 11 novembre 2014, 19:30

echo $http_proxy ne me renvoye rien du tout

Sinon, je n'utilise pas de bureau étant donnée que c'est un serveur dédié je n'y est accès que en ssh

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème avec wget connection refused

Message par Beta-Pictoris » 11 novembre 2014, 21:37

Vérifie, alors, le contenu des fichiers /etc/wgetrc et ~/.wgetrc

Pingwi
Messages : 5
Inscription : 11 novembre 2014, 11:35

Re: Problème avec wget connection refused

Message par Pingwi » 12 novembre 2014, 07:18

Merci ;) il y a vait un proxy de rentré dans .wgetrc j'ai mi use_proxy sur off et tout refonctionne sans soucis.

Une idée de ce qui à pu installer ça sans que je le sache ? Un programme? un hacker ?..?

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème avec wget connection refused

Message par Beta-Pictoris » 12 novembre 2014, 20:48

Tente, déja, de localiser le proxy: http://www.geoiptool.com/

Vérifie les tentatives d'intrusions sur ton système via les commandes last et lastlog.

Scanne les ports pour rechercher la présence d'une éventuelle backdoor.

Tu trouveras toutes sortes d'outils utiles ici.

Tu peux, par exemple, installer un "ids" comme snort.

Pingwi
Messages : 5
Inscription : 11 novembre 2014, 11:35

Re: Problème avec wget connection refused

Message par Pingwi » 13 novembre 2014, 07:28

Ton lien à l'air pas mal avec tous les outils. merci, je regarderait ça ce soir.

Sinon le proxy mis en place c'était l'ip du serveur lui-même sur le port 3128 alors que j'ai jamais installer de proxy dessus c'est pour ca je que comprend pas trop.

En tout cas merci beaucoup pour ton aide.

Répondre