CFG phpMyAdmin

Digital
Messages : 20
Inscription : 01 octobre 2014, 15:24

CFG phpMyAdmin

Message par Digital » 16 novembre 2014, 12:51

Bonjour à tous,

J'ai rencontré un problème avec phpMyAdmin "chose que je n'ai jamais eu :/ ".
J'ai toujours travaillé sur des VPS avec CentOS et quand j'installais phpMyAdmin je pouvais y accéder via mondomaine.com/phpmyadmin/

Actuellement je voulais travailler sur deux VM (windows7 pour le lient, CentOS pour le serveur), j'ai bien configuré mon DNS ect, je peux accéder au serveur, à l'url et au FTP via ma machine client.

Malheureusement pour accéder à mon phpmyadmin la j'ai un petit souci :|
quand je tape l'url il me dit que je n'ai pas les permissions pour avoir accès à /phpMyAdmin sur le serveur.

Je ne sais pas trop quoi faire j'ai déjà regarder sur google et suivi des tutos.
J’ai également suivi le fichier e cfg de ce tuto http://tecadmin.net/how-to-install-phpm ... using-yum/

Merci d'avance pour votre aide ;)

Avatar de l’utilisateur
nouvo09
Messages : 1955
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: CFG phpMyAdmin

Message par nouvo09 » 16 novembre 2014, 16:04

Avant tout, as-tu désactivé sur Centos SElinux, pour faire un test ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Digital
Messages : 20
Inscription : 01 octobre 2014, 15:24

Re: CFG phpMyAdmin

Message par Digital » 17 novembre 2014, 11:10

Bonjour,

Oui j'ai bien désacriver SeLinux ainsi que les iptables.
Mais toujours le même problème.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: CFG phpMyAdmin

Message par Beta-Pictoris » 17 novembre 2014, 19:00

Teste, éventuellement, la version du dépot epel.

Regarde ici.

Digital
Messages : 20
Inscription : 01 octobre 2014, 15:24

Re: CFG phpMyAdmin

Message par Digital » 18 novembre 2014, 10:02

Bonjour merci pour ta réponse,

J'ai déjà tester ce tuto mais rien de concluant :/
Je pense que le souci vient du fichier de cfg = sudo nano /etc/httpd/conf.d/phpMyAdmin.conf

je dois surement me tromper dans les adresses ip...

la machine client: 192.168.0.11
la machine serveur: 192.168.0.10

Si vous avez un fichier de cfg qui fonctionne je pourrai toujours comparer.

Encore merci ;)

Digital
Messages : 20
Inscription : 01 octobre 2014, 15:24

Re: CFG phpMyAdmin

Message par Digital » 19 novembre 2014, 18:45

j'ai une meilleure piste pour mon problème :lol:

Je me suis donc bien centralisé sur le fichier phpMyAdmin.conf
J'ai ENFIN pu avoir un visuel et accès au phpmyadmin via mondomaine.com/phpmyadmin

Et j'ai remarqué qu'il n'arrive pas a lire les modules "mod_authz_core.c".
J'ai donc fait un allow from 192.168.0.11 ( qui est l'ip de la machine ).

Et la ça été :|

Mais ce n'est pas ce que j'aimerais :? Parce que la j'autorise une seule ip et je n'utilise pas les modules :O

Voici une image: http://www.hostingpics.net/viewer.php?i ... 173831.png

Et ma meilleure piste est que je pense tout simplement que apache n'arrive pas a lire les fichiers parce qu’ils sont sous les droits de root !
Maintenant je ne sais pas du tout ou je peux trouver ces fichiers :s

Vous le savez peut être ? :D

Avatar de l’utilisateur
remi
Messages : 216
Inscription : 20 octobre 2009, 07:10
Localisation : Champagne...
Contact :

Re: CFG phpMyAdmin

Message par remi » 20 novembre 2014, 11:49

> J'ai donc fait un allow from 192.168.0.11 ( qui est l'ip de la machine ).
C'était pourtant indiqué dans le tuto de dont tu donnes le lien au premier message... (et donc j'ai pas jugé utile de le repréciser...)

> Et ma meilleure piste est que je pense tout simplement que apache n'arrive pas a lire les fichiers parce qu’ils sont sous les droits de root !
Aucun rapport, les fichiers sont propriétaire = root, mais lecture autorisé à tous le monde.
Contributeur EPEL et CentOS SCLo SIG
Des RPM pour CentOS sur https://rpms.remirepo.net

Avatar de l’utilisateur
remi
Messages : 216
Inscription : 20 octobre 2009, 07:10
Localisation : Champagne...
Contact :

Re: CFG phpMyAdmin

Message par remi » 20 novembre 2014, 11:52

> Et j'ai remarqué qu'il n'arrive pas a lire les modules "mod_authz_core.c".
???
Ce module est uniquement dans Apache 2.4
http://httpd.apache.org/docs/2.4/mod/mo ... _core.html

T'aurais pas bricolé des fichiers de config entre CentOS 6 et CentOS 7 ?
Contributeur EPEL et CentOS SCLo SIG
Des RPM pour CentOS sur https://rpms.remirepo.net

Avatar de l’utilisateur
remi
Messages : 216
Inscription : 20 octobre 2009, 07:10
Localisation : Champagne...
Contact :

Re: CFG phpMyAdmin

Message par remi » 20 novembre 2014, 11:53

Ok, VU!
T'as modifié la partie de config d'Apache 2.4 au lieu de modifier celle (juste en dessous) d'apache 2.2


P.S. et par pitié, évite les copie d'écran en image... il est tellement plus simple / lisible de coller "juste" le texte.
Contributeur EPEL et CentOS SCLo SIG
Des RPM pour CentOS sur https://rpms.remirepo.net

Digital
Messages : 20
Inscription : 01 octobre 2014, 15:24

Re: CFG phpMyAdmin

Message par Digital » 20 novembre 2014, 13:05

Bonjour,

Merci pour tes infos.

Malheureusement tes réponses ne m'avance pas tellement pour mon problème.

Tu pourrais m'en dire un peu plus ?

Répondre