Installation NAS - error Input/Output read /dev/sdb

Dod's
Messages : 2
Inscription : 02 février 2015, 19:13

Installation NAS - error Input/Output read /dev/sdb

Message par Dod's » 02 février 2015, 19:26

Bonjour à tous,

Je suis nouveau dans le monde Centos et je veux installer un serveur NAS avec CentOS6.6.
J'ai un serveur NAS avec 2 disque en RAID 1 pour le système et 18 Disques en RAID 5 pour la sauvegarde.
Le RAID 5 est en RAID matériel et lorsque je veux installer CentOS, j'ai l'erreur suivante lors de la création de ma partition sur mon RAID 5. (Input/Output error during read on /dev/sdb)
Si je fais l'installation sans mon RAID 1, cela fonctionne.
Mon RAID 5 est un RAID matériel avec une carte controller raid Perc 6/E.
J'ai l'impression que mon raid 5 créer un disque virtuel en GPT et donc CentOS bloque sur le lorsqu'il doit crééer une partition et la reformater.

Quelqu'un a-t-il déjà eu ce problème ?

J'espère être assez clair dans mes explications.

Merci par avance

Dod's

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Installation NAS - error Input/Output read /dev/sdb

Message par Beta-Pictoris » 02 février 2015, 22:42

Si ton disque est en gpt, les commandes suivantes vont te l'indiquer:

Code : Tout sélectionner

fdisk -l /dev/sdb
parted /dev/sdb print
Je suppose que tu as supprimé et recréé ta matrice raid via le bios raid.

Tes disques ont une interface SAS. Apparemment le module megaraid_sas du noyau linux permet de gérer ta carte raid.
Regarde ce lien: http://hwraid.le-vert.net/wiki/LSIMegaRAIDSAS

Tu peux le localiser comme ceci:

Code : Tout sélectionner

locate megaraid_sas
Tu peux, aussi, vérifier qu'il soit chargé en mémoire:

Code : Tout sélectionner

lsmod | grep -i sas
Pourquoi tu n'utilises pas, de préférence, une Centos 7 ? Le module peut être plus récent et peut mieux fonctionner.

Quel outil utilises tu pour recréer tes partitions ?

Dod's
Messages : 2
Inscription : 02 février 2015, 19:13

Re: Installation NAS - error Input/Output read /dev/sdb

Message par Dod's » 03 février 2015, 12:30

Bonjour,

Effectivement, je suis passé sur le CentOS 7 mais j'ai le même problème.

Merci de ta réponse rapide.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Installation NAS - error Input/Output read /dev/sdb

Message par Beta-Pictoris » 03 février 2015, 19:50

As tu essayé d'installer la centos 7, uniquement, sur tes disques en raid 1, puis, dans un 2ème temps, de partitionner et formater ton raid 5 ?

S'il y a toujours des erreurs, regarde le détail des logs dans /var/log/messages.

Tu peux, aussi, vérifier l'état de tes disques via la command smartctl:

Code : Tout sélectionner

smartctl -a -d megaraid,0 /dev/sdb
smartctl -a -d megaraid,1 /dev/sdb
smartctl -a -d megaraid,2 /dev/sdb
....
Regarde la page de man à ce sujet, il y a des informations sur les contrôleurs Dell PERC.

Répondre