Problème pour changer les droits dans /dev/sdb1

bapt1990
Messages : 2
Inscription : 07 juillet 2015, 10:13

Problème pour changer les droits dans /dev/sdb1

Message par bapt1990 » 07 juillet 2015, 10:17

Bonjour à tous,

Configuration : CentOS 6.5

Je suis confronté à l'heure actuelle à un problème de taille. Je souhaite donner les droits à "postgres:postgres" sur un répertoire situé dans mon /dev/sdb1.

Cependant, lorsque je souhaite changer les droits cela ne fonctionne pas (commande utilisée : #chown -R postgres:postgres /dev/sdb1/mon_répertoire).
Ce que je ne comprends pas, c'est que si je rajoute l'option "-v" à ma commande, il me renvoit : "changed ownership of `pgsql_data/global/12999' to postgres:postgres" mais les droits de mon répertoire restent inchangés.

Mon disque a été monté de la manière classique, en renseignant le fichier /etc/fstab de la manière suivante :

/dev/sdb1 /mnt/point_de_montage ntfs defaults,uid=1601,gid=1600 0 0

Je ne sais plus trop quoi faire pour solutionner mon problème. Voici ce que j'ai tenté :

- Désactiver le SELinux : Echec
- Changer dans mon fstab le ntfs par ntfs-3g puis rebooter : Echec
- Créer le répertoire voulu avec l'utilisateur concerné : Echec

Pour tester s'il était réellement possible d'attribuer les droits à postgres j'ai créé un répertoire TEST à la racine pour lequel j'ai exécuté la commande énoncée ci-dessus. Ce test à fonctionné.
Le problème vient-il de la manière dont j'ai monté le /dev/sdb1 ? ou le fait d'avoir renseigné le fstab avec mon uid et gid ?

Merci par avance pour votre aide.

information complémentaires : résultats de $fdisk -l

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 243202 1953512448 7 HPFS/NTFS

Avatar de l’utilisateur
Arrfab
Administrateur
Messages : 305
Inscription : 16 octobre 2009, 18:04
Localisation : /dev/irc.freenode.net/#centos
Contact :

Re: Problème pour changer les droits dans /dev/sdb1

Message par Arrfab » 07 juillet 2015, 10:28

/dev/sdb1 est la partition sur le device /dev/sdb, pas le point de montage.
pourquoi utiliser ntfs sur un serveur linux (et donc raison pour laquelle chown ne fonctionnera jamais) ?
----
test -e /dev/human/brain || ( echo 1 > /proc/sys/kernel/sysrq ; echo c > /proc/sysrq-trigger )

bapt1990
Messages : 2
Inscription : 07 juillet 2015, 10:13

Re: Problème pour changer les droits dans /dev/sdb1

Message par bapt1990 » 07 juillet 2015, 10:37

Merci pour votre réponse :).

Je suis nouveau sur Linux. Pour le NTFS, c'est en prévision d'un double boot, mais en effet je peux le changer sachant que je n'utilise que Linux.

Que dois-je faire pour modifier cela ? Pouvez-vous m'épauler ?

Bapt

Avatar de l’utilisateur
nouvo09
Messages : 2045
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème pour changer les droits dans /dev/sdb1

Message par nouvo09 » 07 juillet 2015, 11:53

On vient de te le dire:

on ne change pas le propriétaire sur un /dev, il sera toujours root.

monte le répertoire que tu souhaites par exemple

mount /dev/sdb1 /dossier

ensuite tu pourras changer les droits sur /dossier. Et si ce répertoire doit être monté à chaque démarrage alors tu dois insérer la ligne correspondante dans le fichier fstab, avec les options adéquates (man mount)
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

tru
Messages : 226
Inscription : 20 octobre 2009, 09:30

Re: Problème pour changer les droits dans /dev/sdb1

Message par tru » 10 juillet 2015, 11:57

1) ntfs ne gère pas les permissions unix via chown, c'est le uid= gid= (voir aussi umask,fmask,dmask) qui positionnent les droits.
2) dejà dit, c'est sur le point de montage que l'on change les droits (sur un système de fichiers ext3/4/xfs,..) pas sur le "device" /dev/sdb1

Répondre