Problème avec YUM

cepardea
Messages : 2
Inscription : 27 août 2015, 11:45

Problème avec YUM

Message par cepardea » 27 août 2015, 11:52

Bonjour à tous,

Je dispose d'une machine virtuelle Centos avec eyesofnetwork d'installé dessus.

J'ai eu quelques soucis avec mon yum qui ne voulait plus fonctionner, j'ai donc fait beaucoup de manipulations dont celle de prendre le contenu du fichier yum d'un autre serveur centos et de le recopier dans le mien, et depuis c'est encore pire, à chaque fois que je corrige une erreur, j'en génère une autre, j'ai vraiment besoin d'aide car je ne sais plus quoi faire, je ne peux pas ré installer ma machine virtuelle car je n'ai aucune sauvegardes de ce que j'ai configuré.

Je suis sous Centos 6.5, et voici mon message d'erreur actuel :

[root@SIMONEON tmp]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6.5& amp;arch=x86_64&repo=os error was
14: PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request ( Données non valides. )"
Error: Cannot find a valid baseurl for repo: base


Je vous remercie par avance, et vous souhaite une agréable journée.

Avatar de l’utilisateur
Arrfab
Administrateur
Messages : 305
Inscription : 16 octobre 2009, 18:04
Localisation : /dev/irc.freenode.net/#centos
Contact :

Re: Problème avec YUM

Message par Arrfab » 27 août 2015, 13:52

Simple "eyesofnetwork" modifie CentOS pour ne donc plus être une install CentOS normale.
Il faudrait leur demander la raison pour laquelle ils font celà.

Code : Tout sélectionner

grep mirrorlist /etc/yum.repos.d/CentOS-Base.repo 
Il n'existe pas non plus de CentOS 6.5, mais simplement la version 6, qui a des versions mineurs (l'actuelle est 6.7).
Remplace donc 6.5 par $releasever (comme de base après une install normale) et celà pour tous les repo :

Code : Tout sélectionner

mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates&infra=$infra
----
test -e /dev/human/brain || ( echo 1 > /proc/sys/kernel/sysrq ; echo c > /proc/sysrq-trigger )

cepardea
Messages : 2
Inscription : 27 août 2015, 11:45

Re: Problème avec YUM

Message par cepardea » 27 août 2015, 15:01

je te remercie beaucoup, mon problème à l'air d'être résolu, mon yum update est passé, je ne sais comment te remercier, j'ai pas compris d'où il est sortit ce 6.5 parce que le fichier que j'avais récupéré n'était meme pas sur une 6.5 ^^'

En tous cas merci beaucoup.

Répondre