script d'installation problème make

AngryPanda
Messages : 2
Inscription : 11 janvier 2016, 00:03

script d'installation problème make

Message par AngryPanda » 11 janvier 2016, 00:17

Bonjour,

Alors voila je me suis créer un petit script qui me permet d'installer facilement le service voip Asterisk mais quand je l'exécute les make install ne se font pas correctement par exemple pour dahdi il se finit correctement mais rien n'est installé à la fin et pour Asterisk il me demande d'exécuter le script configure avant de pouvoir lancer make install. Des idées d'où cela pourrait-il venir ?

Code : Tout sélectionner

#!/bin/bash

function flushDownloads 
{
	rm -rf /usr/src/asterisk*
	rm -rf /usr/src/lipbri*
	rm -rf /usr/src/dahdi*
}

. /etc/profile

cd /usr/src/

wget http://downloads.asterisk.org/pub/telephony/dahdi-linux-complete/dahdi-linux-complete-current.tar.gz
wget http://downloads.asterisk.org/pub/telephony/libpri/libpri-1.4-current.tar.gz
wget http://downloads.asterisk.org/pub/telephony/asterisk/asterisk-11-current.tar.gz

cd /usr/src/asterisk*/contrib/scripts

./install_prereq intsall 

tar zxvf dahdi-linux-complete*
tar zxvf libpri*
tar zxvf asterisk*

cd /usr/src/dahdi-linux-complete*
sudo make all
sudo make install
sudo make config

echo " " 
echo "Dadhi installed !" 
sleep 2

echo " "
service dadhi start
sleep 5
echo " "

cd /usr/src/libpri*
sudo make
sudo make install

cd /usr/src/asterisk*

./configure

sudo make menuselect

sudo make

sudo make install

if [ `echo $?` = 1 ]
then
    	echo "fail ma biche"

    	flushDownloads

    	exit 1
fi 

sudo make samples 
 
sudo make clean

sudo make distclean

sudo make config 

flushDownloads


Avatar de l’utilisateur
nouvo09
Messages : 1871
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: script d'installation problème make

Message par nouvo09 » 11 janvier 2016, 09:26

essaie de faire le configure à la main tu verras probablement s'il renvoie un message d'erreur.

D'ailleurs essaie toutes les opérations d'abord à la main pour voir les retours.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Beta-Pictoris
Messages : 993
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: script d'installation problème make

Message par Beta-Pictoris » 11 janvier 2016, 09:29

Je pense qu'il y a une erreur ici:

Code : Tout sélectionner

./install_prereq intsall

AngryPanda
Messages : 2
Inscription : 11 janvier 2016, 00:03

Re: script d'installation problème make

Message par AngryPanda » 11 janvier 2016, 12:49

Oui il y'a effectivement une erreur sur le prereq j'ai copié collé le mauvais code :p

J'ai essayer de le faire à la main et toute la compilation fonctionne en dehors du script ^^

Répondre