Problème de connexion MySQL à une machine virtuel

Reborn
Messages : 10
Inscription : 09 août 2015, 15:01

Problème de connexion MySQL à une machine virtuel

Message par Reborn » 09 août 2015, 15:45

Bonjour à tous,

Je débute sur MySQL et je rencontre une anomalie qui dure depuis 3 jours et je n'arrive pas à trouver la solution seul donc je vous demande de l'aide. :oops:

Je vous essayé de vous expliquer au mieux mon problème:

Je dispose d'un ordinateur Win7 64 bit, sur cet ordinateur j'ai installé une machine virtuelle via VMware Workstation sous CentOS 6.4 i386.
J'ai donc installé Navicat Lite sous CentOS et Navicat Premium sous mon Windows et voulant créer une connexion à distance entre mon pc et ma machine j'ai fais un nouvel utilisateur sur Navicat sous CentOS :

- User (Host %) : OK
- Server priviliges : OK
- Privileges (mes database) : OK

Je vais donc dans mon Nivacat sous Win -> connection -> MySQL -> Host Name / IP Adress : MON IPV4 CentOS -> Port : 3306 -> User -> Password puis Test connection

Message d'erreur : 2003 - Can't connect to MySQL server on 'MON IPV4' (10060)


Commandes utilisées sous CentOS

Pour MySQL : (MySQL shared compat 5.1)
yum install mysql mysql-server
chkconfig --levels 235 mysqld on
/etc/init.d/mysqld start
HTTPD :
yum install httpd
chkconfig --levels 235 httpd on
/etc/init.d/httpd start
PHP :
yum install php
/etc/init.d/httpd restart
Autre :
yum install libexpat.so.0
Autres opérations :

Désactivation du Firewall
Suppression du fichier (root user)
mysql.sock

J'espère avoir détaillé au mieux mon problème et j'espère vraiment trouver une solution :(

Merci d'avance
Cordialement,
Byakuran

Beta-Pictoris
Messages : 993
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème de connexion MySQL à une machine virtuel

Message par Beta-Pictoris » 09 août 2015, 21:35

Arrives tu, déjà, à te connecter via le client "mysql" en donnant les droits à un user comme ceci ? : https://openclassrooms.com/forum/sujet/ ... ysql-40361

Reborn
Messages : 10
Inscription : 09 août 2015, 15:01

Re: Problème de connexion MySQL à une machine virtuel

Message par Reborn » 09 août 2015, 22:21

Beta-Pictoris a écrit :Arrives tu, déjà, à te connecter via le client "mysql" en donnant les droits à un user comme ceci ? : https://openclassrooms.com/forum/sujet/ ... ysql-40361

J'ai bien créé un user avec tous les droits, et l'user marche car je peux me connecter avec cet user via la machine virtuelle par contre impossible de me connecter de mon ordi à ma machine :roll:

J'ai l'impression que ma machine est isolée et que rien n'en "sors" car mes serveurs pour mon jeu tournent sous le CentOS et mon jeu est donc sur mon bureau Win7 et je n'arrive pas à m'y connecter (après je n'exclu pas une faute au niveau de la config de mes serveurs).

Beta-Pictoris
Messages : 993
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème de connexion MySQL à une machine virtuel

Message par Beta-Pictoris » 09 août 2015, 23:23

Peux tu scanner les ports tcp de ton serveur linux depuis une autre machine pour vérifier qu'il y a bien un port sql 3306 ouvert ?

Tu peux utiliser le programme nmap pour faire cela.

Teste, aussi, après avoir désactivé Selinux sur ton serveur, comme ceci:

Code : Tout sélectionner

setenforce 0

Reborn
Messages : 10
Inscription : 09 août 2015, 15:01

Re: Problème de connexion MySQL à une machine virtuel

Message par Reborn » 10 août 2015, 00:23

Beta-Pictoris a écrit :Peux tu scanner les ports tcp de ton serveur linux depuis une autre machine pour vérifier qu'il y a bien un port sql 3306 ouvert ?

Tu peux utiliser le programme nmap pour faire cela.

Teste, aussi, après avoir désactivé Selinux sur ton serveur, comme ceci:

Code : Tout sélectionner

setenforce 0
Voici le résultat du scan avec la commande

Code : Tout sélectionner

nmap localhost
depuis mon serveur Linux

Code : Tout sélectionner

[root@localhost reborn]# nmap localhost

Starting Nmap 5.51 ( http://nmap.org ) at 2015-08-09 15:14 PDT
Nmap scan report for localhost (127.0.0.1)
Host is up (0.0000090s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 995 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
25/tcp   open  smtp
80/tcp   open  http
631/tcp  open  ipp
3306/tcp open  mysql

Depuis Win7 en marquant l'IPV4 de mon CentOS et en choisissant l'option Intense scan, all TCP ports :

Code : Tout sélectionner

Starting Nmap 6.49BETA3 ( https://nmap.org ) at 2015-08-10 00:39 Paris, Madrid (heure d?été)

NSE: Loaded 122 scripts for scanning.

NSE: Script Pre-scanning.

Initiating NSE at 00:39

Completed NSE at 00:39, 0.00s elapsed

Initiating NSE at 00:39

Completed NSE at 00:39, 0.00s elapsed

Initiating Ping Scan at 00:39

Scanning 192.168.198.131 [4 ports]

Completed Ping Scan at 00:39, 2.55s elapsed (1 total hosts)

Nmap scan report for 192.168.198.131 [host down]

NSE: Script Post-scanning.

Initiating NSE at 00:39

Completed NSE at 00:39, 0.00s elapsed

Initiating NSE at 00:39

Completed NSE at 00:39, 0.00s elapsed

Read data files from: C:\Program Files (x86)\Nmap

Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn

Nmap done: 1 IP address (0 hosts up) scanned in 8.77 seconds

           Raw packets sent: 8 (304B) | Rcvd: 4 (248B)


Même après désactivation de Selinux ma connexion ne marche pas, ai-je fais la bonne manipulation par contre car je débute dans CentOS. J'ai écris

Code : Tout sélectionner

setenforce 0
dans ma console en mode root.

Beta-Pictoris
Messages : 993
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème de connexion MySQL à une machine virtuel

Message par Beta-Pictoris » 10 août 2015, 01:31

De ta machine windows, tu peux faire un simple scan:

Code : Tout sélectionner

nmap 192.168.1.131
Ressaye, car le resultat de ton scan montre que le port sql n'est pas accessible. Problème de pare-feu ?

Tu peux forcer mysql à écouter sur ton interface réseau en ajoutant la directive suivante dans la section mysqld du fichier /etc/my.cnf:

Code : Tout sélectionner

[mysqld]
bind-address=192.168.1.131
Tu dois, ensuite, redémarrer le service mysql.

Reborn
Messages : 10
Inscription : 09 août 2015, 15:01

Re: Problème de connexion MySQL à une machine virtuel

Message par Reborn » 10 août 2015, 03:04

De cette manière?

Code : Tout sélectionner

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

[mysqld]
bind-address=192.168.1.131
Concernant le scan nmap via la commande cmd de mon ordinateur :

Code : Tout sélectionner

Microsoft Windows [version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Tous droits réservés.

C:\Users\Rémi>nmap 192.168.1.131

Starting Nmap 6.49BETA3 ( https://nmap.org ) at 2015-08-10 03:02 Paris, Madrid (
heure d?ÚtÚ)
Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn

Nmap done: 1 IP address (0 hosts up) scanned in 3.56 seconds

C:\Users\Rémi>
Et même en désactivant mon pare-feu windows j'ai encore l'erreur.

Beta-Pictoris
Messages : 993
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème de connexion MySQL à une machine virtuel

Message par Beta-Pictoris » 10 août 2015, 14:01

Tu as, déjà, une section mysqld en début de fichier. Il ne faut pas en créer une autre.

Tu dois,ensuite, arrêter le pare-feu et redémarrer mysql:

Code : Tout sélectionner

service iptables stop
service mysql restart
Vérifie, aussi, l'adresse ip de ton serveur:

Code : Tout sélectionner

ip a

Reborn
Messages : 10
Inscription : 09 août 2015, 15:01

Re: Problème de connexion MySQL à une machine virtuel

Message par Reborn » 10 août 2015, 15:46

D'accord et désolé je suis pas très compétent dans se domaine.

Donc je rajoute la ligne de cette façon?

Code : Tout sélectionner

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
bind-address=192.168.1.131
Par contre pour redémarrer mon mysql pour moi c'est

Code : Tout sélectionner

service mysqld restart
et après avoir rajouté le

Code : Tout sélectionner

bind-address=192.168.1.131
mysql ne veut plus démarrer.

Concernant l'IP

Code : Tout sélectionner

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:0c:29:d5:39:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.198.131/24 brd 192.168.198.255 scope global eth0
    inet6 fe80::20c:29ff:fed5:3928/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:0c:29:d5:39:32 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::20c:29ff:fed5:3932/64 scope link 
       valid_lft forever preferred_lft forever

Reborn
Messages : 10
Inscription : 09 août 2015, 15:01

Re: Problème de connexion MySQL à une machine virtuel

Message par Reborn » 10 août 2015, 15:57

Bon après quelques manip...

J'ai rajouté

Code : Tout sélectionner

bind-address=192.168.198.131
et mysql redémarre normalement.

Résultat de netstat

Code : Tout sélectionner

[root@localhost reborn]# netstat -ntlp | grep 3306
tcp        0      0 192.168.198.131:3306        0.0.0.0:*                   LISTEN      6056/mysqld 


Et de ip a

Code : Tout sélectionner

[root@localhost reborn]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:0c:29:d5:39:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.198.131/24 brd 192.168.198.255 scope global eth0
    inet6 fe80::20c:29ff:fed5:3928/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:0c:29:d5:39:32 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::20c:29ff:fed5:3932/64 scope link 
       valid_lft forever preferred_lft forever
et maintenant je ne peux plus me connecter à mysql sur mon serveur linux, du coup j'ai mis blind-address=0.0.0.0. en attendant et je peux de nouveau me connecter à mysql depuis linux mais toujours pas depuis windows. Une aide de votre part via skype ou teamveiwer serait-elle possible? Merci

Répondre