Page 1 sur 1

Compilation V8Js, Erreur...

Publié : 13 octobre 2015, 22:37
par dotMastaz
Bonjour,

J'essaie de compiler la lib v8js, mais je suis confronté à une erreur.
Il ne semble pas 'detecter' quelle est la version installé de la lib V8 ?

Voici pas à pas l'install :

1°: yum install epel-release

2°: yum install -y --enablerepo=epel v8 v8-devel

3° : pecl install v8js-0.2.0 || true

4° Error : checking for V8 version... NONE
configure: error: could not determine libv8 version

Une idée ?

Re: Compilation V8Js, Erreur...

Publié : 14 octobre 2015, 06:54
par remi
L'extension pecl/v8js n'est pas compatible avec v8js de EPEL (v3.14.5.10, utilisé par nodejs) mais nécessite une version > 3.24.6 et < 4.3)

P.S. et sinon, l'application serait dans mon dépôt... ;)

Re: Compilation V8Js, Erreur...

Publié : 14 octobre 2015, 14:18
par dotMastaz
Merci à toi pour cette réponse !
Alors comment dois-je mettre à jour EPEL ?