Centos6.5/spotify

numér!s
Messages : 2
Inscription : 22 novembre 2015, 15:20
Contact :

Centos6.5/spotify

Message par numér!s » 22 novembre 2015, 15:26

Bonjour,

J'ai installé spotify à partir du dépot ulyaoth pour centos6 https://www.ulyaoth.net/resources/spotify.14/.
Quand je lance spotify, j'ai le message d'erreur suivant :

spotify: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or director

Après quelques recherches, j'ai essayé une solution :
locate libudev.so
/lib64/libudev.so.0
/lib64/libudev.so.0.5.1
/usr/lib64/libudev.so.0
/usr/lib64/libudev.so.0.13.1

ln -sf /lib64/libudev.so.0 /lib64/libudev.so.1
... qui m'a valu un crash monumental :cry: . Le système n'a pas apprécié.

Suggestions ?

Beta-Pictoris
Messages : 962
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Centos6.5/spotify

Message par Beta-Pictoris » 22 novembre 2015, 16:00

Tu peux vérifier les bibliothèques nécessaires via la commande ldd.
Je veux, par exemple, connaître les bibliothèques nécessaires au programme /bin/bash:

Code : Tout sélectionner

$ ldd /bin/bash
	linux-vdso.so.1 =>  (0x00007fffa45df000)
	libtinfo.so.5 => /lib64/libtinfo.so.5 (0x00007fe4e9584000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007fe4e9380000)
	libc.so.6 => /lib64/libc.so.6 (0x00007fe4e8fbe000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fe4e97c5000)
Il est possible que tu n'aies pas la bonne version de la bibliothèque libudev.
A noter, la libudev.so.1 est disponible, nativement, sur centos 7, aussi bien, en 32 qu'en 64 bits.

numér!s
Messages : 2
Inscription : 22 novembre 2015, 15:20
Contact :

Re: Centos6.5/spotify

Message par numér!s » 22 novembre 2015, 16:20

Bonjour Beta-Pictoris,

Merci pour ta réponse :D . Je vais opérer un upgrade vers Centos 7.

Répondre