Spawn-fcgi qui ne démarre pas

Avatar de l’utilisateur
Loup-des-Neiges
Messages : 78
Inscription : 20 octobre 2009, 23:29
Localisation : Cannes (06)
Contact :

Spawn-fcgi qui ne démarre pas

Message par Loup-des-Neiges » 25 août 2011, 10:46

Salut,

sur installation toute neuve de lighttpd/php/mysql, juste un petit problème !
Le service "spawn-fcgi" ne se lance pas. Aucun message d'erreur, juste "Échoué"
sur un "service spawn-fcgi start" ou sur le "boot.log" même message.

Je ne trouve pas de fichier log mais après analyse du fichier "/etc/init.d/spawn-fcgi",
il a besoin de :

Code : Tout sélectionner

# Required-Start: $local_fs $network $remote_fs $named
Pour network & named, c'est ok mais il me manque les services local_fs & remote_fs.
C'est la cause de mon erreur ? A quel packet correspondent t-ils ?

Marci
Serveur(s) : [home/serveur-1/serveur-2].loup-des-neiges.com
CentOS : 6 CR
Utilisateur des dépôts : RHEL, REMI

MarbolanGos
Messages : 341
Inscription : 26 octobre 2009, 19:03

Re: Spawn-fcgi qui ne démarre pas

Message par MarbolanGos » 25 août 2011, 15:51

En cherchant dans yum ce spawn-fcgi je suis tombé sur : lighttpd-fastcgi

Si c'est la même chose : http://www.cyberciti.biz/tips/lighttpd- ... ation.html
http://rarebril.com/blog
http://www.smolts.org/client/show/pub_d44745d4-fc38-4d31-a94c-499e6e1838ea

Avatar de l’utilisateur
Loup-des-Neiges
Messages : 78
Inscription : 20 octobre 2009, 23:29
Localisation : Cannes (06)
Contact :

Re: Spawn-fcgi qui ne démarre pas

Message par Loup-des-Neiges » 25 août 2011, 19:48

Salut,

nop, pour la config c'est ok ;)
Sinon, j'avance avec un vrais message d'erreur maintenant !
J'ai mis la main sur le fichier de configuration de Spawn-fcgi :

Code : Tout sélectionner

[root@serveur ~]# cat /etc/sysconfig/spawn-fcgi
OPTIONS="-a 127.0.0.1 -p 9001 -P /var/run/spawn-fcgi.pid -- /usr/bin/php-cgi"
Donc maintenant :

Code : Tout sélectionner

[root@serveur ~]# service spawn-fcgi start
spawn-fcgi: child exited with: 2
Serveur(s) : [home/serveur-1/serveur-2].loup-des-neiges.com
CentOS : 6 CR
Utilisateur des dépôts : RHEL, REMI

Répondre