[Résolu] Utilisation de postfix pour l'envoi uniquement

Avatar de l’utilisateur
Loup-des-Neiges
Messages : 78
Inscription : 20 octobre 2009, 23:29
Localisation : Cannes (06)
Contact :

[Résolu] Utilisation de postfix pour l'envoi uniquement

Message par Loup-des-Neiges » 03 septembre 2011, 21:23

Salut,

J'ai sur mon serveur web un postfix que je n'utilise que pour l'envoi (mail de php, logwatch etc)
car j'utilise un autre serveur pour la gestion complète de mes mails.

Le problème, c'est que mon serveur web a le même domaine que le serveur qui traite mes mails.
(serveur1.loup-des-neiges.com / serveur2.loup-des-neiges.com)

Alors quand un e-mail de mon serveur web part sur par exemple "user@loup-des-neiges.com", il reste en local
sur mon serveur web avec une jolie erreur que je résume par la dernière ligne :

Code : Tout sélectionner

Diagnostic-Code: X-Postfix; unknown user: "user"
Comment faire pour qu'il ne garde qu'un fonction d'envoyeur ?
(Configuration d’origine pour le moment)

Merci !
Dernière modification par Loup-des-Neiges le 04 septembre 2011, 14:35, modifié 1 fois.
Serveur(s) : [home/serveur-1/serveur-2].loup-des-neiges.com
CentOS : 6 CR
Utilisateur des dépôts : RHEL, REMI

Avatar de l’utilisateur
Loup-des-Neiges
Messages : 78
Inscription : 20 octobre 2009, 23:29
Localisation : Cannes (06)
Contact :

Re: Utilisation de postfix pour l'envoi uniquement

Message par Loup-des-Neiges » 04 septembre 2011, 14:34

Solution :

dans "/etc/postfix/main.cf" :

Code : Tout sélectionner

mydestination = $myhostname localhost.$mydomain localhost
relayhost = [smtp.serveur2.$mydomain]
Serveur(s) : [home/serveur-1/serveur-2].loup-des-neiges.com
CentOS : 6 CR
Utilisateur des dépôts : RHEL, REMI

Répondre