Connexion à distance depuis Windows

Avatar de l’utilisateur
nouvo09
Messages : 2195
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Connection à distance depuis Windows

Message par nouvo09 » 01 février 2012, 15:29

N'oublie pas que tu as ssh, le client

et sshd, le serveur

et qu'il faut que les deux coincident.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

MarbolanGos
Messages : 341
Inscription : 26 octobre 2009, 19:03

Re: Connection à distance depuis Windows

Message par MarbolanGos » 01 février 2012, 15:49

J'ai rien compris...
Si la commande est effectuée sur le serveur lui-même autant faire un ssh -p 222 bibi@localhost
http://rarebril.com/blog
http://www.smolts.org/client/show/pub_d44745d4-fc38-4d31-a94c-499e6e1838ea

Avatar de l’utilisateur
Heldwin
Messages : 440
Inscription : 20 octobre 2009, 10:11
Localisation : Unknown

Re: Connection à distance depuis Windows

Message par Heldwin » 02 février 2012, 00:17

paul18 a écrit :juste le serveur, dans un shell, j'ai fait:
ssh -p 222 bibi@ip_serveur

(en root)

il me refus l'accès ....
(edit: Je pensais que le port devait être fermé, mais en faite, depuis le serveur lui-même, le port n'a pas besoin d'être ouvert, même si on utilise l'ip ip_serveur)
Mais pourquoi 22 pour le ftp ? c'est 23 généralement.

Si tu tiens à changer de port tes serveurs, je les mettrais au-dessus de 1024, pour éviter les conflits avec les autres programmes qui ont des ports par défaut.
(quitte à rajouter des 2, autant en mettre un de plus et faire 2222)

EDIT:

Tu peux aussi essayer:

Code : Tout sélectionner

service sshd status
Après avoir updaté mon système, un service sshd restart, a indiqué des OK, mais en fait il était arrêté.
sshd semble maintenant refuser de démarrer sur le port 222 même après un reboot, alors qu'avant il acceptait.

Il semble même refuser tous les ports en-dessous de 1024, à part le port 22.

EDIT2:

Quelqu'un m'a indiqué que ça venait de selinux qui vérifie maintenant le port.
Ce qui est vrai, puisqu'avec un: setenforce 0, le service démarre avec un port inférieur.

Mais le wiki de centos recommande également de mettre un port au-dessus de 1024.
http://wiki.centos.org/HowTos/Network/SecuringSSH (point 5)

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Re: Connection à distance depuis Windows

Message par paul18 » 02 février 2012, 09:50

Salut,

je n'avais pas vu cette histoire de port ...

je résume donc :
- ajout du port dans /etc/sysconfig/iptables
- ajout du port + paramétrage dans /etc/ssh/sshd_config
- ajout du port dans /etc/nxserver/node.conf

redémarrage du serveur (service sshd restart)

installation du client NoMachine ... je note au passage que le port 22 est à nouveau bloqué !!!!

je lance le client ... et ....

le début du message montre qu'il pointe bien sur le serveur avec le bon port ... par contre je ne comprends pas qu'il pointe sur l'user nx alors que j'ai mis à jour AllowUsers .. et enfin ça plante à l'affichage !!!

???????

Paul
###################################################################""

NX> 203 NXSSH running with pid: 432
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: XX.X.X.XX on port: YYYY
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: not detected)
NX> 105 hello NXCLIENT - Version 3.2.0
NX> 134 Accepted protocol: 3.2.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: bibi
NX> 102 Password:
NX> 103 Welcome to: VMware-linux user: bibi
NX> 105 listsession --user="bibi" --status="suspended,running" --geometry="1920x1200x32+render" --type="unix-gnome"
NX> 127 Sessions list of user 'bibi' for reconnect:

Display Type Session ID Options Depth Screen Status Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: bibi
NX> 105 startsession --link="lan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="VMware-linux" --type="unix-gnome" --geometry="1024x768" --client="winnt" --keyboard="pc102/fr" --screeninfo="1024x768x32+render"

NX> 1000 NXNODE - Version 3.2.0-74-SVN OS (GPL, using backend: not detected)
NX> 700 Session id: VMware-linux-1000-D021E74E8E4B8226536E8FEE9592FF31
NX> 705 Session display: 1000
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: 5f6afdc684b3daeb050296ff4c671110
NX> 702 Proxy IP: 10.0.4.20
NX> 706 Agent cookie: 5f6afdc684b3daeb050296ff4c671110
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
NX> 105 /usr/bin/nxnode: line 554: 12175 Complété PATH="$PATH_BIN:$PATH" $PATH_BIN/nxagent $P $R -name "NX - $user@$SERVER_NAME:$display - $session (GPL Edition)" -option "$USER_FAKE_HOME/.nx/C-$sess_id/options" $B $FP $AGENT_EXTRA_OPTIONS_X :$display 2>&3
/usr/bin/nxserver: line 1531: 11909 Terminated sleep $AGENT_STARTUP_TIMEOUT
xrdb: No such file or directory
xrdb: Can't open display ':1000'

** (gnome-session:12206): WARNING **: Impossible d'ouvrir l'affichage :
NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate "/home/bibi/.nx/F-C-VMware-linux-1000-D021E74E8E4B8226536E8FEE9592FF31/session". You might also want to try: ssh -X myserver; /usr/bin/nxnode --agent to test the basic functionality. Session log follows:
Can't open /var/lib/nxserver/db/running/sessionId{D021E74E8E4B8226536E8FEE9592FF31}: No such file or directory.
NX> 1006 Session status: closed
mv: cannot stat `/var/lib/nxserver/db/running/sessionId{D021E74E8E4B8226536E8FEE9592FF31}': No such file or directory
NX> 1001 Bye.
NX> 280 Exiting on signal: 15

Avatar de l’utilisateur
Heldwin
Messages : 440
Inscription : 20 octobre 2009, 10:11
Localisation : Unknown

Re: Connection à distance depuis Windows

Message par Heldwin » 04 février 2012, 02:41

Donc c'est avec freenx qu'il y a un problème. Ca aurait simplifié si tu avais indiqué quels programmes tu utilisais...
-> http://wiki.centos.org/HowTos/FreeNX

Je viens d'essayer, et je parviens à me connecter avec le client NoMachine que j'ai téléchargé.
Comme je suis en 64 bits, et le client en 32 bits, installer le rpm avec yum a résolu les dépendances 32 bits.

J'ai mis le port 2628 pour ssh, donc en plus des changements de la doc du wiki, j'ai changé cette ligne dans node.conf:
SSHD_PORT=2628
Après un:

Code : Tout sélectionner

service freenx-server restart
j'ai pu m'y connecter sans problème (tu n'as pas indiqué que tu avais redémarré le server freenx).

EDIT:
Tu n'as pas indiqué si tu arrivais à te connecter en ssh, ou ssh -X, sans passer par NoMachine.

EDIT2:
As-tu essayé avec le client NoMachine sur ta machine virtuelle vmware centos ?
Je n'ai pas essayé depuis windows, car chez moi je n'ai plus aucun windows depuis environ 3 ans ... :)

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Connection à distance depuis Windows

Message par paul18 » 06 février 2012, 09:45

Salut,

ça marche maintenant avec le nouveau port .... le seule chose que je n'avais pas faite c'est le "service freenx-server restart" (mais pas indiqué dans le tutorial)

... en revanche le port 22 est à nouveau bloqué quand je lance le serveur sshd !!!!

2 solutions :
- où je trouve le pb,
- où je trouve une autre façon de gérer mes transferts ftp (via fillezilla)

Paul

Avatar de l’utilisateur
Heldwin
Messages : 440
Inscription : 20 octobre 2009, 10:11
Localisation : Unknown

Re: Connection à distance depuis Windows

Message par Heldwin » 06 février 2012, 21:03

Tu peux indiquer les messages d'erreurs complets ? Ca aiderait.

* Tu es sûr de ne pas avoir 2 déclarations de ports dans sshd_config ?

Code : Tout sélectionner

grep -i "port " /etc/ssh/sshd_config
* Pourquoi tiens-tu à utiliser le port 22 pour le FTP ?
Que retourne:

Code : Tout sélectionner

netstat -laputen

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Re: Connexion à distance depuis Windows

Message par paul18 » 08 février 2012, 17:39

Salut,

J'ai pas mal de choses à faire en ce moment ... je regarde ça plutôt début de semaine prochaine (je pense) !

@+

Paul

Répondre