[RESOLU] dedibox yum & wget ko

warner
Messages : 13
Inscription : 11 août 2010, 19:13

[RESOLU] dedibox yum & wget ko

Message par warner » 18 avril 2012, 14:54

Bonjour a tous et a toutes :)

Alors, voila je ne sais pas si l'un ou l'une d'entre vous ont déjà rencontré se problème mais j'ai un petit soucis avec mon serveur dédié (online.net : dedibox SC) qui est sous centos 6.2 x64 (fresh install) : en fait dés que je veux effectuer un yum upgrade ou bien un wget j'ai des réponses négatives :

Code : Tout sélectionner

[root@sd-***** ~]# yum upgrade
Loaded plugins: fastestmirror
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os error was
14: PYCURL ERROR 6 - "Couldn't resolve host 'mirrorlist.centos.org'"
Error: Cannot find a valid baseurl for repo: base
et wget :

Code : Tout sélectionner

[root@sd-***** ~]# wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-5.noarch.rpm
--2012-04-18 12:46:58--  http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-5.noarch.rpm
Résolution de download.fedoraproject.org... échec: Nom ou service inconnu.
wget : impossible de résoudre l'adresse de l'hôte «download.fedoraproject.org»
voici mon fichier ifcfg-eth0 (je n'ai rien modifier du tout c'est le fichier que j'ai direct après le formatage du serveur) :

Code : Tout sélectionner

DEVICE=eth0
BOOTPROTO=static
IPADDR=***.***.***.***
NETMASK=255.255.255.0
GATEWAY=***.**.***.***
HWADDR=**:**:**:**:**:**
ONBOOT=yes
METRIC=5
DNS1=127.0.0.1
DNS2=88.191.254.60
DNS3=88.191.254.70
RESOLV_MODS=no
LINK_DETECTION_DELAY=6
Pourquoi le 127.0.0.1 dans DNS1 ? :s

et voici le fichier modifier ensuite par mes soins :

Code : Tout sélectionner

DEVICE=eth0
BOOTPROTO=static
IPADDR=***.***.***.***
NETMASK=255.255.255.0
GATEWAY=***.***.***.***
HWADDR=**:**:**:**:**:**
ONBOOT=yes
METRIC=5
DNS1=8.8.8.8
DNS2=8.8.8.8
RESOLV_MODS=no
LINK_DETECTION_DELAY=6
j'ai mis les dns de google et la je peux faire du yum upgrade a tout va et également du wget MAIS mon site (blog wordpress : apache/mysql/php) n'est plus accessible :(

Je précise que même en désactivant iptables / selinux et fail2ban : la problématique reste la même.

Merci d'avance a ceux et celles qui pourrait avoir une idée sur éventuelle solution



EDIT :

finalement après plusieurs essai d'autres distro il s’avère que c'est seulement avec centos que le problème se pose donc bref pas grave je reste avec ma dedibox mais en fedo 15 x64 :)

Répondre