Problème server DNS

jordane07
Messages : 1
Inscription : 07 juin 2012, 14:11

Problème server DNS

Message par jordane07 » 07 juin 2012, 14:54

Bonjour à tous :D !

Je viens d'installer une machine virtuelle CentOS sur un serveur Windows 2008 (hyper-v) pour y installer GLPI et OCS Inventory.
Après une longue matinée je suis enfin arrivé à y mettre ma carte réseau virtuelle et la configurer pour pouvoir accéder au réseau de l'entreprise et à internet !

les fichiers "ifcfg-eth0", "network" et "resolv.conf" sont ok mais j'ai un problème avec le serveur DNS !!!
En effet dans le fichier "resolv.conf" après avoir mis l'adresse du serveur DNS de l'entreprise je fais un petit "ifup eth0" et le fichier "resolv.conf" devient :

" # Generated by NetworkManger
search MonDomaine
Nameserver 192.169.X.X"

Exactement l'adresse de mon serveur DNS et le nom du domaine.

Vous allez me dire que jusqu'à là tout vas bien mais impossible d'aller sur internet en tapant l'url ("adresse introuvable"), alors qu'avec l'ip ça marche niquel, je peux accéder aux sites. Donc j'en déduis qu'il y a bien un soucis avec le serveur DNS mais je ne vois pas du tout... J'ai essayé d'y mettre le DNS de google 8.8.8.8 et 8.8.4.4 mais exactement le même soucis...
Je pense que le problème vient de ma machine car le serveur DNS marche pour au moins pour une cinquantaine de poste et 5/6 serveurs sur Windows xp, 7, 2003 ou bien 2008...
Je peux pinguer mon serveur ou bien pinguer les autres pc du réseaux de mon serveur le seul problème vient du DNS.

J'espère que vous allez pouvoir m'aider... :)

Merci d'avance!

Cordialement,
Jordane

jmb
Messages : 9
Inscription : 27 septembre 2012, 11:16

Re: Problème server DNS

Message par jmb » 28 septembre 2012, 16:32

Bonjour,

Ton interface est-elle en DHCP ?

Devinas
Messages : 1
Inscription : 07 juin 2013, 21:31

Re: Problème server DNS

Message par Devinas » 07 juin 2013, 21:40

Bonjour,

J'ai eu le même problème que vous. Mais à lire de très près le message d'erreur, Network Manager fait signifier qu'il n'a pas trouver de serveurs dns et recommande par conséquence de retourner dans le fichier /etc/sysconfig/network-scripts/ifcfg-ethX pour déclarer directement les dns sous la forme :

DNS1=xxxx.xxxx.xxxx.xxxx
DNS2=xxxx.xxxx.xxxx.xxxx

Voilà exactement ce que j'ai fait et ça a marché.

Répondre