dhcp : ne s'active pas au boot

Répondre
brunoL
Messages : 7
Inscription : 26 décembre 2013, 14:03

dhcp : ne s'active pas au boot

Message par brunoL » 27 août 2014, 21:44

Bonsoir,

Au boot, le réseau est actif mais eth0 n'est pas up. Il suffit de faire :
dhclient eth0
ou
ifup eth0
pour que tout soit OK.

Mon problème c'est qu'au boot suivant c'est à refaire.

Comment faire monter eth0 à chaque boot sans intervention manuelle.

Merci.

Avatar de l’utilisateur
nouvo09
Messages : 2159
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: dhcp : ne s'active pas au boot

Message par nouvo09 » 27 août 2014, 23:36

qu'y a-t-il dans ton fichier

/etc/sysconfig/network-scripts/ifcfg-eth0
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

brunoL
Messages : 7
Inscription : 26 décembre 2013, 14:03

Re: dhcp : ne s'active pas au boot

Message par brunoL » 28 août 2014, 12:47

mon fichier de config :
maya ~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
TYPE=Ethernet
UUID=8b11457f-94c8-40aa-b45a-9ede150ce381
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=dhcp
HWADDR=28:92:4A:34:52:60
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
HOSTNAME=maya.localdomain
En complément, le problème est survenu suite à une modification de routeur qui est passé de l'adresse 192.168.0.1 à 192.168.2.1 j'ai fait les mises à jour et je me demandes si le pb ne viens pas des fichiers leases qui actuellement contient :
maya ~]$ cat /var/lib/dhclient/dhclient-eth0.leases
lease {
interface "eth0";
fixed-address 192.168.2.53;
option subnet-mask 255.255.255.0;
option dhcp-lease-time 86400;
option routers 192.168.2.1;
option dhcp-message-type 5;
option dhcp-server-identifier 192.168.2.1;
option domain-name-servers 192.168.2.1;
renew 4 2014/08/28 04:50:34;
rebind 4 2014/08/28 14:50:07;
expire 4 2014/08/28 17:50:07;
}
lease {
interface "eth0";
fixed-address 192.168.2.53;
option subnet-mask 255.255.255.0;
option routers 192.168.2.1;
option dhcp-lease-time 86400;
option dhcp-message-type 5;
option domain-name-servers 192.168.2.1;
option dhcp-server-identifier 192.168.2.1;
renew 4 2014/08/28 03:14:16;
rebind 4 2014/08/28 14:53:01;
expire 4 2014/08/28 17:53:01;
}
lease {
interface "eth0";
fixed-address 192.168.2.53;
option subnet-mask 255.255.255.0;
option routers 192.168.2.1;
option dhcp-lease-time 86400;
option dhcp-message-type 5;
option domain-name-servers 192.168.2.1;
option dhcp-server-identifier 192.168.2.1;
renew 4 2014/08/28 14:11:15;
rebind 5 2014/08/29 00:14:17;
expire 5 2014/08/29 03:14:17;
}
[alain@maya
Je trouve les expire bizarre. L'adresse 53 est fixée au niveau du routeur. Merci de ton aide

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: dhcp : ne s'active pas au boot

Message par Beta-Pictoris » 28 août 2014, 16:02

Regarde dans /var/log/messages les messages d'erreurs liés à ton interface réseau.

Avatar de l’utilisateur
nouvo09
Messages : 2159
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: dhcp : ne s'active pas au boot

Message par nouvo09 » 28 août 2014, 16:32

Je vois que cette interface est contrôlée par NetworkManager.

Tu peux vérifier les options dans celui-ci ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

brunoL
Messages : 7
Inscription : 26 décembre 2013, 14:03

Re: dhcp : ne s'active pas au boot

Message par brunoL » 28 août 2014, 17:28

les messages n'affichent pas de problème :
maya ~]$ sudo grep eth /var/log/messages
Aug 27 19:50:06 maya dhclient[2593]: DHCPREQUEST on eth0 to 255.255.255.255 port 67 (xid=0x2d29110)
Aug 27 19:50:10 maya ntpd[1505]: Listen normally on 7 eth0 192.168.2.53 UDP 123
Aug 27 19:51:24 maya kernel: tg3 0000:02:00.0: eth0: Tigon3 [partno(BCM95723) rev 5784100] (PCI Express) MAC address 28:92:4a:34:52:60
Aug 27 19:51:24 maya kernel: tg3 0000:02:00.0: eth0: attached PHY is 5784 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
Aug 27 19:51:24 maya kernel: tg3 0000:02:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
Aug 27 19:51:24 maya kernel: tg3 0000:02:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
Aug 27 19:51:24 maya kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Aug 27 19:51:35 maya kernel: tg3 0000:02:00.0: eth0: Link is up at 100 Mbps, full duplex
Aug 27 19:51:35 maya kernel: tg3 0000:02:00.0: eth0: Flow control is on for TX and on for RX
Aug 27 19:51:35 maya kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Aug 27 19:51:39 maya ntpd[1499]: Listen normally on 4 eth0 fe80::2a92:4aff:fe34:5260 UDP 123
Quant au paramétrage de network-manager je n'y ai pas vu de référence à l'ancien réseau.
À quel niveau un dhcp sur une liaison ethernet peut-il bloquer sachant qu'une intervention manuelle simplissime rétablit la situation ?
A moins que dhclient ne soit pas activé au boot, comment l'identifier ?

Merci.

Avatar de l’utilisateur
nouvo09
Messages : 2159
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: dhcp : ne s'active pas au boot

Message par nouvo09 » 28 août 2014, 20:20

Code : Tout sélectionner

Aug 27 19:51:35 maya kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
et malgré ça, ta connexion n'est pas établie ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

brunoL
Messages : 7
Inscription : 26 décembre 2013, 14:03

Re: dhcp : ne s'active pas au boot

Message par brunoL » 29 août 2014, 08:33

En tout cas inexploitable sans un

Code : Tout sélectionner

$sudo dhclient eth0
que je dois faire à chaque boot.

Comment faire exécuter ce dhclient systématiquement au boot ?
Ce qui jusqu'à mon changement de routeur se faisait !

Merci.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: dhcp : ne s'active pas au boot

Message par Beta-Pictoris » 29 août 2014, 13:54

Tu ne nous montre pas tous les messages du fichier de log.

Vide le fichier de log et montre nous les messages après un redémarrage de ta machine.

brunoL
Messages : 7
Inscription : 26 décembre 2013, 14:03

Re: dhcp : ne s'active pas au boot

Message par brunoL » 31 août 2014, 11:22

Désolé pour le temps à répondre mais ce truc m'a pris le choux ;-)

En fait, centOs n'y était pour rien. C'est le routeur qui avait des vapeurs. Un reset a réglé le problème. Ça a été difficile car le comportement de ce routeur dépendait de la machine connectée ??!!

J'ai 2 prises éthernet sur 4 HS ... peut être le dernier orage ?

Merci à vous deux pour votre aide.
A+

Répondre