Problème connexion sortante

x@vier006
Messages : 17
Inscription : 04 septembre 2014, 13:25
Localisation : Liège, Belgique

Re: Problème connexion sortante

Message par x@vier006 » 08 septembre 2014, 14:59

Non elle ne le connait pas mais elle est connectée à un switch où le routage à été configuré. D'ailleurs si depuis ma machine de test je tente de pinger une autre machine sur le vlan 101 il n'y a pas de soucis. Seul mon seurveur ne répond pas et comme je l'ai dit plus haut, je reçoit bien les ping dans celui-ci visible dans wireshark. Le problème est qu'il n'y répond pas sauf si j'ajoute, sur le serveur, sur ma eth0 (vlan 101) un route statique vers le vlan 100 mais dans ce cas je perd la connexion à internet. Utilise t'il cette route par défaut même poue se connecter sur les autres réseaux ? bizarre ... J'ai essayer de configuré le Métric sur cette route mais dans le cas où il n'est pas à zéro, il ne l'utilise simplement plus.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème connexion sortante

Message par Beta-Pictoris » 08 septembre 2014, 15:02

Si j'ai bien compris, ton serveur centos ne fait pas office de routeur entre les 2 vlans ?

x@vier006
Messages : 17
Inscription : 04 septembre 2014, 13:25
Localisation : Liège, Belgique

Re: Problème connexion sortante

Message par x@vier006 » 08 septembre 2014, 15:07

Non du tout. Mon centos est en fait un serveur NAC (packetfence) c'est pourquoi j'ai 2 cartes réseaux connectée sur 2 vlans différents (une sur le vlan management qui contient mes serveurs et unique les serveurs et une sur le vlan Employé avec en plus les vlan isolation et registration propre à packetfence). Je dois pourvoir me connecter sur mon interface sur le vlan 101 depuis mon vlan 100 pour administrer mon packetfence. Pour ce qui est du routage ce sont les switches qui s'en occupent.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème connexion sortante

Message par Beta-Pictoris » 08 septembre 2014, 15:13

Tu as bien désactivé le parefeu en faisant un service iptables stop ?

Désactive aussi selinux par un setenforce 0 pour voir ce que cela donne.

x@vier006
Messages : 17
Inscription : 04 septembre 2014, 13:25
Localisation : Liège, Belgique

Re: Problème connexion sortante

Message par x@vier006 » 08 septembre 2014, 15:14

Oui c'était fait :/ C'est dans les recommandation de packetfence.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème connexion sortante

Message par Beta-Pictoris » 08 septembre 2014, 15:27

En résumé, ta centos est connecté sur le vlan 100, ...mais ne connaît pas ce vlan 100, parce que les paquets provenant du vlan 100 arrivent par le vlan 101.

L'interface se trouvant sur le vlan 101 a t'elle une passerelle par défaut ? A moins que ce soit l'interface se trouvant sur le vlan 100 ? Ou les 2 ?

x@vier006
Messages : 17
Inscription : 04 septembre 2014, 13:25
Localisation : Liège, Belgique

Re: Problème connexion sortante

Message par x@vier006 » 08 septembre 2014, 15:50

Non pas de passerelle sur le vlan 101. Ma passerelle est sur ma Eth1 (vlan 100).

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème connexion sortante

Message par Beta-Pictoris » 08 septembre 2014, 16:26

Si tu ne veux pas de passerelle par défaut ou de route sur le vlan 101, ta centos doit alors fonctionner comme routeur.
Que donne les commandes suivantes ? :

Code : Tout sélectionner

sysctl net.ipv4.ip_forward
route
Dernière modification par Beta-Pictoris le 08 septembre 2014, 19:44, modifié 1 fois.

x@vier006
Messages : 17
Inscription : 04 septembre 2014, 13:25
Localisation : Liège, Belgique

Re: Problème connexion sortante

Message par x@vier006 » 08 septembre 2014, 16:32

La solution de la route vers le vlan 100 me plait bien mais lorsque je la crée, j'accède bien à mon vlan 100 mais je perd la connexion à Internet.

Résultat de la commande :

Code : Tout sélectionner

[root@VM-CENTOS65-01 pk]# sysctl net.ipv4.ip_forward
net.ipv4.ip_forward = 1
[root@VM-CENTOS65-01 pk]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.100.0   *               255.255.255.0   U     1      0        0 eth1
192.168.101.0   *               255.255.255.0   U     1      0        0 eth0
192.168.98.0    *               255.255.255.0   U     11     0        0 eth1.98
192.168.99.0    *               255.255.255.0   U     11     0        0 eth1.99
default         192.168.100.254 0.0.0.0         UG    0      0        0 eth1
[root@VM-CENTOS65-01 pk]# 
Merci beaucoup

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème connexion sortante

Message par Beta-Pictoris » 08 septembre 2014, 16:41

Et aussi ceci:

Code : Tout sélectionner

cat /etc/sysconfig/network-scripts/ifcfg-eth0
cat /etc/sysconfig/network-scripts/ifcfg-eth1

Répondre