Page 3 sur 3

Re: Problème connexion sortante

Publié : 08 septembre 2014, 16:46
par x@vier006

Code : Tout sélectionner

[root@VM-CENTOS65-01 pk]# cat /etc/sysconfig/network-scripts/ifcfg-Eth0
TYPE=Ethernet
BOOTPROTO=none
IPADDR=192.168.101.104
PREFIX=24
DNS1=192.168.100.53
DNS2=192.168.0.200
DOMAIN=*******.local
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME=Eth0
UUID=843fab83-2682-4825-958f-37f06c07e67a
ONBOOT=yes
HWADDR=00:50:56:9C:9E:59
LAST_CONNECT=1410179054
[root@VM-CENTOS65-01 pk]# cat /etc/sysconfig/network-scripts/ifcfg-Eth1
TYPE=Ethernet
BOOTPROTO=none
IPADDR=192.168.100.31
PREFIX=24
GATEWAY=192.168.100.254
DNS1=192.168.100.54
DOMAIN=***********.local
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME=Eth1
UUID=22736243-b083-4d2a-a5ec-8193a71a812d
ONBOOT=yes
HWADDR=00:50:56:9C:FA:E8
LAST_CONNECT=1409668262

Re: Problème connexion sortante

Publié : 08 septembre 2014, 16:49
par x@vier006
Au cas ou ...

Code : Tout sélectionner

 cat /etc/sysconfig/network
NETWORKING=yes NETWORKING_IPV6=no HOSTNAME=VM-CENTOS65-01.********.local NTPSERVERARGS=iburst NM_BOND_BRIDGE_VLAN_ENABLED=yes
[root@VM-CENTOS65-01 pk]# cat /etc/resolv.conf 
# Generated by NetworkManager
search ******.local
nameserver 192.168.100.54
nameserver 192.168.100.53
nameserver 192.168.0.200

Re: Problème connexion sortante

Publié : 08 septembre 2014, 17:11
par Beta-Pictoris
Essaye ceci.

Re: Problème connexion sortante

Publié : 08 septembre 2014, 17:18
par x@vier006
ok pour les deux première commandes mais erreur sur la 3eme

Code : Tout sélectionner

 sysctl -w net.ipv4.conf.ppp0.rp_filter=0
error: "net.ipv4.conf.ppp0.rp_filter" is an unknown key
Je cherche une solution sur le net.

Re: Problème connexion sortante

Publié : 08 septembre 2014, 17:21
par Beta-Pictoris
Il faut que tu mettes le nom de tes interfaces réseau:

Code : Tout sélectionner

sysctl -w net.ipv4.conf.eth0.rp_filter=0
sysctl -w net.ipv4.conf.eth1.rp_filter=0
Ta machine n'a pas d'interface ppp0. C'est pour cette raison qu'il y a une erreur.

Re: Problème connexion sortante

Publié : 08 septembre 2014, 17:30
par x@vier006
Yeeeeeeeeeeeeeeeeeeeeeeeeah !!! Merci beaucoup ça fonctionne :D Trop fort !

Une dernière chose, les commande que je viens d'entrer sont des commande temporaire non ? Comment écrire ses paramètres en dur ? Je ne vois pas les options dans /etc/sysctl.conf

Un tout grand merci !

Re: Problème connexion sortante

Publié : 08 septembre 2014, 17:36
par Beta-Pictoris
Oui, c'est à toi d'ajouter les directives net.ipv4.... manquantes dans /etc/sysctl.conf, comme pour l'activation du routage.

En résumé, le noyau linux empêche que les réponses aux requêtes, provenant d'une interface réseau, sortent par une autre interface réseau.
En effet, l'adresse ip source utilisée pour la réponse n'est plus la même que l'adresse ip de destination des requêtes entrantes.
C'est un mécanisme anti-spoofing. C'est un risque pour la sécurité. Ah! the man in the middle. :twisted:

Re: Problème connexion sortante

Publié : 08 septembre 2014, 17:39
par x@vier006
Ok je comprend :) En tout cas cette sécurtité m'en aura fait baver !

Encore un énorme merci pour ton aide! A la prochaine,

Xavier.

Re: Problème connexion sortante

Publié : 08 septembre 2014, 20:22
par Beta-Pictoris
Une dernière chose: je ne suis pas certain que laisser actif net.ipv4.ip_forward soit utile dans ce cas. Teste après l'avoir désactiver pour voir.

Sinon, tu devrais vérifier pourquoi le fait d'ajouter une simple route vers le vlan 100 bloque l'accès internet. Il y a, peut-être, quelque chose à faire de ce coté.

Re: Problème connexion sortante

Publié : 09 septembre 2014, 07:59
par x@vier006
Oui ok je vais le désactiver. Et de fait, il faut que je fasse des test de ce côté là.