[Résolu] problème de DNS

Avatar de l’utilisateur
neowdj1
Messages : 262
Inscription : 25 octobre 2009, 23:30
Localisation : Lille

[Résolu] problème de DNS

Message par neowdj1 » 12 juillet 2011, 10:34

Bonjour à tous,

je viens d'installer sur mon laptop CentOS 6 et

j'ai un petit souci de dns qui m'empêche de contacter google.fr (par exemple)

Code : Tout sélectionner

voici mon resolv.conf
# Generated by NetworkManager
search famillewallon.local
nameserver 192.168.1.100 #DNSMASQ
nameserver 89.2.0.1 # numericable
si je fait un nslookup

Code : Tout sélectionner

[antoine@localhost ~]$ nslookup google.Fr
*Server:		192.168.1.100
Address:	192.168.1.100#53

** server can't find google.Fr: NXDOMAIN

et un wget idem

Code : Tout sélectionner

[antoine@localhost ~]$ wget google.fr
--2011-07-12 10:30:43--  http://google.fr/
Résolution de google.fr... échec: Nom ou service inconnu.
wget : impossible de résoudre l'adresse de l'hôte «google.fr»

Si je change l'ordre ca passe pour google.fr mais pas pour mon domaine local géré par Dnsmasq

Un idée ?
Dernière modification par neowdj1 le 12 juillet 2011, 20:17, modifié 1 fois.

Avatar de l’utilisateur
neowdj1
Messages : 262
Inscription : 25 octobre 2009, 23:30
Localisation : Lille

Re: problème de DNS

Message par neowdj1 » 12 juillet 2011, 11:02

finalement j'ai récupérer le hosts de mon serveur

Avatar de l’utilisateur
Arrfab
Administrateur
Messages : 307
Inscription : 16 octobre 2009, 18:04
Localisation : /dev/irc.freenode.net/#centos
Contact :

Re: problème de DNS

Message par Arrfab » 12 juillet 2011, 11:34

celà ressemble à une erreur de config dans dnsmasq. est-ce que tu l'as configuré aussi comme forwarder ?
----
test -e /dev/human/brain || ( echo 1 > /proc/sys/kernel/sysrq ; echo c > /proc/sysrq-trigger )

Avatar de l’utilisateur
neowdj1
Messages : 262
Inscription : 25 octobre 2009, 23:30
Localisation : Lille

Re: problème de DNS

Message par neowdj1 » 12 juillet 2011, 11:46

non mais j'ai le même souci avec le réseau de là ou je travail

voici mon dnsmasq @home

Code : Tout sélectionner

[root@octave ~]# cat /etc/dnsmasq.conf
domain-needed
bogus-priv
#filterwin2k
localise-queries
local=/local/
domain=famillewallon.local
expand-hosts
no-negcache
resolv-file=/tmp/resolv.conf.auto

dhcp-authoritative
dhcp-leasefile=/tmp/dhcp.leases

# use /etc/ethers for static hosts; same format as --dhcp-host
read-ethers

# Plage DHCP
#dhcp-range=eth1,192.168.10.1,192.168.10.99,48h

dhcp-range=eth0,192.168.1.2,192.168.1.99,48h

# Netmask
dhcp-option=1,255.255.255.0

# Route
dhcp-option=eth0,6,192.168.1.100,89.2.0.1

dhcp-option=eth0,3,192.168.1.100


# Serveur PXE
dhcp-boot=pxelinux.0,slug,192.168.1.100

# Enable dnsmasq's built-in TFTP server
enable-tftp
tftp-root=/tftpboot
# Alloue ip static
le service informatique m'a conseillé de faire un copie de mon hosts et de le transposer sur mon ldaptop étant donnée que l'ip 192.168.1.100 est celle de mon serveur à la maison qui passe par VPN.

Avatar de l’utilisateur
Arrfab
Administrateur
Messages : 307
Inscription : 16 octobre 2009, 18:04
Localisation : /dev/irc.freenode.net/#centos
Contact :

Re: problème de DNS

Message par Arrfab » 12 juillet 2011, 11:55

Configure donc le forward dans dnsmasq.
quel est le contenu de ton fichier resolv qu'utilise dnsmasq ? (/tmp/resolv.conf.auto dans ton cas)
Je peux te garantir qu'un nombre incalculable de machines xen/vbox/kvm centos6 ont été déployées dans un vlan de test QA utilisant dnsmasq et il n'y avait pas de problèmes de résolution dns interne (centos.qa) et externe (via un resolv-file=/etc/CentOSQA/qa.resolv.conf , qui lui contient bien le traditionnel "nameserver x.x.x.x") :-)
----
test -e /dev/human/brain || ( echo 1 > /proc/sys/kernel/sysrq ; echo c > /proc/sysrq-trigger )

Avatar de l’utilisateur
neowdj1
Messages : 262
Inscription : 25 octobre 2009, 23:30
Localisation : Lille

Re: problème de DNS

Message par neowdj1 » 12 juillet 2011, 13:57

Arrfab a écrit :Configure donc le forward dans dnsmasq.
quel est le contenu de ton fichier resolv qu'utilise dnsmasq ? (/tmp/resolv.conf.auto dans ton cas)]
je me base sur le resolv conf classique le resolv.conf.auto étant vide

Code : Tout sélectionner

search famillewallon.local
nameserver 127.0.0.1
nameserver 89.2.0.1
nameserver 89.2.0.2[/code

question bête comment tu met en place le forward ? je cherche mais je trouve pas  :-(


[quote="Arrfab"]
Je peux te garantir qu'un nombre incalculable de machines xen/vbox/kvm centos6 ont été déployées dans un vlan de test QA utilisant dnsmasq et il n'y avait pas de problèmes de résolution dns interne (centos.qa) et externe (via un resolv-file=/etc/CentOSQA/qa.resolv.conf , qui lui contient bien le traditionnel "nameserver x.x.x.x") :-)[/quote]

je n'en doute pas

Avatar de l’utilisateur
neowdj1
Messages : 262
Inscription : 25 octobre 2009, 23:30
Localisation : Lille

[Résolu] Re: problème de DNS

Message par neowdj1 » 12 juillet 2011, 20:16

j'ai trouver comment mettre le forward

j'ai modifié la ligne
resolv-file=/etc/resolv.conf.auto

et j'ai créer le fichier resolv.conf.auto avec ceci

Code : Tout sélectionner

nameserver 89.2.0.1
nameserver 89.2.0.2

Répondre