Configuration VSFTP

F49G
Messages : 3
Inscription : 02 avril 2012, 15:08

Configuration VSFTP

Message par F49G » 02 avril 2012, 16:01

Bonjour à tous,
Je rencontre des difficultés dans la configuration de VsFTP (conf ci-dessous), le serveur s'obstine à refuser mes tentatives de connexion. Je me connecte, saisie ID & MDP et me fait bouler...
530 Login incorrect.
Login failed.
J'ai fait la conf en suivant la documentation http://www.centos.org/docs/5/html/Deplo ... conf.html#

# Configuration VsFTP
# By Francois on 04/02/2012

# Mode Standalone
listen=YES

# Pas de connexions anonymes
anonymous_enable=NO

# Utilisateurs locaux autorisés
local_enable=YES

# Seul les utilisateurs présents dans cette liste sont autorisés à se connecter
userlist_enable=NO
userlist_file=/etc/vsftp/user_list
userlist_deny=YES

# Les utilisateurs locaux sont bloqués dans leurs repertoires home
chroot_local_user=YES

# Enregistrement de toutes les actions

xferlog_enable=YES


Merci d'avance pour votre aide !

François.

Avatar de l’utilisateur
nouvo09
Messages : 1839
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Configuration VSFTP

Message par nouvo09 » 02 avril 2012, 18:34

Tu n'essaies pas de te connecter sous root ?

Tu as vérifié ce qu'il y a dans les fichiers list indiqués ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

F49G
Messages : 3
Inscription : 02 avril 2012, 15:08

Re: Configuration VSFTP

Message par F49G » 03 avril 2012, 09:39

Bonjour,

Non, j'essaye de me connecter avec un utilisateur standard.
Et dans mon fichier user_list, seul les deux utilisateurs que je souhaite voir se connecter sont présents.

A plus tard,
François.

Avatar de l’utilisateur
nouvo09
Messages : 1839
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Configuration VSFTP

Message par nouvo09 » 03 avril 2012, 12:12

Alors tu dois donner à userlist_deny la valeur NO
# vsftpd userlist
# If userlist_deny=NO, only allow users in this file
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

F49G
Messages : 3
Inscription : 02 avril 2012, 15:08

Re: Configuration VSFTP

Message par F49G » 03 avril 2012, 13:43

Ah ok,
Je me doutais que je m'embrouillais dans leurs explications :
userlist_deny — When used in conjunction with the userlist_enable directive and set to NO, all local users are denied access unless the username is listed in the file specified by the userlist_file directive. Because access is denied before the client is asked for a password, setting this directive to NO prevents local users from submitting unencrypted passwords over the network.

The default value is YES.
Maintenant, c'est le fichier contenant ma liste d'utilisateurs qu'il n'arrive pas à lire :

francois@fransuvi01:/usr/local/nagios/share$ ftp 99.61.86.99
Connected to 99.61.86.99.
500 OOPS: cannot read user list file:/etc/vsftp/user_list


Et pourtant j'ai fait le nécessaire sur les droits du fichier (chmod 644)...
Je continue de creuser !

Avatar de l’utilisateur
nouvo09
Messages : 1839
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Configuration VSFTP

Message par nouvo09 » 03 avril 2012, 16:20

tous les fichiers situés dans /etc/vsftpd doivent avoir les droits 600 et appartenir à root.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Répondre