VSFTPD & Apache

Nowis
Messages : 4
Inscription : 13 avril 2014, 14:07
Localisation : Rouen
Contact :

VSFTPD & Apache

Message par Nowis » 13 avril 2014, 14:25

Bonjour à tous !

Apprenti développeur informatique en BTS, je dois savoir monter un serveur Web pour mes examens. Je débute donc tout juste en réseau & serveur CentOS.

Je souhaite mettre en place un serveur Web local en utilisant les services VSFTPD et Apache 2. Je souhaite également n'utiliser que des utilisateurs virtuels.

Je bloque sur la configuration de VSFTPD. Je voudrais que la racine de ce dernier soit en /var/www/ et que chaque utilisateurs virtuels soient "bloqués" dans leur dossier comme par exemple : /var/www/nowis/.

Voici donc le fichier de configuration de VSFTPD :

Code : Tout sélectionner

# Ceci configure vsFTPd en mode "standalone"
listen=YES

# On désactive les connexions anonymes
# et on active les non-anonymes(c'est le cas des utilisateurs virtuels):
anonymous_enable=NO
local_enable=YES

# Pour des raisons de sécurité on interdit toute action d'écriture:
write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO

# 'guest_enable' est très important: cela active les utilisateurs virtuels!
# 'guest_username' fait correspondre tous les utilisateurs virtuels à
# l'utilisateur 'ftp' que nous avons défini plus haut, et au home
# correspondant: '/home/ftp/'.
guest_enable=YES
guest_username=apache
nopriv_user=apache
# On veut que les utilisateurs virtuels restent chez eux: '/home/ftp/'
chroot_local_user=YES

# On défini le nombre maximum de sessions à 200(les nouveaux clients recevront
# un message du genre: "erreur: serveur occupé").
# On défini le nombre maximum de sessions par IP à 4
max_clients=200
max_per_ip=4

####################################
# Debian customization             #
####################################
# Some of vsftpd's settings don't fit the Debian filesystem layout by
# default.  These settings are more Debian-friendly.
#
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd
#
# This string is the name of the PAM service vsftpd will use.
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/vsftpd.pem


## Activer la configuration per-user
user_config_dir=/etc/vsftpd/vsftpd_user_conf

## Dossier du FTP
local_root=/var/www/
Puis, voici le fichier de configuration de mon utilisateur virtuel "nowis" :

Code : Tout sélectionner

## l'utilisateur est enfermé dans un dossier déterminé
local_root=/var/www/nowis/

## on ne souhaite pas de lecture seule (Lecture seulement)
anon_world_readable_only=NO

## droit d'écriture(upload)
write_enable=YES
anon_upload_enable=YES

## créer des dossiers
anon_mkdir_write_enable=YES

## droit de renommer, supprimer...
anon_other_write_enable=YES
Je ne rencontre aucune difficulté pour me connecter. Par contre, une fois connecté au FTP via la console, lorsque je tape "pwd", j'obtient un "/". Cela signifie que je suis à la racine du CentOS ? De plus, la commande ls me retourne ceci :

Code : Tout sélectionner

227 Entering Passive Mode (127,0,0,1,196,55).
150 Here comes the directory listing.
226 Transfer done (but failed to open directory).
Un petit coup de main ? :lol:

Beta-Pictoris
Messages : 869
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: VSFTPD & Apache

Message par Beta-Pictoris » 13 avril 2014, 23:39

Nowis a écrit :
Je ne rencontre aucune difficulté pour me connecter. Par contre, une fois connecté au FTP via la console, lorsque je tape "pwd", j'obtient un "/". Cela signifie que je suis à la racine du CentOS ?
Non, tu est bien dans le répertoire que tu as défini, mais il y a un "chroot" qui est effectué.

Tu devrais mettre un fichier dans le répertoire en question et faire "ls" via ton client ftp pour vérifier que tu vois bien ce fichier.

Attention à selinux ! Il peux t'empécher le bon fonctionnnement su service ftp. S'il y a un problème, tu peux désactiver selinux, temporairement, en faisant un "setenforce 0".
Tu peux aussi désactiver, temporairement, le parefeu en faisant un "service iptables stop"

Avatar de l’utilisateur
nouvo09
Messages : 1813
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: VSFTPD & Apache

Message par nouvo09 » 14 avril 2014, 11:36

Chez moi le répertoire /var/www n'existe pas. Mais je n'ai pas installé Apache.

S'il existe chez toi, la première des choses est de voir à qui il appartient et quels sont les droits.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Nowis
Messages : 4
Inscription : 13 avril 2014, 14:07
Localisation : Rouen
Contact :

Re: VSFTPD & Apache

Message par Nowis » 14 avril 2014, 12:42

Beta-Pictoris a écrit : Attention à selinux ! Il peux t'empécher le bon fonctionnnement su service ftp. S'il y a un problème, tu peux désactiver selinux, temporairement, en faisant un "setenforce 0".
Tu peux aussi désactiver, temporairement, le parefeu en faisant un "service iptables stop"
En effet, c'était bien SElinux qui posé souci. Je l'ai désactivé totalement en modifiant son fichier de configuration, mais je ne suis pas sûr que ce soit très "propre" :lol:

Je suis confronté à un nouveau souci :

Je souhaite, depuis mon PC de bureau, accéder au FTP de mon serveur CentOS. Mon PC de bureau tourne sous Windows 7 et j'utilise le client FileZilla.
Je rentre donc l'IP local de mon serveur, l'identifiant et le mot de passe, ainsi que le numéro du port (22).
La connexion se fait mais bloque sur "Délai d'attente dépassé".

J'ai pourtant ouvert les port 21 et 22 du pare-feu du serveur ainsi que de ma Livebox.
Auriez-vous une solution ?

Avatar de l’utilisateur
nouvo09
Messages : 1813
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: VSFTPD & Apache

Message par nouvo09 » 14 avril 2014, 13:53

Je l'ai désactivé totalement en modifiant son fichier de configuration, mais je ne suis pas sûr que ce soit très "propre"
Ce serait quand même mieux de dire ce que tu as modifié, ça éviterait les tâtonnements.

Ensuite pour être sur qu'il s'agit bien d'une question de ports, arrête iptables, et refais le test.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Nowis
Messages : 4
Inscription : 13 avril 2014, 14:07
Localisation : Rouen
Contact :

Re: VSFTPD & Apache

Message par Nowis » 14 avril 2014, 18:08

Pour SElinux, j'ai édité le fichier de configuration : /etc/selinux/config.
J'ai mis l'attribut "SELINUX" en "disabled", ce qui donne :

Code : Tout sélectionner

SELINUX=disabled
Enfin, je viens de re-essayer de me connecter vi FileZilla, et j'ai un nouveau message d'erreur :

Code : Tout sélectionner

Statut :	Connexion à 192.168.1.32...
Réponse :	fzSftp started
Commande :	open "user1@192.168.1.32" 22
Erreur :	Network error: Connection refused
Erreur :	Impossible d'établir une connexion au serveur
Le fait de désactiver iptables avec la commande "service iptables stop" ne change rien :(

Avatar de l’utilisateur
nouvo09
Messages : 1813
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: VSFTPD & Apache

Message par nouvo09 » 14 avril 2014, 18:51

Tu as fait l'essai dans ta Centos, d'ouvrir un terminal et taper :

ftp localhost ??
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Beta-Pictoris
Messages : 869
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: VSFTPD & Apache

Message par Beta-Pictoris » 14 avril 2014, 19:26

Nowis a écrit :Enfin, je viens de re-essayer de me connecter vi FileZilla, et j'ai un nouveau message d'erreur :

Code : Tout sélectionner

Statut :	Connexion à 192.168.1.32...
Réponse :	fzSftp started
Commande :	open "user1@192.168.1.32" 22
Erreur :	Network error: Connection refused
Erreur :	Impossible d'établir une connexion au serveur
Le fait de désactiver iptables avec la commande "service iptables stop" ne change rien :(
Pourquoi le port 22 ? Le protocole ftp utilise les ports 20 pour les données et 21 pour les commandes.
Tu devrais indiquer à filezilla le port 21 ... ou ne rien indiquer du tout.

Nowis
Messages : 4
Inscription : 13 avril 2014, 14:07
Localisation : Rouen
Contact :

Re: VSFTPD & Apache

Message par Nowis » 14 avril 2014, 19:32

Le souci est que lorsque j'essaye sur le port 20 ou 21, je n'ai même pas de connexion qui se fait.
De plus, pour se connecter à distance, je ne suis pas obliger d'utiliser une connexion SSH ?

EDIT : Par contre, une fois le port 21 indiqué comme écouteur dans le fichier de configuration de VSFTPD, je peux accéder via la console, en local, au FTP.
EDIT 2 : Je viens de tester en mettant l'adresse de mon serveur, mais en spécifiant sftp devant ce dernier :

Code : Tout sélectionner

sftp://192.168.1.32
J'obtiens de nouveau cette erreur :

Code : Tout sélectionner

Réponse :	fzSftp started
Commande :	open "user1@192.168.1.32" 21
Erreur :	Délai d'attente expiré
Erreur :	Impossible d'établir une connexion au serveur

Avatar de l’utilisateur
nouvo09
Messages : 1813
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: VSFTPD & Apache

Message par nouvo09 » 14 avril 2014, 23:55

que renvoie un

service sshd status

?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Répondre