Problème sur yppasswd

stephan
Messages : 2
Inscription : 18 novembre 2020, 18:38

Problème sur yppasswd

Message par stephan » 18 novembre 2020, 18:44

Bonjour,

J'ai un système d'information basée sur du CentOS 6.10 avec du NIS.
Tout fonctionne très bien sauf quand un utlistaeur change son mot de passe avec yppasswd
ça ne retient que les 8 premier caractère.

Quelqu'un a une idée ?

Merci d'avance.

Avatar de l’utilisateur
nouvo09
Messages : 2221
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème sur yppasswd

Message par nouvo09 » 18 novembre 2020, 18:58

Code : Tout sélectionner

Par  le  passé, les commandes standard passwd(1), chfn(1) et chsh(1) ne permettaient pas, sous Linux, de modi‐
       fier les informations stockées sur un serveur NIS (mot de passe utilisateur, type de shell, GECOS). Pour modi‐
       fier les informations NIS, vous deviez utiliser à la place : yppasswd, ypchfn et ypchsh.

       Aujourd'hui, ces commandes sont obsolètes et ne devraient plus être utlisées.
extrait du man yppasswd
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

stephan
Messages : 2
Inscription : 18 novembre 2020, 18:38

Re: Problème sur yppasswd

Message par stephan » 18 novembre 2020, 19:16

Merci de ta réponse Nouvo09.

Qu'est-ce qui remplace aujourd'hui ? une commande, un IHM ?

Avatar de l’utilisateur
nouvo09
Messages : 2221
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème sur yppasswd

Message par nouvo09 » 18 novembre 2020, 21:20

je ne m'en sers pas mais si j'en crois ce qui est dit là, les commandes passwd et autres devraient fonctionner. Mais là, je suppose.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Répondre