Display Manager

ciaparis
Messages : 2
Inscription : 14 janvier 2016, 17:30

Display Manager

Message par ciaparis » 14 janvier 2016, 17:56

Bonjour,

Nous avons installé une CentOS 7 chez un de nos clients et après une mise à jour la page de login de GNOME ne s'affiche plus, à la place nous avons une fenetre avec un message "Oups..." et un bouton "logout". J'ai commencé par changer le mode de démarrage de "graphical" à "multi-user" et essayer de lancer GNOME via "startx". Cela ne marche pas. J'ai installé "Xfce" et cela fonctionne en lancant avec "startx" ( après quelques modifications dans des scripts ). Je remet le mode de démarrage en "graphical" et toujours la meme fenetre avec le message "Oups..". Le demerrage en mode graphique ne semble pas suivre la meme procedure qu'avec "startx". Pourtant je sais que l'on peut changer d'environnement sur la page de login. J'ai essaye avec une autre machine, j'ai choisi "xfce session" à la place de "gnome classic". Le choix de la session doit bien enregistrer quelque part. Dans quel fichier cette information est-elle enregistrée ?
Après de nombreuses recherches je n'ai toujours pas trouvé dans quel fichier cette information se trouve. Certains disent dans le fichier "$HOME/.dmrc" hors se fichier n'existe pas, d'autre dans "/etc/sysconfig/desktop" et cela fonctionne uniquement pour le lancement avec "startx".

Merci d'avance pour vos réponses.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Display Manager

Message par Beta-Pictoris » 14 janvier 2016, 19:54

L'environnement est enregistré dans un fichier personnel se trouvant ici: /var/lib/AccountsService/users/$USER.

On peut changer le contenu de la variable XSession en fonction des fichiers se trouvant dans /usr/share/xsessions.

Cela dit, teste avec plusieurs utilisateurs pour voir si le problème n'est pas lié à un compte en particulier et regarde ceci: viewtopic.php?f=34&t=4175

Avatar de l’utilisateur
nouvo09
Messages : 2171
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Display Manager

Message par nouvo09 » 14 janvier 2016, 20:19

En principe Xfce est livré avec le gestionnaire lightdm.

Il faut désactiver gdm: systemctl disable gdm

activer lightdm: systemctl enable lightdm

le démarrer: systemctl start lightdm

à noter que le lancement de la session avec Xfce est : startxfce4

Ensuite tu remets le démarrage en "graphical".
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

ciaparis
Messages : 2
Inscription : 14 janvier 2016, 17:30

Re: Display Manager

Message par ciaparis » 15 janvier 2016, 11:50

Merci pour vos réponses, la modification du fichier /var/lib/AccountsService/users/$USER fonctionne ainsi que l'utilisation de lightdm.

Répondre