désactiver son au démarrage [Résolu]

Bibaros
Messages : 22
Inscription : 29 janvier 2016, 15:51

désactiver son au démarrage [Résolu]

Message par Bibaros » 19 février 2017, 15:22

bonjour
Prière m'aider pour désactiver le son lors de démarrage de mon ordinateur .
système : Centos 7 64bit tourne en virtuelle machine, environnement Kde .
j'ai fait cette commande

Code : Tout sélectionner

locate sound | grep login
et j'ai trouvé le fichier de config de gnome seulement .
Merci d'avance

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: désactiver son au démarrage

Message par Beta-Pictoris » 19 février 2017, 19:32

Essaye de blacklister le module audio.

Tu peux obtenir la liste des modules comme ceci:

Code : Tout sélectionner

lsmod | grep hda
Si je lance la commande, j'obtiens ceci:
snd_hda_codec_hdmi 47892 1
snd_hda_codec_realtek 85956 1
snd_hda_codec_generic 73789 1 snd_hda_codec_realtek
snd_hda_intel 39987 5
snd_hda_codec 136428 4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core 85362 5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep 13608 1 snd_hda_codec
snd_pcm 106416 4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd 83432 20 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
Je peux, alors, créer un fichier blacklist.conf:

Code : Tout sélectionner

echo blacklist snd_hda_codec_realtek > /etc/modprobe.d/blacklist.conf

Bibaros
Messages : 22
Inscription : 29 janvier 2016, 15:51

Re: désactiver son au démarrage

Message par Bibaros » 19 février 2017, 22:01

bonjour
Merci beaucoup pour ton aide ,tu travaille sur quelle version de Centos SVP car apparemment on n'a pas les même modules car

Code : Tout sélectionner

lsmod | grep hda
ne donne rien en sortie .

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: désactiver son au démarrage

Message par Beta-Pictoris » 20 février 2017, 10:19

Rien à voir avec la version de centos. La puce audio de ta machine n'est pas de type hda.
Relance un 'lsmod' sans option et regarde le nom de tous les modules.

Tu veux, peut-être, supprimer le bip du clavier ? Dans ce cas , c'est le module le module 'pcspkr' qu'il faut blacklister.

Bibaros
Messages : 22
Inscription : 29 janvier 2016, 15:51

Re: désactiver son au démarrage

Message par Bibaros » 21 février 2017, 22:31

voilà le résultat du

Code : Tout sélectionner

lsmod | grep snd
:

Code : Tout sélectionner

snd_seq_midi           13565  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_ens1371            25243  3 
snd_rawmidi            31343  2 snd_ens1371,snd_seq_midi
snd_ac97_codec        130605  1 snd_ens1371
ac97_bus               12730  1 snd_ac97_codec
snd_seq                66747  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14356  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_pcm               106416  2 snd_ac97_codec,snd_ens1371
snd_timer              29819  2 snd_pcm,snd_seq
snd                    83432  13 snd_ac97_codec,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_ens1371,snd_seq_device
soundcore              15047  1 snd
j'ai fait :
echo blacklist nd_ac97_codec > /etc/blacklist.d/blacklist.conf
j'ai redemarré mais toujours il ya du son au démarrage j'ai testé de blacklister autre module ( nd_seq_midi , snd_pcm , snd...) mais le même résultat
j'ai executer

Code : Tout sélectionner

modinfo module
j'ai pas pu trouver celui responsable du son lors de démarrage.
j'attend votre réponse ,merci

Bibaros
Messages : 22
Inscription : 29 janvier 2016, 15:51

Re: désactiver son au démarrage

Message par Bibaros » 21 février 2017, 23:00

bonsoir
enfin j'ai trouvé le module c'est
snd_ens1371
merci

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: désactiver son au démarrage

Message par Beta-Pictoris » 21 février 2017, 23:02

Code : Tout sélectionner

snd_ens1371
Chip Ensoniq AudioPCI 1371/1373 : http://cateee.net/lkddb/web-lkddb/SND_ENS1371.html

Code : Tout sélectionner

echo blacklist nd_ac97_codec > /etc/blacklist.d/blacklist.conf 
Ce n'est pas le chemin que je t'ai donné. Regarde bien mon message au dessus.

Bibaros
Messages : 22
Inscription : 29 janvier 2016, 15:51

Re: désactiver son au démarrage

Message par Bibaros » 21 février 2017, 23:10

Merci Beta-Pictoris au fait ca c'est une faute de frappe mais j'ai editer le fichier par vi et j'ai trouvé que "snd_ens1371" est le responsable du son lors de démarrage j'ai appris comment blacklister des modules ... Prière comment mettre ce sujet comme résolut ?

Répondre