Prb de mise a jour YUM

tomcat
Messages : 1
Inscription : 29 juin 2017, 09:28

Prb de mise a jour YUM

Messagepar tomcat » 30 juillet 2017, 22:37

Bonjour à tous,

J'ai fait il y a qques temps une mise a jour via YUM qui s'est coupée a l'arrache .. ça a mis le systeme en vrac et depuis chaque fois que je fais un update, j'ai les erreurs suivantes :

--> Traitement de la dépendance : libBasicUsageEnvironment.so.0()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Traitement de la dépendance : libUsageEnvironment.so.1()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Traitement de la dépendance : libgroupsock.so.1()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Traitement de la dépendance : libliveMedia.so.17()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
---> Le paquet x264-libs.x86_64 0:0.142-12.20141221git6a301b6.fc22 sera mis à jour
--> Traitement de la dépendance : libx264.so.142()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
Removing chromium-libs-media.x86_64 0:59.0.3071.104-1.el7 - u due to obsoletes from chromium-libs-media-freeworld.x86_64 0:59.0.3071.109-5.el7 - u
--> Redémarrage de la résolution des dépendances avec les nouveaux changements.
--> Lancement de la transaction de test
---> Le paquet chromium-libs-media.x86_64 0:59.0.3071.104-1.el7 sera utilisé
--> Traitement de la dépendance : chromium-libs-media(x86-64) = 59.0.3071.104-1.el7 pour le paquet : chromium-59.0.3071.104-1.el7.x86_64
---> Le paquet live555.x86_64 0:2013.11.26-1.fc20 sera mis à jour
--> Traitement de la dépendance : libBasicUsageEnvironment.so.0()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Traitement de la dépendance : libUsageEnvironment.so.1()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Traitement de la dépendance : libgroupsock.so.1()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Traitement de la dépendance : libliveMedia.so.17()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
---> Le paquet x264-libs.x86_64 0:0.142-12.20141221git6a301b6.fc22 sera mis à jour
--> Traitement de la dépendance : libx264.so.142()(64bit) pour le paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Résolution des dépendances terminée
Erreur : Paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (@nux-dextop)
Requiert : libUsageEnvironment.so.1()(64bit)
Suppression  : live555-2013.11.26-1.fc20.x86_64 (installed)
libUsageEnvironment.so.1()(64bit)
Mis à jour par : live555-2016.07.19-3.el7.x86_64 (rpmfusion-free-updates)
~libUsageEnvironment.so.3()(64bit)
Disponible : live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
libUsageEnvironment.so.1()(64bit)
Erreur : Paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (@nux-dextop)
Requiert : libBasicUsageEnvironment.so.0()(64bit)
Suppression  : live555-2013.11.26-1.fc20.x86_64 (installed)
libBasicUsageEnvironment.so.0()(64bit)
Mis à jour par : live555-2016.07.19-3.el7.x86_64 (rpmfusion-free-updates)
~libBasicUsageEnvironment.so.1()(64bit)
Disponible : live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
libBasicUsageEnvironment.so.0()(64bit)
Erreur : Paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (@nux-dextop)
Requiert : libliveMedia.so.17()(64bit)
Suppression  : live555-2013.11.26-1.fc20.x86_64 (installed)
libliveMedia.so.17()(64bit)
Mis à jour par : live555-2016.07.19-3.el7.x86_64 (rpmfusion-free-updates)
~libliveMedia.so.52()(64bit)
Disponible : live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
libliveMedia.so.17()(64bit)
Erreur : Paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (@nux-dextop)
Requiert : libgroupsock.so.1()(64bit)
Suppression  : live555-2013.11.26-1.fc20.x86_64 (installed)
libgroupsock.so.1()(64bit)
Mis à jour par : live555-2016.07.19-3.el7.x86_64 (rpmfusion-free-updates)
~libgroupsock.so.8()(64bit)
Disponible : live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
libgroupsock.so.1()(64bit)
Erreur : Paquet : 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (@nux-dextop)
Requiert : libx264.so.142()(64bit)
Suppression  : x264-libs-0.142-12.20141221git6a301b6.fc22.x86_64 (installed)
libx264.so.142()(64bit)
Mis à jour par : x264-libs-0.148-11.20160614gita5e06b9.el7.x86_64 (rpmfusion-free-updates)
~libx264.so.148()(64bit)
Disponible : x264-libs-0.142-4.20140423gite260ea5.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Disponible : x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Disponible : x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Erreur : Paquet : chromium-59.0.3071.104-1.el7.x86_64 (epel)
Requiert : chromium-libs-media(x86-64) = 59.0.3071.104-1.el7
Suppression  : chromium-libs-media-58.0.3029.110-2.el7.x86_64 (@epel)
chromium-libs-media(x86-64) = 58.0.3029.110-2.el7
Rendu obsolète par : chromium-libs-media-freeworld-59.0.3071.109-5.el7.x86_64 (rpmfusion-free-updates)
chromium-libs-media(x86-64) = 59.0.3071.109-5.el7
Mis à jour par : chromium-libs-media-59.0.3071.104-1.el7.x86_64 (epel)
chromium-libs-media(x86-64) = 59.0.3071.104-1.el7
Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
** 2 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :
ipa-client-common-4.4.0-14.el7.centos.7.noarch des conflits sont installés freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.7.noarch
ipa-common-4.4.0-14.el7.centos.7.noarch des conflits sont installés freeipa-common: ipa-common-4.4.0-14.el7.centos.7.noarch


(Je n'ai pas tout mis)

j'ai essayé qques yum clean all, rpm -rebuildb etc mais rien a faire .. a tel point que je me demande si je ne dois pas reinstaller tout le systeme, ce que j'aimerais si possible eviter ....

J'en appel donc a vos compétences, quelques pistes ?

D'avance merci

Tom

Beta-Pictoris
Messages : 867
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Prb de mise a jour YUM

Messagepar Beta-Pictoris » 31 juillet 2017, 08:43

Tu devrais commencer par désinstaller tous les paquets rpmfusion, voir nux, et désactiver ces dépôts.