Page 1 sur 1

[Résolu] Problème d'update

Publié : 09 août 2017, 16:22
par klaus
Bonjour tout le monde !

J'ai l’erreur suivante lorsque je veux mettre à jour mon CentOS 6.9 :

Code : Tout sélectionner

# yum update
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: centos.quelquesmots.fr
 * centosplus: centos.quelquesmots.fr
 * contrib: centos.crazyfrogs.org
 * epel: mir01.syntis.net
 * epel-testing: mir01.syntis.net
 * extras: centos.crazyfrogs.org
 * updates: centos.mirror.fr.planethoster.net
Resolving Dependencies
--> Running transaction check
---> Package fusioninventory-agent.x86_64 0:2.3.20-1.el6 will be updated
---> Package fusioninventory-agent.x86_64 0:2.3.21-1.el6 will be an update
--> Processing Dependency: perl(setup) for package: fusioninventory-agent-2.3.21-1.el6.x86_64
---> Package libarchive3.x86_64 0:3.2.1-1.el6 will be updated
--> Processing Dependency: libarchive.so.13()(64bit) for package: cmake3-3.6.1-2.el6.x86_64
---> Package libarchive3.x86_64 0:3.3.1-1.el6 will be an update
---> Package perl-FusionInventory-Agent.noarch 0:2.3.20-1.el6 will be updated
--> Processing Dependency: perl(setup) for package: fusioninventory-agent-2.3.21-1.el6.x86_64
---> Package perl-FusionInventory-Agent.noarch 0:2.3.21-1.el6 will be an update
--> Processing Dependency: perl(parent) for package: perl-FusionInventory-Agent-2.3.21-1.el6.noarch
--> Running transaction check
---> Package fusioninventory-agent.x86_64 0:2.3.21-1.el6 will be an update
--> Processing Dependency: perl(setup) for package: fusioninventory-agent-2.3.21-1.el6.x86_64
---> Package libarchive3.x86_64 0:3.2.1-1.el6 will be updated
--> Processing Dependency: libarchive.so.13()(64bit) for package: cmake3-3.6.1-2.el6.x86_64
---> Package perl-FusionInventory-Agent.noarch 0:2.3.20-1.el6 will be updated
--> Processing Dependency: perl(setup) for package: fusioninventory-agent-2.3.21-1.el6.x86_64
---> Package perl-parent.x86_64 1:0.221-144.el6 will be installed
--> Finished Dependency Resolution
Error: Package: fusioninventory-agent-2.3.21-1.el6.x86_64 (epel-testing)
           Requires: perl(setup)
           Removing: perl-FusionInventory-Agent-2.3.20-1.el6.noarch (@epel-testing)
               perl(setup)
           Updated By: perl-FusionInventory-Agent-2.3.21-1.el6.noarch (epel-testing)
               Not found
Error: Package: cmake3-3.6.1-2.el6.x86_64 (@epel)
           Requires: libarchive.so.13()(64bit)
           Removing: libarchive3-3.2.1-1.el6.x86_64 (@epel-testing)
               libarchive.so.13()(64bit)
           Updated By: libarchive3-3.3.1-1.el6.x86_64 (epel)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
J'ai essayé les deux dernières commandes recommandées mais ça n’a rien changé :(
Avez-vous une idée de comment m’y prendre pour résoudre ce problème ?

Merci bien !

Re: Problème d'update

Publié : 09 août 2017, 17:46
par remi
Pourquoi activer epel-testing... qui justement contient des nouveaux paquets à tester ?

Et dans ce cas, il faut rapporter le problème, de préférence sur l'update
https://bodhi.fedoraproject.org/updates ... a10b4719f7 pour fusioninventory-agent

Pour cmake, je pense qu'il faut ouvrir un nouveau rapport de bug sur
https://bugzilla.redhat.com/

Re: Problème d'update

Publié : 09 août 2017, 17:54
par remi
Rectification, pour cmake3 un update corrigeant le problème est dans les tuyaux
https://bodhi.fedoraproject.org/updates ... 657403d96c

Re: Problème d'update

Publié : 09 août 2017, 18:33
par klaus
Merci Rémi pour tes réponses.
remi a écrit :Pourquoi activer epel-testing... qui justement contient des nouveaux paquets à tester ?
Ce n’est pas ma machine et je ne sais pas comment désactiver epel-testing. Pourrais-tu m’indiquer comment faire ?

Re: Problème d'update

Publié : 09 août 2017, 18:34
par klaus
remi a écrit :Rectification, pour cmake3 un update corrigeant le problème est dans les tuyaux
https://bodhi.fedoraproject.org/updates ... 657403d96c
Comment puis-je bénéficier de cet update ?

Re: Problème d'update

Publié : 17 août 2017, 10:21
par klaus
Ça a été réglé avec le dernier yum update !