Erreur yum update (conflits)

Fabdici
Messages : 3
Inscription : 27 septembre 2017, 13:52

Erreur yum update (conflits)

Message par Fabdici » 27 septembre 2017, 14:02

Bonjour,

Je dispose de plusieurs CentOS dans un environnement de qualification et de leurs équivalents RedHat en environnement de production.

Un de mes serveurs refuse de se mettre à jour. J'avais des conflits entre "ipa" et "freeipa". J'ai corrigé le problème en suivante ceci :
https://access.redhat.com/solutions/2774681

Voir ce que j'obtiens maintenant lorsque je lance : yum update

Code : Tout sélectionner

--> Traitement du conflit : kernel-3.10.0-693.2.2.el7.x86_64 entre en conflit avec kexec-tools < 2.0.14-3
--> Traitement du conflit : systemd-219-42.el7_4.1.x86_64 entre en conflit avec dracut < 033-499
--> Résolution des dépendances terminée
Erreur : Paquet : 1:java-1.7.0-openjdk-headless-1.7.0.151-2.6.11.1.el7_4.x86_64 (updates)
             Requiert : copy-jdk-configs >= 2.2
             Installé  : copy-jdk-configs-1.2-1.el7.noarch (@base)
                 copy-jdk-configs = 1.2-1.el7
Erreur : Paquet : python2-ipalib-4.5.0-21.el7.centos.1.2.noarch (updates)
             Requiert : python-gssapi >= 1.2.0-3
             Installé  : python-gssapi-1.2.0-2.el7.x86_64 (@base)
                 python-gssapi = 1.2.0-2.el7
Erreur : Paquet : samba-client-libs-4.6.2-11.el7_4.x86_64 (updates)
             Requiert : krb5-libs >= 1.15.1
             Installé  : krb5-libs-1.14.1-27.el7_3.x86_64 (@updates)
                 krb5-libs = 1.14.1-27.el7_3
             Disponible : krb5-libs-1.14.1-26.el7.i686 (base)
                 krb5-libs = 1.14.1-26.el7
Erreur : Paquet : samba-client-libs-4.6.2-11.el7_4.x86_64 (updates)
             Requiert : libtevent.so.0(TEVENT_0.9.30)(64bit)
Erreur : Paquet : 1:java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64 (updates)
             Requiert : copy-jdk-configs >= 2.2
             Installé  : copy-jdk-configs-1.2-1.el7.noarch (@base)
                 copy-jdk-configs = 1.2-1.el7
Erreur : Paquet : evince-3.22.1-5.2.el7_4.x86_64 (updates)
             Requiert : gtk3(x86-64) >= 3.16.0
             Installé  : gtk3-3.14.13-20.el7_3.1.x86_64 (@updates)
                 gtk3(x86-64) = 3.14.13-20.el7_3.1
             Disponible : gtk3-3.14.13-20.el7.x86_64 (base)
                 gtk3(x86-64) = 3.14.13-20.el7
Erreur : Paquet : openssh-7.4p1-12.el7_4.x86_64 (updates)
             Requiert : libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Erreur : systemd conflicts with dracut-033-463.el7_3.2.x86_64
Erreur : Paquet : kernel-3.10.0-693.2.2.el7.x86_64 (updates)
             Requiert : linux-firmware >= 20170606-55
             Installé  : linux-firmware-20160830-49.git7534e19.el7.noarch (@base)
                 linux-firmware = 20160830-49.git7534e19.el7
Erreur : Paquet : python2-ipalib-4.5.0-21.el7.centos.1.2.noarch (updates)
             Requiert : python2-cryptography >= 1.4
             Installé  : python2-cryptography-1.3.1-3.el7.x86_64 (@base)
                 python2-cryptography = 1.3.1-3.el7
Erreur : kernel conflicts with kexec-tools-2.0.7-50.el7.x86_64
Erreur : Paquet : nss-3.28.4-11.el7_4.x86_64 (updates)
             Requiert : nss-pem(x86-64)
Erreur : Paquet : kernel-3.10.0-693.2.2.el7.x86_64 (updates)
             Requiert : dracut >= 033-502
             Installé  : dracut-033-463.el7_3.2.x86_64 (@updates)
                 dracut = 033-463.el7_3.2
             Disponible : dracut-033-463.el7.x86_64 (base)
                 dracut = 033-463.el7
Erreur : Paquet : python2-ipaclient-4.5.0-21.el7.centos.1.2.noarch (updates)
             Requiert : python-dns >= 1.12.0-3
             Installé  : python-dns-1.12.0-2.20150617git465785f.el7.noarch (@base)
                 python-dns = 1.12.0-2.20150617git465785f.el7
Erreur : Paquet : evince-3.22.1-5.2.el7_4.x86_64 (updates)
             Requiert : libgnome-desktop-3.so.12()(64bit)
Erreur : Paquet : samba-client-libs-4.6.2-11.el7_4.x86_64 (updates)
             Requiert : libtdb.so.1(TDB_1.3.11)(64bit)
Erreur : Paquet : python2-ipalib-4.5.0-21.el7.centos.1.2.noarch (updates)
             Requiert : python-dns >= 1.12.0-3
             Installé  : python-dns-1.12.0-2.20150617git465785f.el7.noarch (@base)
                 python-dns = 1.12.0-2.20150617git465785f.el7
Erreur : Paquet : openssh-clients-7.4p1-12.el7_4.x86_64 (updates)
             Requiert : libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Erreur : Paquet : samba-client-libs-4.6.2-11.el7_4.x86_64 (updates)
             Requiert : libtevent.so.0(TEVENT_0.9.31)(64bit)
Erreur : Paquet : samba-libs-4.6.2-11.el7_4.x86_64 (updates)
             Requiert : libpytalloc-util.so.2(PYTALLOC_UTIL_2.1.9)(64bit)
Erreur : Paquet : openssh-server-7.4p1-12.el7_4.x86_64 (updates)
             Requiert : libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Erreur : Paquet : nss-3.28.4-11.el7_4.x86_64 (updates)
             Requiert : nss-util >= 3.28.4-2
             Installé  : nss-util-3.28.4-1.0.el7_3.x86_64 (@updates)
                 nss-util = 3.28.4-1.0.el7_3
             Disponible : nss-util-3.21.0-2.2.el7_2.i686 (base)
                 nss-util = 3.21.0-2.2.el7_2
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest
J'ai essayé les 2 solutions proposées ci-dessus (le "skip-broken" et le "rpm").

Pouvez-vous m'aider ?
Merci,

Fabdici
Messages : 3
Inscription : 27 septembre 2017, 13:52

Re: Erreur yum update (conflits)

Message par Fabdici » 27 septembre 2017, 14:32

La commande "yum check" ne produit pas d'erreur.
Les repository installés sont :

Code : Tout sélectionner

base/7/x86_64                     CentOS-7 - Base                                                           9 363
epel/x86_64                          Extra Packages for Enterprise Linux 7 - x86_64           11 968
extras/7/x86_64                   CentOS-7 - Extras                                                           224
updates/7/x86_64                CentOS-7 - Updates                                                         719

Fabdici
Messages : 3
Inscription : 27 septembre 2017, 13:52

Re: Erreur yum update (conflits)

Message par Fabdici » 27 septembre 2017, 15:04

"yum clean all" a permis de corriger mon problème et de passer de 7.3 à 7.4

Répondre