phpmyadmin avec centos

thomas76
Messages : 2
Inscription : 23 mars 2018, 19:00

phpmyadmin avec centos

Message par thomas76 » 23 mars 2018, 19:03

Bonjour,

J'ai installé centos 7.2 sur une dedibox de chez online. J'ai un problème au moment de l'installation de phpmyadmin. Normalement lorsque j'utilise un serveur debian avec ipdemonserveur/phpmyadmin j'ai l'interface graphique habituelle.
Là j'ai essayé plein de choses mais rien à faire je n'ai jamais phpmyadmin.
Si quelqu'un a une idée ou une solution à ce problème je suis preneur car là je galère.

Merci à tous
Thomas

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: phpmyadmin avec centos

Message par Beta-Pictoris » 23 mars 2018, 20:55

Il y a 2 composantes qui peuvent bloquer l'accès à ton site:
Le parefeu "firewalld".
La couche sécurité "selinux".

Comment les as tu configurées ?

thomas76
Messages : 2
Inscription : 23 mars 2018, 19:00

Re: phpmyadmin avec centos

Message par thomas76 » 24 mars 2018, 04:27

Bonjour,

merci pour votre aide.

en ce qui concerne firewalld je l'ai désactivé et j'ai réactivé iptables.
Pour seolinux je l'ai désactivé avec la commande setenforce 0. Ensuite, j'ai essayé de lancer httpd avec la commande service httpd start.
A la suite de cela j'ai le message d'erreur "Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details."
Lorsque je vais dans systemctl status httpd.service j'ai l'erreur suivante Failed to start The Apache HTTP Server.
Je pense que cela est du au fait que le même port est utilisé deux fois mais je ne sais pas comment modifier cela.

Au final, le problème phpmyadmin est sans doute du au fait que je ne peux pas lancer le serveur apache.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: phpmyadmin avec centos

Message par Beta-Pictoris » 24 mars 2018, 14:35

La commande "journalctl -xe" peut te donner plus d'informations.
Regarde, éventuellement, les messages se trouvant dans '/var/log/httpd/'. Mais si "httpd" ne tourne pas, tu ne devrais avoir grand chose à ce niveau là.
Il doit, y avoir, un problème dans les fichiers de configuration d'apache. Les fichiers se trouvent dans '/etc/httpd'.

Cela dit, le paquet 'phpMyAdmin' fait partie du dépôt epel. Comment l'as tu installé ?

Répondre