[fermé] problèmes affichage lors de la création d'un compte

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

[fermé] problèmes affichage lors de la création d'un compte

Message par paul18 » 04 avril 2018, 09:08

Bonjour,

J'ai récemment fait une mise à jour de mes Centos7 ("update"), aussi est-ce l'origine du problème (???), mais après avoir créer un nouveau compte utilisateur, j'ai des problèmes avec la gestion des affichages (voir les captures):
- la "desktop panel" a disparu,
- je ne peux plus gérer la taille de l'écran - il me faut taper un "xrandr -s 1650x1050"
- les modifications de l'arrière plan ne sont pas prise en compte - de même il y a un problème avec le thème
- pour ouvrir un terminal, "click-droit" fonctionne encore, mais il reste toujours en arrière plan (cliquer dessus ne le fait pas passer devant)
- (pas de problème sur mon compte à moi ni les autres - l'avant dernier compte utilisateur créé remonte à 1 mois)

quelqu'un a-t'il déjà eu ce problème ? où chercher le problème ?

Remarque: nous nous connectons au serveur via VNC

Merci par avance

Paul
Image
Image
Dernière modification par paul18 le 05 avril 2018, 09:26, modifié 1 fois.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problèmes affichage lors de la création d'un compte

Message par Beta-Pictoris » 04 avril 2018, 11:51

Je suppose que tu utilises le bureau gnome.
J'ai l'impression que le gestionnaire de fenêtre est manquant. Il manquerait des paquets ?
Dans un premier temps, essaye de passer du mode 'gnome classique' au mode gnome normal et vice-versa:
Image

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Re: problèmes affichage lors de la création d'un compte

Message par paul18 » 04 avril 2018, 12:12

merci pour cette réponse, mais je n'ai accès qu'à des terminaux (que je ne peux même pas redimensionner soit dit en passant).

Il doit y avoir une combinaison de touches pour arrivant à ton écran, mais je ne me rappelle plus

Tu parles du problème de package(s), mais les autres comptes utilisateurs fonctionnent sans problème (dont le mien) ; il s'agit ici du compte du nouvel arrivant qui est comme ça.

je cherche, mais ....

Paul

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problèmes affichage lors de la création d'un compte

Message par Beta-Pictoris » 04 avril 2018, 12:23

C'est l'écran d'accueil du gdm. Quand tu te logues, tu dois arriver sur cet écran (ou sur quelque chose d'équivalent). Non ?

Sinon, vérifie les permissions du profil utilisateur et les groupes:

Code : Tout sélectionner

ls -dl /home/login_user/
ls -l /home/login_user
groups
Supprime, aussi, les répertoires '.config', '.local' et '.cache' et logue toi de nouveau.

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Re: problèmes affichage lors de la création d'un compte

Message par paul18 » 04 avril 2018, 12:41

Beta-Pictoris a écrit :C'est l'écran d'accueil du gdm. Quand tu te logues, tu dois arriver sur cet écran. Non ?
Non j'utilise VNC qui se connecte directement au compte sans passer par l'interface graphique (c'est un serveur distant).

J'ai supprimé les répertoires et j'ai rebooté; il m'a demandé de reconfigurer mais rien de neuf sous le soleil (???)

Paul
Image

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Re: problèmes affichage lors de la création d'un compte

Message par paul18 » 04 avril 2018, 12:44

un oubli: il a tous ses droits sur son compte (drwx)

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problèmes affichage lors de la création d'un compte

Message par Beta-Pictoris » 04 avril 2018, 14:06

Ton système utilise certainement un serveur xvnc ou quelque chose d'équivalent.

As tu vérifié si ton nouvel utilisateur ne doit pas être dans un groupe particulier ?

As tu essayé de te loguer après avoir désactivé selinux ? :

Code : Tout sélectionner

setenforce 0

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Re: problèmes affichage lors de la création d'un compte

Message par paul18 » 04 avril 2018, 14:28

merci pour le temps consécra ; c'est bien un problème de gdm je pense ; pour avoir un gdm, j'ai tenté d'ajouter les 2 lignes ci-dessous dans "/etc/gdm/custom.conf" :

Code : Tout sélectionner

AutomaticLogin=linuxconfig
AutomaticLoginEnable=True
=> l'écran reste noir et j'ai l'erreur visible dans la capture
Image

si je supprime ces lignes, je reviens à mon problème initial ; par contre pourquoi mon compte fonctionne correctement et aucun des nouveaux ? (test avec toto et même résultat) ... je devrait avoir le même problème ????

Pour setenforce :

Code : Tout sélectionner

setenforce:  setenforce() failed
Paul

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problèmes affichage lors de la création d'un compte

Message par Beta-Pictoris » 04 avril 2018, 14:54

La dernière commande doit être lancée en root.

paul18
Messages : 115
Inscription : 04 janvier 2012, 16:33

Re: problèmes affichage lors de la création d'un compte

Message par paul18 » 04 avril 2018, 15:11

l'écran est redevenu noir

sur mon compte j'ai des alertes :
Image

Répondre