Problème après mise à jour

et76
Messages : 84
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Problème après mise à jour

Message par et76 » 27 décembre 2018, 17:40

Bonjour,
Moi aussi j'ai de gros problème après une mise à jour de ma Centos 7 sur un PC qui a aussi une Fedora 28.
Ma configuration un PC avec un core i3 3100 une carte graphique AMD avec le driver Gallium 0.4 on AMD BARTS, informations venant de paramètres.
Voila ma petite histoire : il y a quelques jours vers le 20 décembre j'effectue une mise à jour via yum update de mon PC pour ma Centos 7, information environ 800 Mo de mise à jour, pourquoi pas je valide la mise à jour puis je vaque à d'autres occupations le temps de la mise à jour (ma liaison internet est un peu lente 300 kb/s). Manque de chance, et cela en pleine mise à jour un bon coup de vent et suivi de plusieurs coupures électriques (je suis à la campagne). Ma Centos est KO mais chance ma Fedora fonctionne.
Réinstallation de ma Centos après téléchargement d'un nouveau CD live gnome, celui d'origine bloque sur le partitionnement personnalisé pourquoi mystère.
Après cette réinstallation mise à jour et problèmes, après l'affichage du bureau le choix d'un des menus applications ou emplacements l'écran ne change pas puis clignotement lent de l'écran puis fond avec plein de petits dessins, puis des morceaux d'images.
Redémarrage en init 3, passage en root et essai de mise à jour la gros problèmes beaucoup de messages indiquant qu'il y a des confits entre des versions de modules installés par exemple un module en 1-1-17 et un en 1-1-18 de mémoire.
Donc comme pour un autre post je pense que dans les mises à jour disponibles il y a de gros problèmes qui se voient dans un affichage incorrect.
Je pense qu'il faut être patient et attendre de nouvelles mises à jour.
Question complémentaire : sur les sites concernant Centos on trouve beaucoup versions différentes à télécharger dont des de la version 7.6 en live et des ayant une indication finale de 16xx ou 17xx ou 18xx laquelle doit-on choisir ?
Merci d'avance mais ce problème de mise à jour déplorable de Centos est très étrange ce n'est pas dans les habitudes de la maison ?
A+

Avatar de l’utilisateur
nouvo09
Messages : 2007
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème après mise à jour

Message par nouvo09 » 27 décembre 2018, 19:27

Salut

tu peux essayer à partir d'un terminal de lancer un yum update et recopier ici les messages signalant des conflits ? au moins en partie s'ils sont trop nombreux ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

et76
Messages : 84
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème après mise à jour

Message par et76 » 27 décembre 2018, 20:07

Sauf que le PC en question n'est pas utilisable, après une nouvelle installation et juste la mise à jour du kernel la suppression de packagekit, ekiga, evolution, shotwell, empathy, orca, rhytmbox cheese que je n'utilise pas et l'installation de thunderbird, la création d'un deuxième utilisateur ordinaire plantage donc réinstallation de la version 7.0.146 et là je ne touche à rien ni mise à jour ni suppression, dans le doute pas touche.
C'est étrange jusqu'ici les mises à jour n'avaient pas créées de problème.
A+

et76
Messages : 84
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème après mise à jour

Message par et76 » 03 janvier 2019, 12:33

Et voici la suite de mes problèmes.
Mon disque est partitionné en plusieurs modules :
2 en base sda1 et sda2 pour le boot et le système de la Centos sda1, le système de ma fedora 28 sur sda2 et une partition étendue avec le swap et les partitions home pour chaque système des partitions de données, photos, musiques utilisées par les 2 systèmes et enfin 2 partitions en attente d'un troisième système.
Après mes problèmes suivant les coupures électriques je n'ai pas réussi à retrouver ma Centos même après réinstallation.
J'ai donc tenté une réinstallation des deux systèmes mais j'ai inversé les partitions systèmes sda1 pour fedora et sda2 pour centos en reformatant les partitions système, home et swap à chaque installation.
Après cette réinstallation je n'ai pas mis à jour ma centos par crainte, mais voila ma fedora met 4 mn 30 pour afficher mon bureau LXDE.
Le test de la RAM ne signale pas de problèmes celui du disque avec l'utilitaire gnome-disk non plus. Je décide d'installer une nouvelle version de fedora 29 LXDE sur les 2 partitions en attente. Miracle cette fedora fonctionne bien sauf l'heure qui est sur New-York malgré la valeur de /etc/localtime qui est identique sur la centos et dont l'affichage est correct lui et en phase avec le système.
Donc conclusion la partition sda1 de mon disque à des problèmes, donc disque à remplacer puisque le formatage à l'installation ou la vérification et formatage via un live de gparted ne trouve rien d'anormal et ne corrige rien.
Voila la conclusion de mes problèmes.
A+ et bonne année à tous

et76
Messages : 84
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème après mise à jour

Message par et76 » 03 janvier 2019, 12:35

Un oubli, après réinstallation de ma fedora en version 29 la 28 est toujours là mais inutilisable j'ai osé mettre à jour ma centos et celà sans problèmes

Avatar de l’utilisateur
nouvo09
Messages : 2007
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème après mise à jour

Message par nouvo09 » 03 janvier 2019, 15:19

Donc conclusion la partition sda1 de mon disque à des problèmes, donc disque à remplacer
Tu tires des conclusions bien hâtives. Fais le test smart sur ton disque avant tout.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

et76
Messages : 84
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème après mise à jour

Message par et76 » 03 janvier 2019, 17:28

Merci pour ta réponse et voici le résultat de la commande très bavarde

Code : Tout sélectionner

[root@PI3100 ~]# smartctl -a /dev/sda
smartctl 6.6 2017-11-05 r4594 [x86_64-linux-4.19.12-301.fc29.x86_64] (local build)
Copyright (C) 2002-17, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family:     Seagate Barracuda 7200.14 (AF)
Device Model:     ST1000DM003-9YN162
Serial Number:    Z1D1000F
LU WWN Device Id: 5 000c50 0403ad598
Firmware Version: CC4B
User Capacity:    1 000 204 886 016 bytes [1,00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    7200 rpm
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Thu Jan  3 10:17:09 2019 EST

==> WARNING: A firmware update for this drive may be available,
see the following Seagate web pages:
http://knowledge.seagate.com/articles/en_US/FAQ/207931en
http://knowledge.seagate.com/articles/en_US/FAQ/223651en

SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(  575) seconds.
Offline data collection
capabilities: 			 (0x73) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					command.
					No Offline surface scan supported.
					Self-test supported.
					Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   1) minutes.
Extended self-test routine
recommended polling time: 	 ( 109) minutes.
Conveyance self-test routine
recommended polling time: 	 (   2) minutes.
SCT capabilities: 	       (0x3085)	SCT Status supported.

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   101   099   006    Pre-fail  Always       -       3469792
  3 Spin_Up_Time            0x0003   097   097   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   097   097   020    Old_age   Always       -       3105
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   074   060   030    Pre-fail  Always       -       17286874220
  9 Power_On_Hours          0x0032   076   076   000    Old_age   Always       -       21306
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   097   097   020    Old_age   Always       -       3104
183 Runtime_Bad_Block       0x0032   100   100   000    Old_age   Always       -       0
184 End-to-End_Error        0x0032   100   100   099    Old_age   Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
188 Command_Timeout         0x0032   100   099   000    Old_age   Always       -       5 5 8
189 High_Fly_Writes         0x003a   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   071   064   045    Old_age   Always       -       29 (Min/Max 21/30)
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       0
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       115
193 Load_Cycle_Count        0x0032   001   001   000    Old_age   Always       -       289341
194 Temperature_Celsius     0x0022   029   040   000    Old_age   Always       -       29 (0 16 0 0 0)
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
240 Head_Flying_Hours       0x0000   100   253   000    Old_age   Offline      -       9573h+15m+48.328s
241 Total_LBAs_Written      0x0000   100   253   000    Old_age   Offline      -       93102086969830
242 Total_LBAs_Read         0x0000   100   253   000    Old_age   Offline      -       183506509055872

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Aborted by host               80%     21276         -
# 2  Short offline       Completed without error       00%     21276         -
# 3  Extended offline    Aborted by host               90%     21276         -
# 4  Short offline       Completed without error       00%     21170         -

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

[root@PI3100 ~]# 
Je ne suis pas en mesure d'en comprendre les informations avec la ligne 7 qui pourrait être une information sur un taux d'erreurs peut-être important mais à voir avec l'utilisation du disque.
Mais le changement de partition a bien réglé un problème ma centos semble bien fonctionner et ma fedora 28 elle non ....

Avatar de l’utilisateur
nouvo09
Messages : 2007
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème après mise à jour

Message par nouvo09 » 04 janvier 2019, 10:07

Je pense que ton disque a un gros souci. Cependant il ne semble pas être dramatique puisque la ligne "pending sectors" est à 0.

Pour ce qui est du démarrage de Fedora, il serait préférable d'ouvrir un sujet dans le forum éponyme.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Répondre