[Résolu] Connexion SSH vers serveur avec message d’erreur à l'ouverture de celui-ci

Maaax
Messages : 6
Inscription : 21 octobre 2018, 11:34

[Résolu] Connexion SSH vers serveur avec message d’erreur à l'ouverture de celui-ci

Message par Maaax » 15 février 2020, 15:13

Bonjour à toutes et tous,

J’ai un serveur Nextcloud installé sur une Raspberry PI 3 avec CentOS 7 pour Raspberry installé dessus.

Version CentOS : CentOS Linux release 7.6.1810 (AltArch)

Problème rencontré : Je me suis connecté ce matin en SSH sur le serveur dans le but de renouveler un certificat Let's Encrypt mise en place dessus. La connexion SSH s’établie mais j’ai des messages d’erreur sur le serveur concernant .bash_profile puis le prompt n’est pas le même, on dirait un prompt en mode dégradé au lieu du hostname habituel. J’ai aussi des messages d’erreur quand j’ouvre .bash_profile avec VIM. Des logs d'erreurs aussi avec la commande

Code : Tout sélectionner

journalctl -xe 
Messages d’erreur à l'ouverture:

Code : Tout sélectionner

-bash: /home/user/.bash_profile: ligne1: Erreur de syntaxe près du symbole inattendu « self._x509, »
-bash: /home/user/.bash_profile: ligne1: `      _lib.X509_set_version(self._x509, version)'
Prompt :

Code : Tout sélectionner

-bash-4.2$
Message d’erreur VIM :

Code : Tout sélectionner

E575: viminfo : Caractère initial non valide à la ligne ^?ELF^A^A^A
E575: viminfo : Caractère initial non valide à la ligne  D<8d><a6>^D^Bi^B^D
E575: viminfo : Caractère initial non valide à la ligne ^A,
E575: viminfo : Caractère initial non valide à la ligne ^A
E575: viminfo : Caractère initial non valide à la ligne ^C
E575: viminfo : Caractère initial non valide à la ligne Ə<e2>^Qʌ<e2>^T<f2><bc><e5>
E575: viminfo : Caractère initial non valide à la ligne (
E575: viminfo : Caractère initial non valide à la ligne ^\ <9f><e5>^B0<93><e7>
E575: viminfo : Caractère initial non valide à la ligne 3<ff>/<e1>^H@<bd><e8><bf><ff><ff><ea>^T^N^A
E575: viminfo : Caractère initial non valide à la ligne ^L <9d><e5>
E136: Il y a trop d'erreurs ; interruption de la lecture du fichier viminfo
Appuyez sur ENTRÉE ou tapez une commande pour continuer
journalctl -xe : Le problème semble lié à la connexion SSH voci les messages important :

Code : Tout sélectionner

févr. 15 12:51:23 cloud sshd[1262]: pam_unix(sshd:auth): check pass; user unknown
févr. 15 12:51:23 cloud sshd[1262]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=20

J’accède toujours à mon espace Nextcloud via navigateur. c’est la première fois que je rencontre le problème, tout fonctionnais parfaitement jusqu’à ce que je me connecte aujourd’hui. Je m’y connecte rarement, uniquement pour renouveler le certificat.

Merci de m’aider car là j‘avoue être un peu largué :)
Dernière modification par Maaax le 15 février 2020, 20:46, modifié 2 fois.

Avatar de l’utilisateur
nouvo09
Messages : 2147
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Connexion SSH vers serveur avec message d’erreur à l'ouverture de celui-ci

Message par nouvo09 » 15 février 2020, 15:53

salut
je dirais dans un premier temps de renommer le fichier .bash_profile de ton compte en .bash_profile-old

et de recréer un .bash_profile tout neuf pour voir si le souci peut venir de là.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Maaax
Messages : 6
Inscription : 21 octobre 2018, 11:34

Re: Connexion SSH vers serveur avec message d’erreur à l'ouverture de celui-ci

Message par Maaax » 15 février 2020, 20:06

Merci nouvo09 pour ta réponse rapide,

J'ai essayé de renommer le fichier en .bash_profile.old mais bizarrement je ne peux pas ! La commande mv me renvoie ce message :

Code : Tout sélectionner

-bash-4.2$ sudo mv .bash_profile .bash_profile.old
mv: impossible de déplacer « .bash_profile » vers « .bash_profile.old »: Aucun fichier ou dossier de ce type
J'ai plusieurs fois renommer des fichiers .bash sans problème, j'en suis allé à vérifier sur Internet si je ne me trompait pas de commande :D

En fait j'ai des messages d'erreur pour tout même un simple reboot du système (j'ai éssayé) ne marche pas !!!

Code : Tout sélectionner

-bash-4.2$ sudo reboot 
[sudo] Mot de passe de user :  
Failed to open /dev/initctl: Aucun périphérique ou adresse 
Failed to talk to init daemon.
Systemd semble HS aussi, je redémarre la Raspberry à l'arrache (pas bien mais tant pis) et on verra la suite.

Maaax
Messages : 6
Inscription : 21 octobre 2018, 11:34

Re: Connexion SSH vers serveur avec message d’erreur à l'ouverture de celui-ci

Message par Maaax » 15 février 2020, 20:09

Après redémarrage à l'arrache tout fonctionne à nouveau même le renommage !!! Rien compris de ce qui s'est passé ! :shock:

Merci à toi ;)

Avatar de l’utilisateur
nouvo09
Messages : 2147
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: [Résolu] Connexion SSH vers serveur avec message d’erreur à l'ouverture de celui-ci

Message par nouvo09 » 15 février 2020, 22:03

Apparemment tu n'avais pas bien démarré: lorque tu as un prompt tel que: -bash-4.2$ c'est précisément soit que tu n'as pas de fichier bsh_profile, ce qui semble peu probable, soit que la machine a démarré en mode dépannage.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Répondre