De l'aide pour l'installation d'Apache...

Banahan
Messages : 4
Inscription : 05 octobre 2020, 10:25

De l'aide pour l'installation d'Apache...

Message par Banahan » 09 octobre 2020, 19:17

Bonjour,
Je suis tout nouveau à CentOS7.
J'ai 20 ans d'expérience sur serveur MacOSX, mais avec une utilisation assez faible du terminal.
J'ai un VPS avec CentOS7
Je veux installer Webdna sur un serveur Apache.
http://webdna.us/page.dna?numero=1025
J'avais installé Virtualmin, mais apparement Webdna ne reconnaissait pas l'Apache pour réaliser son installation avec Yum.
J'ai désinstallé Virtualmin.
Et en essayant de réinstaller Apache tout seule cela ne fonctionne pas...
[root@vm45-8 ~]# sudo yum update
...
[root@vm45-8 ~]# sudo yum install httpd
Modules complémentaires chargés : changelog, fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.rezopole.net
* centos-sclo-rh: ftp.rezopole.net
* centos-sclo-sclo: ftp.rezopole.net
* extras: ftp.rezopole.net
* updates: ftp.rezopole.net
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet httpd.x86_64 0:2.4.46-1.codeit.el7 sera installé
--> Traitement de la dépendance : httpd-tools = 2.4.46-1.codeit.el7 pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
--> Traitement de la dépendance : httpd-filesystem = 2.4.46-1.codeit.el7 pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
--> Traitement de la dépendance : mod_http2 pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
--> Traitement de la dépendance : httpd-filesystem pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
--> Traitement de la dépendance : libbrotlienc.so.1()(64bit) pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
--> Lancement de la transaction de test
---> Le paquet httpd.x86_64 0:2.4.46-1.codeit.el7 sera installé
--> Traitement de la dépendance : httpd-tools = 2.4.46-1.codeit.el7 pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
--> Traitement de la dépendance : libbrotlienc.so.1()(64bit) pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
---> Le paquet httpd-filesystem.noarch 0:2.4.46-1.codeit.el7 sera installé
---> Le paquet mod_http2.x86_64 0:1.15.16-1.codeit sera installé
--> Traitement de la dépendance : libnghttp2 >= 1.21.1 pour le paquet : mod_http2-1.15.16-1.codeit.x86_64
--> Traitement de la dépendance : libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) pour le paquet : mod_http2-1.15.16-1.codeit.x86_64
--> Traitement de la dépendance : libnghttp2.so.14()(64bit) pour le paquet : mod_http2-1.15.16-1.codeit.x86_64
--> Traitement de la dépendance : libcrypto.so.1.1()(64bit) pour le paquet : mod_http2-1.15.16-1.codeit.x86_64
--> Lancement de la transaction de test
---> Le paquet httpd.x86_64 0:2.4.46-1.codeit.el7 sera installé
--> Traitement de la dépendance : httpd-tools = 2.4.46-1.codeit.el7 pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
--> Traitement de la dépendance : libbrotlienc.so.1()(64bit) pour le paquet : httpd-2.4.46-1.codeit.el7.x86_64
---> Le paquet mod_http2.x86_64 0:1.15.16-1.codeit sera installé
--> Traitement de la dépendance : libnghttp2 >= 1.21.1 pour le paquet : mod_http2-1.15.16-1.codeit.x86_64
--> Traitement de la dépendance : libnghttp2.so.14()(64bit) pour le paquet : mod_http2-1.15.16-1.codeit.x86_64
---> Le paquet openssl111-libs.x86_64 0:1.1.1g-2.codeit.el7 sera installé
--> Résolution des dépendances terminée
Erreur : Paquet : mod_http2-1.15.16-1.codeit.x86_64 (CodeIT)
Requiert : libnghttp2 >= 1.21.1
Erreur : Paquet : httpd-2.4.46-1.codeit.el7.x86_64 (CodeIT)
Requiert : httpd-tools = 2.4.46-1.codeit.el7
Installé  : 1:httpd-tools-2.4.6-93.el7.vm.x86_64 (@virtualmin)
httpd-tools = 1:2.4.6-93.el7.vm
Disponible : httpd-tools-2.4.6-93.el7.centos.x86_64 (base)
httpd-tools = 2.4.6-93.el7.centos
Disponible : httpd-tools-2.4.41-4.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.41-4.codeit.el7
Disponible : httpd-tools-2.4.43-1.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.43-1.codeit.el7
Disponible : httpd-tools-2.4.43-2.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.43-2.codeit.el7
Disponible : httpd-tools-2.4.43-4.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.43-4.codeit.el7
Disponible : httpd-tools-2.4.43-5.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.43-5.codeit.el7
Disponible : httpd-tools-2.4.43-6.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.43-6.codeit.el7
Disponible : httpd-tools-2.4.43-7.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.43-7.codeit.el7
Disponible : httpd-tools-2.4.46-1.codeit.el7.x86_64 (CodeIT)
httpd-tools = 2.4.46-1.codeit.el7
Erreur : Paquet : httpd-2.4.46-1.codeit.el7.x86_64 (CodeIT)
Requiert : libbrotlienc.so.1()(64bit)
Erreur : Paquet : mod_http2-1.15.16-1.codeit.x86_64 (CodeIT)
Requiert : libnghttp2.so.14()(64bit)
Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest
[root@vm45-8 ~]# sudo systemctl start httpd
Failed to start httpd.service: Unit not found.
[root@vm45-8 ~]# sudo systemctl enable httpd
Failed to execute operation: No such file or directory

Que pensez vous que je dois je faire pour réussir cette install?
Merci d'avance
Lawrence

Avatar de l’utilisateur
nouvo09
Messages : 2195
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: De laide pour l'installation d'Apache...

Message par nouvo09 » 09 octobre 2020, 21:12

Code : Tout sélectionner

Installé  : 1:httpd-tools-2.4.6-93.el7.vm.x86_64 (@virtualmin)
la réponse est là.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Banahan
Messages : 4
Inscription : 05 octobre 2020, 10:25

Re: De laide pour l'installation d'Apache...

Message par Banahan » 10 octobre 2020, 11:28

Merci pour ce retour.
Du coup j'ai fait : yum remove httpd-tools.x86_64
et obtenu
Supprimé :
httpd-tools.x86_64 1:2.4.6-93.el7.vm
Terminé !

j'ai ensuite fait :
yum list installed
&
rpm -qa
Les seul paquet avec http dedans sont du perl

ensuite j'ai refait :
sudo yum install httpd
j'obtient
Erreur : Paquet : mod_http2-1.15.16-1.codeit.x86_64 (CodeIT)
Requiert : libnghttp2 >= 1.21.1
Erreur : Paquet : mod_http2-1.15.16-1.codeit.x86_64 (CodeIT)
Requiert : libnghttp2.so.14()(64bit)
Erreur : Paquet : httpd-2.4.46-1.codeit.el7.x86_64 (CodeIT)
Requiert : libbrotlienc.so.1()(64bit)
Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest

Est ce que je dois installer ces paquets indépendamment?

j'ai essayé de lancer Apache et libnghttp2 et j'obtient toujours:

[root@vm45-8 ~]# sudo systemctl start httpd
Failed to start httpd.service: Unit not found.
[root@vm45-8 ~]# sudo service httpd status
Redirecting to /bin/systemctl status httpd.service
Unit httpd.service could not be found.

Lors de l'install de libnghttp2
[root@vm45-8 ~]# yum install libnghttp2
j'obtient :
Some packages in your transaction are brought to you by GetPageSpeed:
- libnghttp2-1.40.0-1.el7.x86_64
To enable package installs, subscribe using the following link:

https://www.getpagespeed.com/repo-subsc ... .182.6.242

Ce lien me demande 10€/mois...

Lorsque je retente de lancer Apache j'obtiens toujours

[root@vm45-8 ~]# sudo service httpd status
Redirecting to /bin/systemctl status httpd.service
Unit httpd.service could not be found.

Merci d'avance pour votre aide...

Avatar de l’utilisateur
nouvo09
Messages : 2195
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: De laide pour l'installation d'Apache...

Message par nouvo09 » 10 octobre 2020, 12:08

J'ai un VPS avec CentOS7
que renvoie la commande

uname -a

?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Banahan
Messages : 4
Inscription : 05 octobre 2020, 10:25

Re: De laide pour l'installation d'Apache...

Message par Banahan » 10 octobre 2020, 12:10

Voila

[root@vm45-8 ~]# uname -a
Linux vm45-8.hosteur.net 3.10.0-1127.19.1.el7.x86_64 #1 SMP Tue Aug 25 17:23:54 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Avatar de l’utilisateur
nouvo09
Messages : 2195
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: De laide pour l'installation d'Apache...

Message par nouvo09 » 10 octobre 2020, 12:26

Tu dois avoir
- soit un centos7 customisé par ton hébergeur
- soit un mélange du aux différentes installations que tu as faites

en effet je ne vois le paquet réclamé que pour centos8
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Banahan
Messages : 4
Inscription : 05 octobre 2020, 10:25

Re: De laide pour l'installation d'Apache...

Message par Banahan » 10 octobre 2020, 12:34

Je suis chez Hosteur, je ne sais pas si ils customisent...
>>- soit un mélange du aux différentes installations que tu as faites
Je n'ai que mis Virtualmin et ensuite enlevé.

Pourquoi CentOS8, je veux rester en 7 (à cause de Webdna que je veux installer)

J'ai essayé de suivre https://www.linuxhelp.com/how-to-comple ... centos-7-6
Mais j'ai toujours cette demande

---> Le paquet openssl111-libs.x86_64 0:1.1.1h-1.codeit.el7 sera installé
--> Résolution des dépendances terminée
=======================================================================
Some packages in your transaction are brought to you by GetPageSpeed:
- libnghttp2-1.40.0-1.el7.x86_64
To enable package installs, subscribe using the following link:

https://www.getpagespeed.com/repo-subsc ... .182.6.242
=======================================================================


Exiting because subscription is missing

Avatar de l’utilisateur
nouvo09
Messages : 2195
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: De laide pour l'installation d'Apache...

Message par nouvo09 » 10 octobre 2020, 23:09

Apparemment pour une raison que toi seul connais, tu es allé chercher des paquets sur le dépôt codeit.guru.

Ces paquets entrent en conflit avec les composants standards des dépôts Centos.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Répondre