[Résolu] problème serveur web owncloud

iochy
Messages : 32
Inscription : 16 août 2014, 01:50

[Résolu] problème serveur web owncloud

Message par iochy » 26 juillet 2016, 19:42

Bonjour à tous,

je viens vous demander de l'aide car je rencontre quelque souci avec mon serveur Owncloud hébergé sur un dédié Kimsufi.
J'ai migré vers un autre serveur, l'ancien utilisé du HTTPS.
La migration c'est bien passé (à part que j'ai du désactiver SELinux, sans comprendre pourquoi...), en HTTP j'ai pu me connecter au serveur et vérifier que les données étaient bien transférées. Pour passer en HTTPS cet fois avec Let's Encrypt, je dois configurer mon fichier de conf en virtualhost.

mes fichiers de conf sont dans "/etc/httpd/conf.d/"
Mon fichier de conf d’origine :

Code : Tout sélectionner

Alias /owncloud "/var/www/html/owncloud/"
<Directory "/var/www/html/owncloud">
  Options +FollowSymLinks
#  AllowOverride All

  <IfModule mod_dav.c>
        Dav off
  </IfModule>

  SetEnv HOME /var/www/html/owncloud
  SetEnv HTTP_HOME /var/www/html/owncloud
</Directory>

<Directory "/var/www/html/owncloud/data/">
  # just in case if .htaccess gets disabled
    Require all denied
</Directory>
Mon fichier modifié :

Code : Tout sélectionner

<VirtualHost *:80>
        ServerName www.mondomaine.fr/owncloud
        ServerAlias mondomaine.fr/owncloud
        DocumentRoot /var/www/html/owncloud
        ErrorLog /var/log/httpd/error-owncloud.log
        CustomLog /var/log/httpd/request-owncloud.log combined

<Directory "/var/www/owncloud/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Require all granted
</Directory>
</VirtualHost>

Maintenant je me retrouve avec une page blanche avec un fichier de conf PHP :

Code : Tout sélectionner

<?php
/**
 * @author Jörn Friedrich Dreyer <jfd@butonic.de>
 * @author Lukas Reschke <lukas@owncloud.com>
 * @author Morris Jobke <hey@morrisjobke.de>
 * @author Robin Appelman <icewind@owncloud.com>
 * @author Thomas Müller <thomas.mueller@tmit.eu>
 * @author Vincent Petry <pvince81@owncloud.com>
 *
 * @copyright Copyright (c) 2015, ownCloud, Inc.
 * @license AGPL-3.0
 *
 * This code is free software: you can redistribute it and/or modify
 * it under the terms of the GNU Affero General Public License, version 3,
 * as published by the Free Software Foundation.
 *
 * This program is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
 * GNU Affero General Public License for more details.
 *
 * You should have received a copy of the GNU Affero General Public License, version 3,
 * along with this program.  If not, see <http://www.gnu.org/licenses/>
 *
 */

// Show warning if a PHP version below 5.4.0 is used, this has to happen here
// because base.php will already use 5.4 syntax.
if (version_compare(PHP_VERSION, '5.4.0') === -1) {
	echo 'This version of ownCloud requires at least PHP 5.4.0<br/>';
	echo 'You are currently running ' . PHP_VERSION . '. Please update your PHP version.';
	return;
}

try {
	
	require_once 'lib/base.php';

	OC::handleRequest();

} catch(\OC\ServiceUnavailableException $ex) {
	\OCP\Util::logException('index', $ex);

	//show the user a detailed error page
	OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
	OC_Template::printExceptionErrorPage($ex);
} catch (\OC\HintException $ex) {
	OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
	OC_Template::printErrorPage($ex->getMessage(), $ex->getHint());
} catch (Exception $ex) {
	\OCP\Util::logException('index', $ex);

	//show the user a detailed error page
	OC_Response::setStatus(OC_Response::STATUS_INTERNAL_SERVER_ERROR);
	OC_Template::printExceptionErrorPage($ex);
}
Même en remettant l'ancien fichier de conf je me retrouve avec le même message d'erreur, je ne comprends pas pourquoi.
edit : sans rien touché, avec le fichier de conf d'origine la page de connexion est revenu. Mais il me reste à faire marcher en mode "virtualhost".
Si quelqu'un peut me guider.

Merci pour votre aide.
Dernière modification par iochy le 27 juillet 2016, 23:30, modifié 1 fois.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème serveur web owncloud

Message par Beta-Pictoris » 26 juillet 2016, 23:12

Les 2 directives suivantes ne ciblent pas le même répertoire:

Code : Tout sélectionner

 DocumentRoot /var/www/html/owncloud
 
<Directory "/var/www/owncloud/">

iochy
Messages : 32
Inscription : 16 août 2014, 01:50

Re: problème serveur web owncloud

Message par iochy » 26 juillet 2016, 23:29

Bonsoir merci à toi,
En effet, j'ai du m'enméler les doigts à un moment ...
Mais le problème ne vient pas de là, j'ai essayé en supprimant cette partie, mais ça ne marche pas mieux.
Voici mon fichier owncloud.conf actuel :

Code : Tout sélectionner

<VirtualHost *:80>
        ServerName mondomaine.fr/owncloud
#       ServerAlias mondomaine.fr/owncloud
        DocumentRoot /var/www/html/owncloud
        ErrorLog /var/log/httpd/error-owncloud.log
        CustomLog /var/log/httpd/request-owncloud.log combined
</VirtualHost>
Par exemple en utilisant le fichier ci-dessus, je configure le fichier "/etc/httpd/conf/httpd.conf" pour qu'il récupère les fichiers de conf dans conf.d :

Code : Tout sélectionner

IncludeOptional conf.d/*.conf
Le site marche, mais si je prends ce même fichier et que je configure "/etc/httpd/conf/httpd.conf" pour aller dans site-enabled

Code : Tout sélectionner

IncludeOptional sites-enabled/*.conf
Là le site me renvois la page blanche avec le code PHP

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème serveur web owncloud

Message par Beta-Pictoris » 27 juillet 2016, 00:07

Si tu remplaces ton fichier index.php par un fichier html, est-ce que ça marche mieux ?

As tu essayé d'accéder à ton site de cette façon ? : http://mondomaine.fr/owncloud/index.php

iochy
Messages : 32
Inscription : 16 août 2014, 01:50

Re: problème serveur web owncloud

Message par iochy » 27 juillet 2016, 00:27

Mon fichier index.php est dans "/var/www/html/owncloud/"
Au même endroit, j'ai déjà un fichier index.html qui contient :

Code : Tout sélectionner

<!DOCTYPE html>
<html>
<head>
        <script type="text/javascript"> window.location.href="index.php"; </script>
        <meta http-equiv="refresh" content="0; URL=index.php">
</head>
</html>
Je dois désactiver les 2 fichiers et renomer index.php en index.html ?

J'ai essayé plusieurs adresse dans le navigateur, "mondomaine.fr" ; "mondomaine.fr/owncloud/" ; "mondomaine.fr/owncloud/index.php"
A chaque fois j'ai la même page.

Si je tape directement "mondomaine.fr", je suis redirigé vers "mondomaine.fr/index.php"

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème serveur web owncloud

Message par Beta-Pictoris » 27 juillet 2016, 01:44

Le but est de vérifier que les pages html (sans php) s'affichent, déjà, correctement.
Renomme tes fichiers index en .old et crée un fichier index.html tout simple et redémarre ton serveur.

iochy
Messages : 32
Inscription : 16 août 2014, 01:50

Re: problème serveur web owncloud

Message par iochy » 27 juillet 2016, 08:58

Voilà ce que j'ai testé

Code : Tout sélectionner

mv index.php index.php.org
mv index.html index.html.org
touch index.html
systemctl restart httpd
Dans le navigateur si je tape :
mondomaine.fr => la page blanche PHP
mondomaine.fr/index.php => Not Found The requested URL /index.php was not found on this server.
mondomaine.fr/owncloud/index.php => la page blanche PHP

Actuellement j'ai remis le fichier de conf d'origine, ça ne marche toujours pas. Je ne comprends pas pourquoi en remettant le fichier d'origine je reste sur la même erreur ?

Code : Tout sélectionner

Alias /owncloud "/var/www/html/owncloud/"
<Directory "/var/www/html/owncloud">
  Options +FollowSymLinks
#  AllowOverride All

  <IfModule mod_dav.c>
        Dav off
  </IfModule>

  SetEnv HOME /var/www/html/owncloud
  SetEnv HTTP_HOME /var/www/html/owncloud
</Directory>

<Directory "/var/www/html/owncloud/data/">
  # just in case if .htaccess gets disabled
    Require all denied
</Directory>

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème serveur web owncloud

Message par Beta-Pictoris » 27 juillet 2016, 14:16

Code : Tout sélectionner

touch index.html
systemctl restart httpd
Tu dois mettre quelque chose dans ton fichier index.html, par exemple, un message simple en texte pour vérifier qu'il s'affiche.

iochy
Messages : 32
Inscription : 16 août 2014, 01:50

Re: problème serveur web owncloud

Message par iochy » 27 juillet 2016, 15:27

Alors depuis mon téléphone c'est pas simple ;)
Mais je suis arrivé à faire un écho bonjour > /var/www/html/owncloud/index.html

J'ai redémarré httpd mais depuis mon téléphone rien ne s'affiche, la barre de chargement s'arrête au 1/4. Httpd est bien démarré.

PS : je viens de t'envoyer un MP

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème serveur web owncloud

Message par Beta-Pictoris » 27 juillet 2016, 15:43

Tu as remis ton fichier virtualhost avec le directive "Directory" corrigée ?

Teste, directement, sur ton serveur avec lynx.

Regarde, aussi, dans les fichiers de logs

Répondre