Page 2 sur 2

Re: problème serveur web owncloud

Publié : 27 juillet 2016, 15:49
par Beta-Pictoris
Ok, je viens de voir ton site dans mes MP. Ça marche en html avec ce lien: http://mondomaine.fr/owncloud/index.html

Donc, le problème doit venir de php. Remets ton fichier php.
Tu devrais ajouter la directive suivante dans ton virtualhost et redémarrer ton serveur.

Code : Tout sélectionner

php_admin_flag engine on

Re: problème serveur web owncloud

Publié : 27 juillet 2016, 18:39
par iochy
Alors mon fichier virtualhost :

Code : Tout sélectionner

<VirtualHost *:80>
        ServerName mondomaine.fr/owncloud
#       ServerAlias mondomaine.fr/owncloud
        DocumentRoot /var/www/html/owncloud
        php_admin_flag engine on
        ErrorLog /var/log/httpd/error-owncloud.log
        CustomLog /var/log/httpd/request-owncloud.log combined
</VirtualHost>
Même après reboot du serveur, j'ai toujours le même message.
PS : je ne comprend pas un truc, quand je supprime le fichier "index.html" contenant le "bonjour" et que je remet les fichiers "index.php" et "index.html" d'origine, si je tape l'adresse "mondomaine.fr/owncloud/index.html" j'ai toujours le "bonjour" d'affiché ! même quand le service httpd est stoppé !!

Re: problème serveur web owncloud

Publié : 27 juillet 2016, 19:01
par Beta-Pictoris
Tu dois vider le cache de ton navigateur.

Re: problème serveur web owncloud

Publié : 27 juillet 2016, 19:50
par iochy
Oui pas faux pour pour le cache, j'ai fais mon noob ...

Bon la ça fonctionne avec le virtualhost.
par contre pourquoi à chaque fois je mets tout en vrac quand je configure le apache pour aller chercher ce même fichier dans un répertoire "site-enabled" ...

Je crois que comme ce serveur ne vas pas héberge rgrand chose d'autre je vais rester ainsi non ?

Re: problème serveur web owncloud

Publié : 27 juillet 2016, 20:05
par Beta-Pictoris
Après une modification, tu devrais arrêter apache et vérifier que des processus httpd ne continuent pas de tourner:

Code : Tout sélectionner

pgrep -l httpd
Cela dit, si ça marche, tu peux mettre "[Résolu]" dans le titre. :)

Re: problème serveur web owncloud

Publié : 27 juillet 2016, 23:29
par iochy
J'avais vérrifier les process après avoir stoppé apache, avec un "ps -ef | grep httpd"
Merci pour ton aide.