HTTPD - DocumentRoot - non pris en compte

Avatar de l’utilisateur
remi
Messages : 211
Inscription : 20 octobre 2009, 07:10
Localisation : Champagne...
Contact :

Re: HTTPD - DocumentRoot - non pris en compte

Message par remi » 27 novembre 2016, 13:58

Il faut vérifier les droits de "tous" les niveaux de l'arborescence

Code : Tout sélectionner

ls -ld /mnt
ls -ld /mnt/raid
ls -ld /mnt/raid/data
ls -ld /mnt/raid/data/web
Et ajuster pour que "apache" puisse traverser (x) les niveaux supérieurs et lire (r-x) le dernier
Contributeur EPEL et CentOS SCLo SIG
Des RPM pour CentOS sur https://rpms.remirepo.net

Nox
Messages : 12
Inscription : 27 novembre 2016, 10:35

Re: HTTPD - DocumentRoot - non pris en compte

Message par Nox » 27 novembre 2016, 14:26

Voilà ce que j'ai

Code : Tout sélectionner

ls -ld /mnt/
drwxr-xr-x. 3 root root 17 27 nov.  10:46 /mnt/
ls -ld /mnt/raid
drwxr-xr-x. 4 root root 4096 27 nov.  10:57 /mnt/raid
ls -ld /mnt/raid/data
drwxr-xr-x. 3 root root 4096 27 nov.  10:57 /mnt/raid/data
ls -ld /mnt/raid/data/web/
drwxr-xr-x. 2 root root 4096 27 nov.  10:57 /mnt/raid/data/web/
Je mets chown et chgrp apache pour le dernier ?

Beta-Pictoris
Messages : 953
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: HTTPD - DocumentRoot - non pris en compte

Message par Beta-Pictoris » 27 novembre 2016, 15:06

Tu peux, au moins, changer le groupe:

Code : Tout sélectionner

chgrp -R  apache /mnt/raid/data/web
Par contre, tu laisseras les permissions du groupe en 'r-x'.
Pas la peine de donner des droits en écriture à apache.

As-tu ajouté les directives suivantes dans ton fichier de configuration apache ? :

Code : Tout sélectionner

DocumentRoot /mnt/raid/data/web

<Directory /mnt/raid/data/web>
    AllowOverride None
    Require all granted
</Directory>

Nox
Messages : 12
Inscription : 27 novembre 2016, 10:35

Re: HTTPD - DocumentRoot - non pris en compte

Message par Nox » 27 novembre 2016, 17:37

Code : Tout sélectionner

chgrp -R  apache /mnt/raid/data/web
ls -ld /mnt/raid/data/web/
drwxr-xr-x. 2 root apache 4096 27 nov.  10:57 /mnt/raid/data/web/
J'ai egalement ceci

Code : Tout sélectionner

ls -la /mnt/raid/data/web/
total 12
drwxr-xr-x. 2 root apache 4096 27 nov.  10:57 .
drwxr-xr-x. 3 root root   4096 27 nov.  10:57 ..
-rw-r--r--. 1 root apache   10 27 nov.  10:57 index.html
Dans mon fichier de config j'ai ceci

Code : Tout sélectionner

# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/mnt/raid/data/web"

#
# Relax access to content within /var/www.
#
<Directory "/mnt/raid/data/web">
    AllowOverride None
    # Allow open access:
    Require all granted
</Directory>
Je n'ai modifier que la partie : DocumentRoot

Nox
Messages : 12
Inscription : 27 novembre 2016, 10:35

Re: HTTPD - DocumentRoot - non pris en compte

Message par Nox » 27 novembre 2016, 17:45

FOUND IT ..... :D Punaise ...

J'ai fais ceci

Test de SELINUX

Code : Tout sélectionner

getenforce
"Enforcing"
Mis en Permissif

Code : Tout sélectionner

setenforce 0
"Permissive"
Check .... ça fonctionne :)

Je vais réinstaller une dernière fois pour valider ça :).

Un grand merci pour votre aide et vos reponses, c'est cool.

Nox
Messages : 12
Inscription : 27 novembre 2016, 10:35

Re: HTTPD - DocumentRoot - non pris en compte

Message par Nox » 27 novembre 2016, 19:24

bon j'ai fait une réinstallation complète de base

voici le deroulé de ce que j'ai fais

Code : Tout sélectionner

yum update
yum httpd
firewall-cmd --permanent --add-port=80/tcp
firewall-cmd --permanent --add-port=443/tcp
firewall-cmd --reload
yum nano
nano /etc/httpd/conf/httpd.conf
Dans Documentroot : /MON/NOUVEAU/DOC/ROOT
setenforce 0
systemctl start httpd
systemctl enable httpd
et c'est bon :)

Avatar de l’utilisateur
nouvo09
Messages : 1839
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: HTTPD - DocumentRoot - non pris en compte

Message par nouvo09 » 28 novembre 2016, 13:26

setenforce 0
1) cette commande ne modifie pas de manière permanente la configuration de SElinux

2) si ton serveur est destiné à être accédé depuis l'extérieur, c'est une mauvaise idée. Dans ce cas, vérifie que setroubleshootd est bien installé, active-le s'il ne l'est pas et remets le statut de SElinux à permissive.
De cette manière SElinux sera actif sans bloquer les accès et tu seras alerté sur les anomalies que tu pourras corriger avant de le repasser sur Enforcing.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Nox
Messages : 12
Inscription : 27 novembre 2016, 10:35

Re: HTTPD - DocumentRoot - non pris en compte

Message par Nox » 28 novembre 2016, 16:22

merci je vais regler cela :)

Répondre