Page 1 sur 2

HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 10:43
par Nox
Bonjour,

Voila un grand moment que je seche sur la question :(
Je suis immediatement desolé si mon probleme est dit 12milles fois et que c'est simple .... mais je m'en remets a vous. je n'en peu plus et je ne comprend pas. j'ai je pense avoir tout essayer .....

Je vous explique c'est tres con.

Installation toute fraiche de Centos 7
Package de Base donc tout a installer à la main
installation de httpd
--- Test : Ok
--- Test : index.html dans /var/www/html : Ok
Installation de Php7
--- Ok
Montage RAID6 avec Mdadm : OK
Creation d'un point de montage : /mnt/raid/Web : OK

access lecture ecriture ssh : OK
Instalaltion de pure-FTPd : OK
Document root d'un User FTP dans /mnt/raid/Web : OK
test connexion Filezilla : OK.

Bon jusque la on est bien :)

Voila le souci

Nano /etc/httpd/conf/httpd.conf

Modiffication du Documentroot : /mnt/raid/Web

Test de connexion : KO j'ai la fenetre d'apache par defaut disant BROVO c'est installer.

J'ai desactive SElinux
J'ai pour test biensur et en dernier recours fait un truc a pas faire :p chmod 777 sur /mnt/raid/Web
j'ai regarder les droit d'acces : j'ai mis apache:apache pour /Web

rien n'y fait :(

Je precise que je suis un bon debutant en linux.

Merci pour votre aide.

Desolé si ce n'est pas la bonne rubrique ou si je dis n'importe quoi :(.

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 11:09
par Beta-Pictoris
As tu vidé le cache de ton navigateur web et redémarré apache ?
As tu mis un fichier index.html ou index.php dans /mnt/raid/Web ? A moins que tu essayes d'afficher le contenu du répertoire dans ton navigateur web ?

Comment as tu fait pour installer php7 ?

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 11:21
par Nox
Hello, Merci pour le retour rapide :)

Alors :
- J'ai vidé mon cache par le biais de Ctrl+F5.
Sachant que lorsque je remet le Documentroot par defaut cela fonctionne tout de suite.

- Php7 : https://blog.remirepo.net/post/2016/02/ ... HEL-CentOS
j'ai suivi le Tuto et tout passe bien. cependant actuellement j'ai Php5 par défaut.

- il y a dans /mnt/raid/Web un fichier HTML (le même que dans /var/www/html)

Je me rappel plus comment j’avais fait la première fois pour que tout fonctionne bien, et je dois dire que je ne m’étais pas autant embêté ...

merci

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 11:38
par remi
Modifier DocumentRoot est clairement insuffisant, il y a plein d'autres endroits ou /var/www apparait dans le fichier de configuration, en particulier les droits par défaut.

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 11:47
par Nox
Je viens de reprendre a Zero ma config, une reinstallation complete est en cours.

J'ai fait une installation a partir de Centos DVD
J'ai coché : Serveur Web dans les package.

L’installation viens tout juste de se terminer.
Dans la journée je vais remonter mon Raid, refaire les partages et Voir de plus pret le fichier de config httpd.

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 12:00
par Nox
Raid : Ok
Sync en cours

Pourquoi je precise que je fais du RAID ? juste pour des histoires de droit. Je ne sais pas si sur un montage raid soft, mes dossiers on les memes droits que sur des disques Physique

J'ai mis en pratique ceci : https://devops.profitbricks.com/tutoria ... -centos-7/
Sachant que httpd, php et mysql sont deja installer par defaut.
j'ai ouvert les ports
j'ai créer un fichier index.html avec le message "TEST" dedans
j'ai désactivé SElinux
J'ai relancer le serveur et j'ai activé le serveur a chaque boot.
test : http://IPLOCALCENTOS --> OK
test : https://IPLOCALCENTOS --> Ok
La meme chose en externe.

Je vois maintenant pour modifier mon httpd.conf dans /etc/httpd/conf/httpd.conf.

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 12:06
par Nox
Apres avoir modifier tout ce que j'avais
de
/var/www & /var/www/html
en
/mnt/raid/web

Lorsque je fais des test sur http://IPLOCALCENTOS --> KO
cela me redonne la page Welcome.conf ....

est-ce que je epux regarder quelque part d'autre ? :(

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 12:27
par Nox
dans error.log j'ai ceci

Code : Tout sélectionner

AH00035: access to /index.html denied (filesystem path '/mnt/raid/data/web/index.html') because search permissions are missing


:) oui mais voila je ne sais pas quoi faire pour les permissions ....

Je vous laisse tranquille je ne veux pas vous embêter trop longtemps pour ce week-end :p.

si vous avais une idée en passant faites moi signe :) sinon j'attendrai Lundi :).

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 12:37
par Beta-Pictoris
Nox a écrit :

Code : Tout sélectionner

AH00035: access to /index.html denied (filesystem path '/mnt/raid/data/web/index.html') because search permissions are missing
/mnt/raid/data/web ou /mnt/raid/web ? Vérifie le chemin exact.
Vérifie aussi les droits sur tes répertoires et fichiers.

Re: HTTPD - DocumentRoot - non pris en compte

Publié : 27 novembre 2016, 13:22
par Nox
Chemin exact /mnt/raid/data/web.

Comment puis-je faire pour contrôler mes droit.

Sortie de ls -l je ne sais pas faire autre chose.